[Solved] RAK831 setup working somewhere?


As I can at least post in that forum, I’d like to know if someone has succeeded to install recently a RAK831 system with Pi3B+ as TTN gateway ? I followed the pretty outdated tuto on TTN blog and also that one listed in forum https://www.thethingsnetwork.org/labs/story/rak831-lora-gateway-from-package-to-online but both fails miserably :frowning:
Is there an up-to-date tuto somewhere I can be pointed too ? as I’m losing patience trying all tutos I can find till one hopefully works !

Thanks for advices,


If you have a problem with RAK products please ask at their support forum

Have you used the instructions on the TTN documentation site? Just substitute resin.io with balena.io as they renamed their service some time ago.

My problem is not with RAK products but how to setup TTN on it :wink:

Yep first tuto I have tried but failed, it never succeeded to connect at TTN network due to some SSL problems unless the PI has well a full internet connectivity ! I have tried too to setup variables indicated in tuto in both variables categories that exist in Balena as none has same name as in the tuto but not more success :frowning:

If you want help with the setup it helps if you provide more details like log information. Just saying your car doesn’t drive won’t help a mechanic solve the issue, the same applies for us as we’re unable to see what happens. (Or you need to share that particular application in the balena console with me so I can take a look and try to help you out.)

Are you using the legacy packet forwarder UDP connection? I wouldn’t expect SSL to be involved unless you are using some more recent sort of connection.

How would you expect it to work without Internet connectivity?

Its difficult for TTN, which is a free to use service, to provide free support for all 3rd party products

Yep for sure for logs, I fully agree for you but as I had tried an other setup in meantime, I have no more these ! I’ll redo the setup this way tomorrow and share my results here about failure if it fails again, or will let you know too if it works fine this time (perhaps missed a step or made an error somewhere !) !

If I remember well it was indicated in setup not to tick that option but as indicated will attempt that setup again tomorrow and share results here :wink:
thanks @cslorabox and @kersing for offer of help :wink:

Here is updated information about attempt to setup my gateway with RAK831 et Pi3B+. I get same results as yesterday unhappy. Everything goes fine till I fill the details of my gw setup in TTN console in Balena dashboard. The app in PI3B+ restarts well to apply values filled and then get errors as below. I have just obfuscated the GW EUI as not sure it should be publicly shared !

Thanks for help and if you need more infos let me know :wink:


14.07.19 12:52:42 (+0200) Killing service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:52:42 (+0200) Killed service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:52:43 (+0200) Installing service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:52:43 (+0200) Installed service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:52:44 (+0200) Starting service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:52:45 (+0200) Started service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:52:45 (+0200) *** Resin Machine Info:
14.07.19 12:52:45 (+0200) *** Type: None
14.07.19 12:52:45 (+0200) *** Arch: None
14.07.19 12:52:45 (+0200) *******************
14.07.19 12:52:45 (+0200) *** Configuration:
14.07.19 12:52:45 (+0200) *******************
14.07.19 12:52:45 (+0200) GW_EUI: XXXXXXXX
14.07.19 12:52:45 (+0200) Enabling TTN gateway connector
14.07.19 12:52:45 (+0200) *******************
14.07.19 12:52:45 (+0200) *** Fetching config from TTN account server
14.07.19 12:52:45 (+0200) *******************
14.07.19 12:52:45 (+0200) <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:727)>
14.07.19 12:52:45 (+0200) Unable to fetch configuration from TTN. Is the TTN API reachable from gateway? Are your GW_ID and GW_KEY correct? Retry in 30s
14.07.19 12:52:57 (+0200) Killing service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:53:09 (+0200) Service exited ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:53:09 (+0200) Killed service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:53:10 (+0200) Installing service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:53:11 (+0200) Installed service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:53:11 (+0200) Starting service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:53:13 (+0200) Started service ‘main sha256:eb26dd8474625f9c84d833520709d6af99a85b77f3e18a73de33e1fd93f2c49a’
14.07.19 12:53:13 (+0200) *** Resin Machine Info:
14.07.19 12:53:13 (+0200) *** Type: None
14.07.19 12:53:13 (+0200) *** Arch: None
14.07.19 12:53:13 (+0200) *******************
14.07.19 12:53:13 (+0200) *** Configuration:
14.07.19 12:53:13 (+0200) *******************
14.07.19 12:53:13 (+0200) GW_EUI: XXXXXXXX
14.07.19 12:53:13 (+0200) Enabling TTN gateway connector
14.07.19 12:53:13 (+0200) *******************
14.07.19 12:53:13 (+0200) *** Fetching config from TTN account server
14.07.19 12:53:13 (+0200) *******************
14.07.19 12:53:13 (+0200) <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:727)>
14.07.19 12:53:13 (+0200) Unable to fetch configuration from TTN. Is the TTN API reachable from gateway? Are your GW_ID and GW_KEY correct? Retry in 30s

Hum while looking for a solution at my problem I found a lot easier way to setup the gateway ! RAKWireless offers a ready to use image for Pi 3B+ and in few minutes and very easily I had my gateway active and running !
For people wanting to use RAKWireless hardwares, don’t bother with outdated tutos available on TTN websit, just go on RAKWireless website to download the image for your hardware and follow their very simple and easy document to setup the image and in 5 minutes you are running :wink:
So one more TTN gateway is now active (in an area where nearest Lora network is 100km away !) !

Outdated because of a change that happened to the balena images a couple of days ago where I’m am working on fixing it. May-be you shouldn’t be so harsh in your judgment?

[Edit] The TTN account server does not provide the intermediate certificate to clients connecting and as a result the client can’t validate the server certificate. Now the question is why this happens…
@htdvisser have there been changes that could result in TTN no longer providing the immediate certificate? For instance while fixing the security issue last week?

Welcome to the club of gateway owners. :slight_smile:

There have been no changes to TLS. Also, when I connect to the account server, I see the full chain:

% openssl s_client -connect account.thethingsnetwork.org:443                                                    [1]
depth=2 O = Digital Signature Trust Co., CN = DST Root CA X3
verify return:1
depth=1 C = US, O = Let's Encrypt, CN = Let's Encrypt Authority X3
verify return:1
depth=0 CN = account.thethingsnetwork.org
verify return:1
Certificate chain
 0 s:/CN=account.thethingsnetwork.org
   i:/C=US/O=Let's Encrypt/CN=Let's Encrypt Authority X3
 1 s:/C=US/O=Let's Encrypt/CN=Let's Encrypt Authority X3
   i:/O=Digital Signature Trust Co./CN=DST Root CA X3

not only Balena stuffs :wink: To help you update the tuto, here are things that needs to be updated in it that I noticed while using it:

  • as you told, update all resin stuffs to become balena ones
  • perhaps indicate when you “add” device that you can select also the option of Wifi if your raspberry is getting internet access through Wifi no ?
  • extract content of zip downloaded from Balena is useless as Etcher is taking care of that automatically
  • Your part about Etcher for Windows and Mac is also good for Linux (no need to go with DD and all these command line stuffs)
  • Update the part about Environment variables to reflect the updated web interface of Balena

I’ll publish too a story about how I have succeeded to setup it with RAK tools as it can be interesting too (different way to reach same result :wink:

Thanks :slight_smile: now next step succeed to get some Lora devices to connect to it and transmit datas !

Hi Vincen, since I had the same problem as you and I’m not able to fix it could you pass the link of the tutorial/guide you used to put your gateway with raspberry pi3b in motion.


Unhappy looks like the tuto is no more there :frowning: It was on Rakwireless website: RAKwireless Downloads but perhaps asking support you can get a copy of it. Don’t forget that if your gw is not already registered in TTN V2 it’s completely useless now as you can no more register gw in TTN V2 since 1st June/July :frowning:

OK, anyway, thank you very much.

Wrong - just register under V3! And if previously registered in V2 some details can still be amended even if system read only so may be poss to get it online as a correction… depends on what root cause of issue is. Personally would just get latest build instructions and go straight to V3…do not pass go do not collect £200/$200/€200 or whatever on local Monopoly Money…