Tenant with ID ttN error

Hello all,

Following the instructions as per the quick start on the Generic Node page.

I already have a number of devices registered to the application I’m registering this node under but am suddenly getting this error. Any help would be greatly appreciated: I’ve not had this error with any other device before.

I’ve researched the error but don’t really understand what the issue is: I’m logged in no problem, set to the right location…

`Preformatted text`{
  "code": 5,
  "message": "error:pkg/identityserver/store:tenant_not_found (tenant with id `ttn` not found)",
  "details": [
      "@type": "type.googleapis.com/ttn.lorawan.v3.ErrorDetails",
      "namespace": "pkg/identityserver/store",
      "name": "tenant_not_found",
      "message_format": "tenant with id `{tenant_id}` not found",
      "attributes": {
        "tenant_id": "ttn"
      "correlation_id": "d2b08afc993744e8aa150806877bd273",
      "code": 5
}`Preformatted text`

Please can you format the JSON (and serial logs & code etc) with the </> tool

What method did you use to register the device?

Hi Nick,

All of the methods mentions: QR code, manual and the device repo method.



At which point do they all bring up the same error message?

Try to be more expansive - otherwise it may take dozens of questions before we get enough info.

Hi Nick,

all brought up during the registering device. It appears when I hit Register End Device.

I believe it must be an issue with my account/profile (I’m using the community ed) because I solved it by creating a whole new account. Not ideal but it’s just a workaround for the moment.

1 Like