The Things Kickstarter Gateway Firmware v1.0.9

Hello everyone, we just released a new firmware for The Things Kickstarter Gateway.

The v1.0.9 firmware replaces the expired DST Root CA X3 with the DigiCert Global Root G2 that Microsoft Azure will begin using soon.

This firmware has been pushed to the stable and beta over-the-air update channels, so most gateways will update to the new firmware somewhere in the next 24 hours.

For manual installation of the new firmware, see the instructions on GitHub.

4 Likes

Might be also worth updating the TTI docs page here
https://www.thethingsindustries.com/docs/gateways/thethingskickstartergateway/
To add recommendation to move on from 1.0.8 once registered to correct for the CA?

….that reminds me TTKGW new users or people revisiting old setup for a TKGW following ttn.fyi/activate link end up directed to that page…. = GOOD! Problem is users of Things Nodes are told to follow same link and up in same place = BAD! (ESP as no onward link to correct Node set up per note 4. In the shipped quick start leaflet . 4. Continue with the steps as described in the illustrated guide quick start guide for The Things Node found on https://ttn.fyi/activate.

Can you update page to at least show a Node docs link?

1 Like

Dear Hylke,

Thanks for your work!

Is there a reason why the suggested changes in the firmware (pull requests on github) are not taken into account?
Reason I am asking is that since a certain update of TTN V3 I had connection problems with my gateway, which I did not have before. If the gateway lost its connection it would not reconnect (3 flashing blue LEDs). This could only be solved by removing power. This happened at least once a week. I thought of stopping with this gateway.

But I contacted the programmer of the pull requests (Daniel Kucera) and he gave me his version. This worked flawless for one year, until today (again blue LEDs flashing). And I discoverded the gateway updated itself to V1.0.9. I thought I had disabled automatic update. It seems I am back to the old situation now.

Would be nice if this could be solved by using the suggested improvements.

I am wondering whether I am the only one with this kind of problem?

The main reason is that The Things Kickstarter Gateway doesn’t have an official maintainer (or in TTI terminology: “code owner”).

Over the last couple of years, I’ve only submitted some small and easy patches to prevent the thing from breaking down (mostly just updating Root CAs) but if my own TTKG doesn’t have a problem, I’m not touching that code.

However, I believe my colleague @adrianmares recently started experimenting a bit with TTKG firmware, so I’ll ask him if he can perhaps review and test those patches.

1 Like

Hey.

I’ve indeed looked into merging Daniel Kucera’s PRs into the development branch of the gateway firmware - I’m testing them in my form which is available here.

I will try to get them merged to develop in the future - I will update this thread this once that happens.

2 Likes

Thanks very much Adrian!

I have been running these fixes for a couple of months now, so I have incorporated them into the current develop channel - it should be available to your gateway once you change the channel from stable to develop and restart the gateway.

2 Likes

Thank you! I can finally go back to stock firmware :slight_smile: (or at least rebase).

Thank you! Good news. I also will switch to develop now.