The Things Node does not send uplink data


(Lso) #1

My new Things node seems not able to send data (uplink) to its application; butit is constantly sending activation data.

I did the following actions :
I was able to retrieve the device EUI (by downloading the DeviceInfo sketch) and registering it in my console; by creating an application I received an application EUI and an Appkey, which was copied in the Basic sketch (and uploaded to the device). I’ve checked these codes twice.
In the application data console, the device seemed to be sending constantly activation codes and receives always new devices addresses. But it does not answer with sending temperature, battery level,…etc.
image

image

I made a new application and restarted the complete work process.
I have installed new batteries (rechargeables).

The RSSI seems very low (fluctuates between -117 and -121), but as it is receiving its activation request, i am not sure that this is a problem.

Could anyone give a suggestions what other actions to take to overcome this? Is the device broken? Why does the application receive different device addresses?

Thanks in advance.

Kind Regards

Luc


(Arjan) #2

Just to be sure: the RSSI you see is that for the OTAA Join Request (orange icon), as sent by the node and received by one or more gateways. (Probably one gateway as you’re only mentioning one RSSI.) If you have access to gateways logs (like in TTN Console) then you’d also see the OTAA Join Accept being sent (green icon). You cannot see the RSSI for the Join Accept, but most likely the node has not received that, and keeps retrying.

So, you need a better reception (take the node outside; increase its height?), or need to try at a lower data rate (higher SF):

As an aside: as TTN assigns a DevAddr, it has accepted the Join Request, so the settings in the device match the settings in TTN Console (DevEUI, AppEUI, AppKey).


(Lso) #3

Thank you for the quick reply.
I changed SF to 10 and this resulted in regular uplinks (the node was already installed outside to measure the outside temperature).

And the application reports a better rssi (-113 ->-115) and multiple gateways.

image

You suggest to access the TTN gateway, but can you confirm that, as these are not my property, I cannot configure them in my console?

Thank you for the support.

Kind Regards,

Luc


(Arjan) #4

If you know the gateway owner, you could ask them to add you as a collaborator in TTN Console. But unfortunately, there is no “read-only” collaboration, so they might kindly decline such request…

So indeed: you cannot see the traffic of gateways that you do not own, and are not a collaborator of.


(Jg Spitfire) #5

Hi, i have a similar problem, first my node did not get the join response and continuosly sent the join request as the image above but “suddenly” my node started to sent the join request, then got the join request accepted but repeated the process
nodo1

i mention “suddenly” because it started to work just when i moved my gateway, then while i was reading this post i moved my node antenna toward my gateway and it worked!
nodo2

I am very confused because yesterday i read in a post that the devices (gateway and node) must not be too close then i moved my gateway away from my node and it works then i disconnected my node and when was started once again just sent the join request, i had doubts about the distance between devices but today i confirmed it is the problem but the solution is very random because sometimes works and sometimes doesnt works, any suggestion?

details:

  • i am using the pycom lopy4 as gateway and the bl072z “number guessing” example from st workshop
  • i have the same SF(7) in the node and gateway(i dont know if this is ok)
  • now i have 1 meter of distance between devices and the node has joined to the network correctly and it is sendig data (before was at the same distance but the node antenna toward other direction and didnt work)
  • the duty cycle in the node is disabled (the number guessing example has this option for test purposes and i dont know if this is possible in TTN)

thanks!