The WORKBENCH part 5

Today I investigated the performance of the Aurel GP 868 antenna that can be purchased at Conrad (Aurel GP 868 Ground Plane Antenne Antenne | Conrad.nl).

This antenna is nice looking with rubber protection at the ends of the radials

before After

From experience, I know that these rubbers will detune the antenna frequency down, and when I verified the antenna I found that the 868 MHz antenna actually was resonant at 816 MHz and not 868 MHz. At the resonant frequency, antenna performance is pretty good with 18 dB return loss. However, at 868 MHz return loss was 9 dB. That did not meet my quality standards.

afbeelding

Because the antenna resonance frequency was lower than 868 MHz the elements of the antenna were too long and can be shortened to tune for an exact 868 MHz. In an iterative process with intermediate measurements, I shortened the elements on average 2 mm with a satisfying result: return loss was >26 dB from 864 to 873 MHz.

afbeelding

Radio link performance is directly influenced by the quality of the antenna. I know this antenna is performing well.

The only problem left is that the antenna is not waterproof but that can be solved with some Self-amalgamating tape.

6 Likes

Is the 2mm for use with the rubbers or without them?

The 2 mm is without rubbers. With rubbers, you probably need more.

1 Like

Perhaps a warning to others:
The rubber caps are very firm. When removing the vertical rod, something inside came loose and now the rod can be moved.

BTW the resonant frequency is not the frequency with the best VSWR but the frequency with Xs=0

So is this antenna only suitable for those having the proper RF equipment to measure antenna performance and are willing to tune the antenna themselves (and not a good buy for others)?

Why (and where) is it not waterproof?

A post was merged into an existing topic: The LIBRARY basement part 12

No. The antenna is performing well enough for many applications.

That is because the top is hard-plastic and I expect that the capillary effect will allow water to enter. As the internal connector is an F-type (from what I know is this connector 75 ohms, not 50) the water might leak into the coaxial cable connected to it.

No, there is additional length taken from the rods to tune it.

1 Like

Using OTAA & TTSCE (TTN V3) :+1: :slight_smile:

Raspberry Pi Pico (RP2040) + Arduino + MCCI LMIC

LMIC-node @ Rasberry Pi Pico 1920x984

This is one of my Raspberry Pi Pico’s + RFM95 using LoRaWAN to connect to TTN V3.

It runs the LMIC-node example application.

2 Likes

NOT on the WorkBench any time soon …

Screenshot 2021-05-20 at 20.26.23

How are you finding the LT-33222? I have a US-915 version that I need to install the AU915 firmware on before I can use it. I’ve got some ideas for agricultural use.

Apparently too cute to send to a customer …

Anthropomorphic Voltage Regulator

I started from a moteino based, added tpl5110 for managing deep sleep, added place for rfm95w, added place for bme280 ( with polish nails xD) , added patch antenna, those little baby run for 1 year and half now on 2 AAA lithium cells

signal-2021-05-23-100632_005 signal-2021-05-23-100632_002

I also made the same but this time adding a mofset to switch off the moisture sensor.

signal-2021-05-23-100632_001

All run on ttn v3, with custom optiboot firm

I can share diagram on easyEDA.

1 Like

Adafruit QT Py running LMIC-node

Adafruit QT Py + LMIC-node

This is my Adafruit QT Py (SAMD21) board with HPD13A LoRa module and SSD1306 OLED display running LMIC-node connected to TTN V3.

Support for the Adafruit QT Py has just been added to LMIC-node.

3 Likes

I had a productive day working with the owner of a local WISP to perform a test installation and range testing at a proposed gateway colocated on one of his sites. This didn’t happen in my workshop but was on site at a PoP on a hill. Still I think it counts for here.

As they say no contact with the enemy goes as planned which was true today. The WISP guy had some trouble with getting a connection to the internet via the router used to act as CPE instead of connecting directly to his core. That was solved with noticing a VPN program had crashed and the laptop was trying to connect to a different part of the core and was fixed with a reboot.

It was then my time to shine. While checking if the gateway had booted we discovered that the status is no longer displayed in V2 of the console so I had to hastily read the migration documentation and move my gateway from V2 to V3. This was actually easier than I was expecting and went well with the gateway talking to the V3 console. I’m going to move over my other gateways in the next few weeks but I might leave one on V2 until I know all V2 apps are moved to V3 though.

I had a T-Beam module loaded with TTN-Mapper firmware installed but forgot to charge the 18650 battery. None of the powerbanks I brought with me would power it properly nor would the other guy’s USB charger. We eventually got enough power into the battery to get the T-Beam to boot.

From there it was time to drive around testing range with two different antennas. The best we got was about -110dbm RSSI with -2.5 SNR at about 13KM for the trial gateway. From there we did more driving to add more coverage to TTN mapper for the local area. We happened to get 20KM to a different gateway in a nearby town which also impressed me.

I’m quite pleased with how the day went. I’ve got a new collaborator to work with, we have a great idea how much actual range we have compared to simulated coverage and I have ordered a better gateway based on the SX1302 chipset to go into production at the site. We have plans to rollout LoRaWAN coverage at some of his other sites in the future if the next stage of collaboration works out.

3 Likes

As the current world wide shortage of, well, anything really, spent 30 minutes today tracking down some 220uF Electrolytic capacitors, 5mm pitch that weren’t gold plated, let alone finding a LoRaWAN module and an MCU to suit, I’ve gone back to me roots and updated it a little:

4808RFM

It’s an ATmega4808 28 pin SSOP which is, with a fine tipped soldering iron, feasibly hand-solderable. I’m using a trusty RFM95. The 4808 has 48KB of flash and 6KB of SRAM which is half as much again of flash and three times more than the trusty 328P of Arduino Uno/Nano/Pro Mini fame.

I’ve put the Optiboot boot loader on it, so the Arduino IDE thinks it’s an Arduino and I used the latest MCCI LMIC (v4) that provides v1.0.3 LoRaWAN to test OTAA and the forbidden fruit that is ABP and all is well.

Having turned off some of the junk for Class B but turned up logging to 11 (as I want to explore the MAC commands coming down from v3 a bit more), it took up 26741 bytes of flash (54%) and 1216 bytes SRAM (19%). Plenty of space for sensors and gratuitous text strings. With logging set to 0, it uses 22882 bytes of flash.

So for non-critical applications, I suspect this will be my go-to build for a while until the silicon universe stops ebbing & flowing quite so much.

1 Like

An alternative to EdgeImpulse for edge AI classification before sending result over LoRaWAN?

1 Like

Not on any workbench for a rather long time … … is it me or is supply going backwards?

Screenshot 2021-11-18 at 19.40.32

1 Like

Looks like the latest Microchip MPLAB ICE 4 emulator, programmer, debugger is out and available in stock with latest IDE support available for download if interested (AVR, SAMD users et al)
https://www.microchip.com/en-us/development-tool/DV244140

2 Likes