TTIG does not connect to TTN

@itrich: Yes I may confirm your opinion. Same thing here. My Sensordata get lost about 50% of time since some days (about 5 to 6). At this moment my TTIG’s LED is solid green, but no packet arrives at TTN. TTN Console says TTIG not connected, Sensors not connected since 2 hours. Very dissapointing …


Here I had some outage again, starting from 14:00 h CET. The worst thing is, that the TTIG did not come back by itself. However, constant green light was on, so I didn’t notice it. After unplugging/plugging it back it started to be online again. I don’t have physical access to all my TTIGs all the time and some of them are far away from my office, located in locked room. Kind of inconvenient if one has to manually reboot them.

1 Like

Are there issues at the momen my indore gateway showing same symptoms …
Green light on unit - off line in console
Reboot it and it comes back for a bit then nothing.

1 Like

At TTN Conf. Johan said TTN now running v3 Gateway server.
There was an update to v3 21 hrs ago one fix was for
“Authentication of Basic Station gateways”

The TTIG indoor runs Basic Station Packet forwarder.

1 Like

Any news on if this might be causing aprox 10 mins of use between reboots?
i cant process more than 20 packets! befor green light stays on and silence

Same symptoms over here. I unboxed another TTIG for testing and it shows the same behavior. It is not related to a defective device.

interestingley its dhcp host name changes to /s2/tc.key so looks like a scripts broken somware that should be ESP_50BDXX .
Bug in latest pushed software?

That is not a recent phenomena…been running long term tests on 5 since last Spring and sometimes see the /s2/… change vs ESP… so probably not just latest s/w. Have seen them go offline for an hour or three a few times lately, often in a.m. but suspect may be dodgy wi-fi backhaul. Had to recycle 2 earlier when I was forced to reset AP for other matters and they didn’t recover wi-fi connection. Interestingly a Dragino LPS8 on parallel test with same AP also struggled to recover after AP reboot and also required reboot… wondering if it’s a dhcp refresh problem, maybe all struggled to get new leases… may be worth you guys checking timing of drop offs to see if tied in to taking new IP under dhcp or failing to hold? Strange but…

Do you guys have the “Automatically update gateway” checkbox enabled? (TTN/Gateways/Console/Settings). I believe that this might cause the trouble with TTIG.
Edit: I unchecked the box and re-plugged/ rebooted the device. So far it still receives …
Edit2: … and offline again :slightly_frowning_face:

1 Like

did not help in my case

it seemed to keep it on a bit longer today ong that but now when its on downlinks are not processing corectly .

its about to go back in its box and be returened as not fit for function.

Thanks to the slack channel, a possible explanation:

Unplug, wait more than 600 seconds, replug.

Looks like that short power cycles may cause trouble …


The keepalive was recently extended from 60 to 600 secs which helps make up GW’s more resilient from WS disconnects, but now means a longer wait before restart if they go down?! Also this is lousey problem to deal with if gateway is ‘remote’ as no way to shutdown and restart to recover, simply forcing a reboot would seem not giving enough time so may need to engineer some kind of long period power supply turn off/turn on solution (a node driving a relay? but how to command if the TTIG is the only GW in range?! :thinking: )

1 Like

Yes, and apparently introducing problems to people for whom the 60 seconds setting was shorter than an automatic daily reset of their internet connection, but the 600 seconds is troublesome.

I also have the same problem with 4 TTiG that won’t connect to the TTN:


they all 4 got a MAC APP address starting with 2C:…
3 other ones work fine they got MAC APP addresses starting with CC:…
All off them are registered on TTN via console gateway.

How can help me? Greetings Frans

Channelling @arjanvanb, here’s a recent thread on the matter:

If they are already registered on TTN or not correctly provisioned, you’ll need to mention a TTI staff member, as you will see was done in that thread.

@descartes: In this particular issue, these gateways are correctly provisioned by the manufacturer. Seems like something else. @WSVV1 is discussing with me on a private thread. Thanks for the redirect. :+1:

1 Like

How can i test with you this issue. Teams video conference or here? I don’t know what is the problem and if i have to sent them back to RS were bougth them.

HELP! My TTIG (TBMH100) never goes to solid-green. I did the setup and it connects to my WiFi base station and receives an IP address (confirmed from the base station that it sees the TTIG, and I can ping the TTIG), but it just fast-blinks green (and occasionally momentarily blinks green/red)- it NEVER goes to solid-green. I tried re-doing the setup twice, in which I deleted my WiFi network and re-added it, but I get the same result each time- it goes to fast-blink green. I yanked it out of the wall and plugged it back in, but I get the same fast-blink-green. No firewalls or weird network, just a typical Linksys WiFi router doing NAT to the Internet, that works fine for lots of other devices on my network.

I added it into the TTN Console, but since the gateway never goes to solid-green, I don’t expect it to work. (It shows “Last seen: ”.)

MY 915MHz unit, bought at Adafruit:
MFG date: 2020-01-04 07:23:01
FW Build: 2018-12-06 09:30:37
FW Version: 2.0.0
Core Version: 2.0.0(minihub/debug)
Copyright (c) 2018 Semtech Corporation. All rights reserved.

Hey Eric. What’s the EUI?