TTIG Gateways Not Going Solid Green after Registration

Just tried two different TTIG gateways and after registering them in the TTN Console, neither of them is reaching a solid-green LED status. After registration the only things in the Live Data tab are:

Update gateway [ “attributes” ] ← This seems to be repeating itself periodically
Update gateway [“ids.eui”“, lbs_lns_secret”]
Create gateway API key
Create gateway API key
Create gateway

Historically this has been a problem with the TTN backend that required some intervention on the part of @KrishnaIyerEaswaran2 . Please can you check on that now?

The two units I just tried are the following EUIs:

  • 58A0CBFFFE80260A
  • 58A0CBFFFE8016CC

They are the same vintage as the others I have reported about in the past.

I second this - I’m getting exactly the same symptoms. My EUI is


I have factory reset, reclaimed it again and I get the same result.

Plenty of reboots. Device is confirmed as successfully connecting to WiFi.

1 Like

In both your cases, it looks like you haven’t selected a frequency plan for your gateways. Without that, the gateway will not connect.

Was that intentional?

For now, if you just update the gateway with your preferred frequency plans and reconnect, it will work.

1 Like

@KrishnaIyerEaswaran2 I used the website to claim the gateways and I definitely picked frequencies in that process both times… perhaps a bug on the front end / back end didn’t ‘accept’ the selection?

I can confirm that setting the frequency plan using ttn-lw-cli fixed the problem. I couldn’t get ttn-lw-cli to work on my Ubuntu 22.04 machine, so I ran it on a Windows guest in VirtualBox instead and ran this command, for example:

ttn-lw-cli.exe gateways set eui-58a0cbfffe80260a-3 --frequency-plan-id US_902_928_FSB_2

I don’t know if there is a way to update the Frequency Plan post-hoc in the web interface, but I couldn’t find it so I went the cli route instead.

I have a 915 TTIG for testing purposes and swap it between US & AU bands on demand via the web console without issue.

(It’s in a 20" container and I’ve tested for leaks, nothing gets out)

And if the CLI didn’t work on U22.04, my web to CLI interface would be a chocolate fireguard.

Happy to provide training on arising issues.

Yes, please can you screenshot where you change the frequency plan settings in the web UI and how you navigate to there?

Go to general settings scroll down and expand LoRaWAN options.

Damn you man, I was going to ask for a purchase order :wink:

Thanks guys, helpful!

Sorry, I’ll ask for one first next time. Then we can split the loot. :sunglasses:

1 Like

Hi, apologies if this thread hijacking is rude!

I don’t know if I have the same problem, but I do know I need some help please :slight_smile:

My EUI is E58A0CBFFFE800FC, the gateway is a couple of years old, and may have never worked!

Loose the leading E and double check rest of correct EUI. What GW-ID have you chosen/used?

Oh wow, I don’t even know when I made that mistake!

The corrected EUI is 58A0CBFFFE800FC0

uk-so53-4lq-ttig is the ID I chose at some point.

It happens :blush: ! Many guilty of same ooops!

Doesnt appear to be registered,tenantID=ttn,id=uk-so53-4lq-ttig
What happens if you try to register same again (claim again) using same details/same GW-ID - what does detailed error message (if any) say.

When I try to claim it again I get this:

  "code": 9,
  "message": "error:pkg/deviceclaimingserver/gateways:gateway_not_authorized (gateway with EUI `58A0CBFFFE800FC0` already exists and is not authorized for claiming)",
  "details": [
      "@type": "",
      "namespace": "pkg/deviceclaimingserver/gateways",
      "name": "gateway_not_authorized",
      "message_format": "gateway with EUI `{gateway_eui}` already exists and is not authorized for claiming",
      "attributes": {
        "gateway_eui": "58A0CBFFFE800FC0"
      "correlation_id": "8196ed8e1f4d491a99e9e899e9ce818d",
      "code": 9

Looks like one for @KrishnaIyerEaswaran2 as may not have been set up in 3rd party claim server for TTN registration. Where did you buy this from/what sales channel? I see another GW a bit south of you - south of Blencowe Drive - (RPi based?) that is quite well mapped including close into your area so would have expected some coverage recognition of this if its was ever ‘live’ near there…

1 Like

Thanks for the help BTW!

I bought it way back on 8 Sept 2019, from RS Components.

Yes, I connected* a Raspi LoRa device (which I’ve since fried :slightly_frowning_face:) to that other gateway - I should probably introduce myself to my neighbour - the coverage was mapped by me!

* ‘connected’ is the wrong word, but my device’s broadcasts were “heard” and reported by that gateway

Was it ever registered to TTN V2?, If live at time of V2 sunset (early Dec 2020) it could well have been auto-migrated to V3 or might have got lost on the way! RS supplied GW’s usually ok for claiming/registration but there can always be exceptions. Beyond scope for TTN Forum volunteers so you need to wait for TTI Core team assist - you might flag on the TTN Slack #support channel for faster response - link to this thread starting from your post perhaps.

1 Like

TBH, I don’t remember!

I’ll hop over to Slack, thanks again :smiling_face:

For completeness, here’s my message on Slack: Slack