TTIG : The Things Indoor Gateway

A post was merged into an existing topic: Things Indoor Gateway - part 1

I had now the TTIG for a while and can now compare it with a RAK2245.
I realize, as many above that the TTIG is missing a lot of packets, and does not work with some of the channels. Is this problem solved ?

What is the way to update the firmware, and what is the current firmware ?
Mine is :

MFG date2018-12-11 09:03:45
FW Build2018-12-06 09:30:37
FW Version2.0.0
Core Version2.0.0(minihub/debug)

So I hope there has been a release since.
Thanks for any help.

I too found that some packets get lost. Packets I know of because received by 2-3 gateways at distance (10-20km, not mine).
My impression, formed initially when I observed with some attention the gateway log in the console, is that the gateway is like deaf for some time after receiving a packet. This in part could be due to downlinks windows, but I did not check whether downlinks were sent too in those moments.

Interesting - a test to run could be to blast out two packets in quick succession, that aren’t actually from any recognized node (and therefore won’t generate any downlink reply) and see if they get reported as raw gateway traffic.

1 Like

This is something I promised myself to try, but I have yet to find time and will :slight_smile:

A post was merged into an existing topic: Things Indoor Gateway - part 1

Hi guys. Recently received the TTIG. Works like a charm. But… no power plug in the package from RS Components. Was really hoping to get one afterwards…

Have somebody got their hands on one?

Thanks.

Hi. Got my hands on gw - Eu model. Configured in console. Shows as online but no received/sent packets.
eui-58a0cbfffe8004f7

Testing via S76 module. It works on some other network i tested.

Not sure what else to do

The S76 worked on another network or the TTIG? My understanding is the TTIG configures via CUPS Server and only works on TTN/TTI?

Double check you have received 868EU version and not 915US…I received 5units and all boxes showed TTIG-868 with correct RS Stock code but the 5th was actually a mis-pack with a 915 in the box…check the label if it says TMBT100915xxxx and not TMBT100868 and has the FCC ID called out (bottom left of lable) you have a problem unit… (I’m aware of other instances not only mine)

If you have a 915 it will show up in console and appear as online but will be deaf to the 868EU Tx’s of the S76 so no traffic captured.

Good Luck! :wink:

1 Like

It worked on Lattelecom lorawan network - https://www.actility.com/tag/lattelecom/

(http://3priedez.net/images/uploads2/2019.05.02/img.2019.05.02.hefXyG.png)

Did anyone managed to get it working on AS923 or AU915?
I have a solid green light and a connected status on the console but no data packet coming through.

As per my post 6D ago above its not unknown for the wrong type to ship so double check you have a 915Mhz vs 868Mhz version. If it shows connected in the TTN Console then being wrong freq would mean its ‘deaf’ to your 915Mhz nodes and no data coming through and is one of the possibilities to consider… :wink:

Worth checking to eliminate possibility just in case…good luck! :slight_smile:

Maybe a stupid question, but how can I buy it? I can’t find any links.

1 Like

Not sure where in the world you are but sales are through RS Components/Allied.

Here is UK link
https://uk.rs-online.com/web/c/semiconductors/semiconductor-development-kits/radio-frequency-development-kits/?searchTerm=things%20indoor%20gateway

Single units: https://uk.rs-online.com/web/p/radio-frequency-development-kits/1843981/

Back in stock 17th June?

1 Like

I have both a TTIG and a RAK2245.

For test, I send a message every minute with a Steval-STRK01 Lora sensor.
With a message every minute, the RAK2245 got all messages, but the TTIG got only one message over two.

I have now repeated the experiment with a message every two minutes.
Now both TTIG and RAK2245 get all messages.

The sensor is in the house, but far away from the gateways

RAK2245 :
“rssi”: -67,
“snr”: 10,

TTIG:
“rssi”: -69,
“snr”: 10.75,

but variations occur. the rssi of both gateways are comparable.

Not so much, but I am also sure some packet is lost. Which SF do you use? However, as I had the impression that the gateway was not listening for some time after receiving a packet, I did a test as suggested by @LoRaTracker, with a node set for sending every 7 seconds (but ended sending every 12, LMIC takes some time for completing). This at SF7. Almost all packets were received. I would replicate at SF12, but I have to set two nodes for sending one some second after the other.

Hey, we’ve just opened pre-orders for TTIG at Connected Things Store. We have our first units arriving mid-June, so we’re taking orders now and will ship out ASAP.

We can take orders from companies or individuals and ship anywhere in Europe (and wider), so hopefully that will help with some of the supply issues!

You can pre-order here: https://connectedthings.store/gb/lorawan-gateways/the-things-indoor-gateway-868-mhz.html

Give me a shout if you have any problems ordering from the link above and I’ll see if I can help out!

Cheers,
Al

1 Like

Tom, where’d you get it?

Allied Electronics & Automation.
DHL shipment 6185827244
I was on TTN wait list.
Got e-mail to say “Available now”
Clicked on all the links… whatever…
Purchased.
Arrived.
Obviously a U.S. version.
It’s fine by me.
I only give information in case someone’s interested in process improvement.

I installed a new Indoor Gateway in my house a couple of days ago. The installation went smoothly and TTN says the gateway is connected and receiving and transmitting messages. The documentation says this about the green LED:

GREEN - blinking 1 sec - [GW Mode] WiFi STA not connected
GREEN - blinking 1/4 sec - [GW Mode] WiFi STA connected,establishing connection to LNS, configuring radio
GREEN - solid - [GW Mode] WiFi STA connected, GW connected to LNS, radio listening

Since I installed it, my gateway has been alternating between Green-solid and Green-blinking-1/4-sec. It’s solid for about 55 seconds and then blinking for 10-20 seconds. The WiFi at the installation location is strong and I’ve also tried two other locations with good WiFi. My Internet connection seems stable.

Is this behavior normal? I wouldn’t be too concerned except that I have a device that doesn’t seem to be receiving messages. According to TTN it is succesfully activating but the device doesn’t seem to think so. I also see pulses on the DI1 pin which the LMIC doc tells me is called RxTimeout and the device is acting as if its activations requests are timing out.

1 Like