TTN GATEWAY central 2


#214

http://things-gateway.local/info

or

http://noc.thethingsnetwork.org:8085/api/v2/gateways/xxxx

xxx= your gateway name


(Smbunn) #215

Awesome, why did I not know this? Documentation seems a bit sparse :slightly_smiling_face:


(Willem (pe1dlf)) #216

after running (with the usual reboots) for a couple weeks I have now new issues

2018-05-01 17:47:07.922591 LORA: Kick LoRa module with ACK after not acked it for 60s
2018-05-01 17:51:15.827663 LORA: Kick LoRa module with ACK after not acked it for 60s
2018-05-01 17:52:17.808688 LORA: Kick LoRa module with ACK after not acked it for 60s
2018-05-01 17:53:19.764363 LORA: Kick LoRa module with ACK after not acked it for 60s

This goes on and on - I switch off the gateway for a while but the issues returns after a while

2018-05-01 17:54:55.209257 Firmware name: AmazingAckermann, type: 0, version: 1.0.2, commit: 475aef56, timestamp: 1521106500

This appears to be same as I experienced with 1.0.3, but for some reason it surfaces on 1.0.2 as well :frowning:


(Willem (pe1dlf)) #217

This appears to happen when there are no LORA packets received …


(The Things Products Team) #218

Hello Everyone

We just pushed a new firmware to the beta channel. This patch addresses two major issues faced by many people in this thread:

  • Revert problematic LoRa updates (1.0.3)
  • Includes a WiFi patch for more stability

You can find the link to the firmware from the Github page. It would be really helpful to have some beta testers check this release and let us know how it works at their end.


The Things Products Team


#219

4-a7

“ready to rumble” :sunglasses:


(Willem (pe1dlf)) #220

2018-05-02 17:54:42.599677 Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp: 1525259181

Ok let’s see what happens …


(Arjan) #221

No cigar for me. Getting into the reboot loop again with 1.0.4. Too bad it’s still not logging a lot:

LORA: Configuration failed, retry
LORA: RESET MODULE
LORA: ChaSNTP: State change from 0 to 0
SNTP: State change from 0 to 0
Full reboot loop log in 1.0.4

Timestamps added by https://github.com/avbentem/raspi-uart-monitor

[2018-05-02T17:28:18.788Z] **************************
[2018-05-02T17:28:18.789Z] *   The Things Network   *
[2018-05-02T17:28:18.792Z] *      G A T E W A Y     *
[2018-05-02T17:28:18.794Z] **************************
[2018-05-02T17:28:18.802Z] Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp: 1525259181
[2018-05-02T17:28:18.819Z] Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
[2018-05-02T17:28:18.831Z] Build time: May  2 2018 11:07:39
[2018-05-02T17:28:18.833Z] Reboot reason: 0x10
[2018-05-02T17:28:18.839Z] BOOT: (persisted info) 6F 72 72 65 01 03 8B 2C E7 16 0D 49 B2 32 50 B4
[2018-05-02T17:28:18.840Z]
[2018-05-02T17:28:18.840Z]
[2018-05-02T17:28:18.841Z]
[2018-05-02T17:28:18.841Z]
[2018-05-02T17:28:18.853Z] WIFI: Entering state 0
[2018-05-02T17:28:18.855Z] WIFI: Entering SCAN state 0
[2018-05-02T17:28:18.856Z]
[2018-05-02T17:28:18.857Z] MAIN: Initialisation complete
[2018-05-02T17:28:18.858Z] LORA: Changing state from 0 to 0
[2018-05-02T17:28:19.026Z]
[2018-05-02T17:28:19.028Z] MAIN: Leaving state 0
[2018-05-02T17:28:19.030Z] MAIN: Entering state 1
[2018-05-02T17:28:19.039Z] FLASH: Magic bytes found: wifi config present
[2018-05-02T17:28:19.043Z] FLASH: Magic bytes found: activation data present
[2018-05-02T17:28:19.047Z] FLASH: Magic bytes found: FOTA data present
[2018-05-02T17:28:19.050Z] FLASH: Loading Firmware Data
[2018-05-02T17:28:19.062Z] CNFG: (Firmware HASH (sha256)) 65 0D 50 41 6F 3C 7A 21 B0 6A 61 4A FF BE C3 DD 3F 8A 2C 8F D1 98 70 9F 71 EF C5 53 6A 7D 31 AF
[2018-05-02T17:28:19.065Z] FLASH: Loading WiFi Data
[2018-05-02T17:28:19.067Z] CNFG: WiFi SSID:      <redacted>
[2018-05-02T17:28:19.070Z] CNFG: WiFi key:       ***
[2018-05-02T17:28:19.072Z] CNFG: WiFi conn_type: 1
[2018-05-02T17:28:19.074Z] CNFG: WiFi sec_type:  4
[2018-05-02T17:28:19.076Z] FLASH: Loading Activation Data
[2018-05-02T17:28:19.080Z] CNFG: Gateway ID:         arjanvanb-gw-1
[2018-05-02T17:28:19.083Z] CNFG: Gateway Key:        ***
[2018-05-02T17:28:19.089Z] CNFG: Account Server URL: https://account.thethingsnetwork.org
[2018-05-02T17:28:19.091Z] CNFG: Locked:             true
[2018-05-02T17:28:19.094Z] CNFG: Locked first time:  false
[2018-05-02T17:28:19.095Z]
[2018-05-02T17:28:19.097Z] MAIN: Leaving state 1
[2018-05-02T17:28:19.099Z] MAIN: Entering state 2
[2018-05-02T17:28:19.105Z] INET: State change to 0
[2018-05-02T17:28:19.402Z] LORA: Initialisation complete
[2018-05-02T17:28:19.405Z] LORA: Changing state from 0 to 1
[2018-05-02T17:28:19.652Z] WIFI: Entering state 1
[2018-05-02T17:28:19.654Z] ETH: IP Address: 0.0.0.0
[2018-05-02T17:28:19.656Z] WIFI: Entering state 4
[2018-05-02T17:28:19.659Z] WIFI: Entering SCAN state 1
[2018-05-02T17:28:20.080Z] Scan is completed successfully
[2018-05-02T17:28:20.082Z] WIFI: Entering SCAN state 2
[2018-05-02T17:28:20.090Z] WIFI: Entering SCAN state 5
[2018-05-02T17:28:20.093Z] WIFI: Entering SCAN state 0
[2018-05-02T17:28:20.095Z] WIFI: Entering state 2
[2018-05-02T17:28:20.097Z] WIFI: Disabling modules
[2018-05-02T17:28:20.103Z] Head magic match void: trying to free an already freed block, ignore
[2018-05-02T17:28:20.105Z] WIFI: Entering state 3
[2018-05-02T17:28:20.744Z] SNTP: State change from 0 to 1
[2018-05-02T17:28:20.870Z] INET: Gateway has Ethernet
[2018-05-02T17:28:20.872Z] INET: State change to 2
[2018-05-02T17:28:20.878Z] INET: Connected to a network, waiting for DHCP lease, checking validity with ping
[2018-05-02T17:28:20.969Z] WIFI: Enabling modules for client
[2018-05-02T17:28:20.972Z] WIFI: Entering state 6
[2018-05-02T17:28:20.974Z]
[2018-05-02T17:28:20.975Z]
[2018-05-02T17:28:20.976Z] >WIFI: IP Address: 0.0.0.0
[2018-05-02T17:28:22.939Z] CB: SNTP: State change from 1 to 2
[2018-05-02T17:28:23.838Z] ETH: IP Address: 192.168.0.12
[2018-05-02T17:28:25.834Z] WIFI: IP Address: 192.168.178.53
[2018-05-02T17:28:25.863Z] INET: State change to 3
[2018-05-02T17:28:25.865Z] INET: Ping probe
[2018-05-02T17:28:25.876Z] INET: Ping response from PIC32INT, set as default
[2018-05-02T17:28:25.878Z] INET: State change to 4
[2018-05-02T17:28:26.396Z] LORA: Wait init complete, waiting for application.
[2018-05-02T17:28:26.398Z] LORA: Changing state from 1 to 2
[2018-05-02T17:28:28.427Z] SNTP: State change from 2 to 3
[2018-05-02T17:28:28.766Z] MON: SYS Stack size: 3965
[2018-05-02T17:28:28.768Z] MON: TCPIP Stack size: 3815
[2018-05-02T17:28:28.771Z] MON: APP Stack size: 7951
[2018-05-02T17:28:28.773Z] MON: LoRa Stack size: 3915
[2018-05-02T17:28:28.777Z] MON: heap usage: 164KB (172KB), free: 176KB
[2018-05-02T17:28:29.525Z] SNTP: State change from 3 to 4
[2018-05-02T17:28:30.623Z] SNTP: State change from 4 to 5
[2018-05-02T17:28:37.207Z] SNTP: State change from 5 to 6
[2018-05-02T17:28:37.210Z] SNTP: State change from 6 to 1
[2018-05-02T17:28:37.213Z] INET: Initiated NTP request.
[2018-05-02T17:28:38.304Z] SNTP: State change from 1 to 2
[2018-05-02T17:28:38.753Z] MON: SYS Stack size: 3965
[2018-05-02T17:28:38.755Z] MON: TCPIP Stack size: 3806
[2018-05-02T17:28:38.758Z] MON: APP Stack size: 7951
[2018-05-02T17:28:38.760Z] MON: LoRa Stack size: 3915
[2018-05-02T17:28:38.764Z] MON: heap usage: 167KB (172KB), free: 172KB
[2018-05-02T17:28:39.403Z] SNTP: State change from 2 to 3
[2018-05-02T17:28:40.500Z] SNTP: State change from 3 to 4
[2018-05-02T17:28:41.598Z] SNTP: State change from 4 to 5
[2018-05-02T17:28:41.607Z] SNTP: State change from 5 to 6
[2018-05-02T17:28:41.612Z] SNTP: State change from 6 to 7
[2018-05-02T17:28:41.615Z] INET: State change to 5
[2018-05-02T17:28:41.616Z]
[2018-05-02T17:28:41.617Z] MAIN: Leaving state 2
[2018-05-02T17:28:41.619Z] MAIN: Entering state 3
[2018-05-02T17:28:41.620Z]
[2018-05-02T17:28:41.622Z] CNFG: Load online user config state change to 4
[2018-05-02T17:28:41.624Z] HTTP: Close active socket 0
[2018-05-02T17:28:41.626Z] HTTP: Starting connection
[2018-05-02T17:28:41.635Z] HTTPS: Connection Opened: Starting TLS Negotiation
[2018-05-02T17:28:41.638Z] HTTP: Wait for TLS Connect
[2018-05-02T17:28:42.088Z] HTTP: TLS Connection Opened: Starting Clear Text Communication
[2018-05-02T17:28:42.118Z] HTTP: Got 1477 bytes
[2018-05-02T17:28:44.118Z] HTTP: Connection Closed
[2018-05-02T17:28:44.120Z] HTTP: Close active socket 1
[2018-05-02T17:28:44.124Z] CONF: Parsing response token: HTTP/1.1 200 OK
[2018-05-02T17:28:44.130Z] CONF: ROUTER URL: mqtts://bridge.eu.thethings.network:8883
[2018-05-02T17:28:44.131Z]
[2018-05-02T17:28:44.134Z] CNFG: Load online user config state change to 6
[2018-05-02T17:28:46.126Z] FREQ: APP_URL_Buffer: https://account.thethingsnetwork.org/api/v2/frequency-plans/EU_863_870
[2018-05-02T17:28:46.128Z] HTTP: Starting connection
[2018-05-02T17:28:46.140Z] HTTPS: Connection Opened: Starting TLS Negotiation
[2018-05-02T17:28:46.142Z] HTTP: Wait for TLS Connect
[2018-05-02T17:28:46.637Z] HTTP: TLS Connection Opened: Starting Clear Text Communication
[2018-05-02T17:28:46.650Z] HTTP: Got 1232 bytes
[2018-05-02T17:28:48.649Z] HTTP: Connection Closed
[2018-05-02T17:28:48.652Z] HTTP: Close active socket 1
[2018-05-02T17:28:48.653Z]
[2018-05-02T17:28:48.656Z] CNFG: Load online user config state change to 7
[2018-05-02T17:28:48.657Z]
[2018-05-02T17:28:48.659Z] CNFG: Configuring LoRa module
[2018-05-02T17:28:48.662Z] LORA: Changing state from 2 to 4
[2018-05-02T17:28:48.665Z] LORA: Starting reconfiguration
[2018-05-02T17:28:48.670Z] LORA: version: 01
[2018-05-02T17:28:48.676Z] LORA: Configuration failed, retry
[2018-05-02T17:28:48.703Z] LORA: Starting reconfiguration
[2018-05-02T17:28:48.754Z] MON: SYS Stack size: 2837
[2018-05-02T17:28:48.755Z] MON: TCPIP Stack size: 3806
[2018-05-02T17:28:48.756Z] MON: APP Stack size: 3283
[2018-05-02T17:28:48.757Z] MON: LoRa Stack size: 3857
[2018-05-02T17:28:48.757Z] MON: heap usage: 168KB (253KB), free: 171KB
[2018-05-02T17:28:54.663Z] LORA: version: 01
[2018-05-02T17:28:54.680Z] LORA: Configuration failed, retry
[2018-05-02T17:28:54.696Z] LORA: Starting reconfiguration
[2018-05-02T17:28:58.731Z] MON: SYS Stack size: 2837
[2018-05-02T17:28:58.733Z] MON: TCPIP Stack size: 3806
[2018-05-02T17:28:58.735Z] MON: APP Stack size: 3283
[2018-05-02T17:28:58.738Z] MON: LoRa Stack size: 3857
[2018-05-02T17:28:58.742Z] MON: heap usage: 168KB (253KB), free: 171KB
[2018-05-02T17:29:00.670Z] LORA: version: 01
[2018-05-02T17:29:00.687Z] LORA: Configuration failed, retry
[2018-05-02T17:29:00.703Z] LORA: RESET MODULE
[2018-05-02T17:29:03.556Z] LORA: ChaSNTP: State change from 0 to 0
[2018-05-02T17:29:03.559Z] SNTP: State change from 0 to 0
[2018-05-02T17:29:03.561Z]
[2018-05-02T17:29:03.563Z]
[2018-05-02T17:29:03.564Z]
[2018-05-02T17:29:03.566Z] **************************
[2018-05-02T17:29:03.568Z] *   The Things Network   *
[2018-05-02T17:29:03.571Z] *      G A T E W A Y     *
[2018-05-02T17:29:03.572Z] **************************
[2018-05-02T17:29:03.577Z] Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp: 1525259181
[2018-05-02T17:29:03.598Z] Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
[2018-05-02T17:29:03.600Z] Build time: May  2 2018 11:07:39
[2018-05-02T17:29:03.613Z] Reboot reason: 0x10
[2018-05-02T17:29:03.620Z] BOOT: (persisted info) 6F 72 72 65 01 03 8B 2C E7 16 0D 49 B2 32 50 B4

So, I’ve put back the SD card to get 1.0.3, commit: 2c56ce09 again, which was running fine so far. After a few reboots that is running again now. But this 1.0.3 still gives me https://github.com/TheThingsProducts/gateway/issues/8 a few times a week.


#222

A week ago i have flashed (pickit3) the gateway with a stable version.
Bootloader:r2-c463e87e (2018-02-23T14:42:40Z)
Firmware:v1.0.2-475aef56 (2018-03-15T09:35:00Z)

Reset the gateway fot 5 seconds. Delete the gateway in the backend. Activate the gateway and give it an other name in the backend. Now the gateway works for a week.


(Remko) #223

Just got it copied on the SD and is running now: 1.0.4
This gateway is running on WiFi.


(Jurrien) #224

No luck here… After inserting a SD card with the beta firmware, the gateway updated successfully

Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp: 1525259181
Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
Build time: May  2 2018 11:07:39
Reboot reason: 0x40
BOOT: (persisted info) 6F 72 72 65 01 03 BD DD FF FE F9 BA 67 7B 2D E7 

The gateway went online and started to receive couples of package but after few minutes it restarted

MQTT: Sending status packet
MQTT: Sending status succeeded: 8
MON: SYS Stack size: 2845
MON: TCPIP Stack size: 3823
MON: APP Stack size: 3251
MON: LoRa Stack size: 3857
MON: heap usage: 278KB (279KB), free: 61KB
SNTP: State change from 0 to 0
SNTP: State change from 0 to 0


**************************
*   The Things Network   *
*      G A T E W A Y     *
**************************
Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp: 1525259181
Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
Build time: May  2 2018 11:07:39
Reboot reason: 0x10
BOOT: (persisted info) 6F 72 72 65 01 10 BD DD FF FE F9 BA 67 7B 2D E7 

But then got stuck in a reboot loop. This is the full log of such a reboot loop

**************************
*   The Things Network   *
*      G A T E W A Y     *
**************************
Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp: 1525259181
Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
Build time: May  2 2018 11:07:39
Reboot reason: 0x10
BOOT: (persisted info) 6F 72 72 65 01 10 BD DD FF FE F9 BA 67 7B 2D E7 




WIFI: Entering state 0
WIFI: Entering SCAN state 0

MAIN: Initialisation complete
LORA: Changing state from 0 to 0

MAIN: Leaving state 0
MAIN: Entering state 1
FLASH: Magic bytes found: wifi config present
FLASH: Magic bytes found: activation data present
FLASH: Magic bytes found: FOTA data present
FLASH: Loading Firmware Data
CNFG: (Firmware HASH (sha256)) 65 0D 50 41 6F 3C 7A 21 B0 6A 61 4A FF BE C3 DD 3F 8A 2C 8F D1 98 70 9F 71 EF C5 53 6A 7D 31 AF 
FLASH: Loading WiFi Data
CNFG: WiFi SSID:      <REMOVED>
CNFG: WiFi key:       ***
CNFG: WiFi conn_type: 1
CNFG: WiFi sec_type:  4
FLASH: Loading Activation Data
CNFG: Gateway ID:         <REMOVED>
CNFG: Gateway Key:        ***
CNFG: Account Server URL: https://account.thethingsnetwork.org
CNFG: Locked:             true
CNFG: Locked first time:  false

MAIN: Leaving state 1
MAIN: Entering state 2
INET: State change to 0
LORA: Initialisation complete
LORA: Changing state from 0 to 1
WIFI: Entering state 1
ETH: IP Address: 0.0.0.0 
WIFI: Entering state 4
WIFI: Entering SCAN state 1
SNTP: State change from 0 to 1
Scan is completed successfully
WIFI: Entering SCAN state 2
WIFI: Entering SCAN state 5
WIFI: Entering SCAN state 0
WIFI: Entering state 2
WIFI: Disabling modules
Head magic match void: trying to free an already freed block, ignore
SNTP: State change from 1 to 1
WIFI: Entering state 3
WIFI: Enabling modules for client
WIFI: Entering state 6


>WIFI: IP Address: 0.0.0.0 
CB: INET: Gateway has WiFi
INET: State change to 2
INET: Connected to a network, waiting for DHCP lease, checking validity with ping
SNTP: State change from 1 to 2
LORA: Wait init complete, waiting for application.
LORA: Changing state from 1 to 2
WIFI: IP Address: <REMOVED> 
MON: SYS Stack size: 3965
MON: TCPIP Stack size: 3828
MON: APP Stack size: 7980
MON: LoRa Stack size: 3883
MON: heap usage: 163KB (172KB), free: 177KB
INET: State change to 3
INET: Ping probe
INET: Error sending probe on Eth
INET: Ping response from MRF24WN, set as default
INET: State change to 4
SNTP: State change from 2 to 3
SNTP: State change from 3 to 4
SNTP: State change from 4 to 5
SNTP: State change from 5 to 6
SNTP: State change from 6 to 7
INET: State change to 5

MAIN: Leaving state 2
MAIN: Entering state 3

CNFG: Load online user config state change to 4
HTTP: Close active socket 0
HTTP: Starting connection
HTTPS: Connection Opened: Starting TLS Negotiation
HTTP: Wait for TLS Connect
HTTP: TLS Connection Opened: Starting Clear Text Communication
HTTP: Got 1293 bytes
HTTP: Connection Closed
HTTP: Close active socket 1
CONF: Parsing response token: HTTP/1.1 200 OK
CONF: ROUTER URL: mqtts://bridge.eu.thethings.network:8883

CNFG: Load online user config state change to 6
FREQ: APP_URL_Buffer: https://account.thethingsnetwork.org/api/v2/frequency-plans/EU_863_870
HTTP: Starting connection
MON: SYS Stack size: 2870
MON: TCPIP Stack size: 3828
MON: APP Stack size: 3269
MON: LoRa Stack size: 3883
MON: heap usage: 171KB (249KB), free: 168KB
HTTPS: Connection Opened: Starting TLS Negotiation
HTTP: Wait for TLS Connect
HTTP: TLS Connection Opened: Starting Clear Text Communication
HTTP: Got 1232 bytes
HTTP: Connection Closed
HTTP: Close active socket 1

CNFG: Load online user config state change to 7

CNFG: Configuring LoRa module
LORA: Changing state from 2 to 4
LORA: Starting reconfiguration
LORA: version: 01
MON: SYS Stack size: 2870
MON: TCPIP Stack size: 3828
MON: APP Stack size: 3269
MON: LoRa Stack size: 3853
MON: heap usage: 167KB (249KB), free: 172KB
SNTP: State change from 0 to 0
SNTP: State change from 0 to 0


**************************
*   The Things Network   *
*      G A T E W A Y     *
**************************
Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp: 1525259181
Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
Build time: May  2 2018 11:07:39
Reboot reason: 0x10
BOOT: (persisted info) 6F 72 72 65 01 10 BD DD FF FE F9 BA 67 7B 2D E7

(Smbunn) #225

My gateway is on 1.0.3 and runs for about 4 to 5 hours then fails. Always fails with UART to LoRa. I have to jiggle the LoRa board, power off, pink button power on and re-activate the gateway. 90% of the time is has also lost the fact that my wifi gateway is WAP 2 Personal.
Usually takes two or three goes to get it to activate, then I have another 4 to 5 hours before it fails again.

Really frustrating as I can be deep into debugging my LoRa device and trying to figure out why it stops working after a code recompile, only to find out it is not the device, its my damn unreliable gateway that has fallen over. You always get so tied up in what you are doing you fail to step back and just check that the environment the device is running in is still working. There has been a few choice words a few times!

Are we going t get new LoRa boards to fix this?


(Guru) #226

Somewhat anecdotal update 26 days later: After testing, gateway was installed inside our workshop with the stock antenna and a single node talking to it every 10mins from my home about 200m away to keep it company.

It disappeared for 18h in the first week, but recovered itself. After the second week it disappeared for 3 days, but again recovered without intervention.

It’s on 1.0.4 firmware now and no significant outages since.
Received Messages: 2427
This equates to about 17 days worth of messages at 10mins(ish) intervals, so there are missing messages, or other outages not accounted for.


(Reinier van der Lee) #227

The TTN gateway here stopped today after working for more than a month with FW 1.0.3.
I have tried a power reset and SD card update to the latest stable release candidate. Also did a new setup from factory default. No luck so far, LoRa configuration fails, and the gateway is in a reboot cycle. I have shared the system log on github.

Firmware version: 1.0.4, commit: a7beae91, timestamp: 1525259181
Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
Build time: May 2 2018 11:07:39


(Reinier van der Lee) #228

@guru Similar experience here. Gateway was originally DOA (reboot loop) , but worked after update to 1.0.3.
After 1.0.4 online update it was stuck in the reboot loop again but restored overnight after being connected to an Ethernet cable. When installing to it’s original location, connected to WiFi, it was stuck in the reboot loop again. I have let it sit there, and somehow it restored and is now working again. I have set the gateway settings to accept updates and beta releases.


(Mike) #229

Both 1.0.2 and 1.0.4 give me the bootloop issue. Which branch gives me 1.0.3 and is there anything I can do to help fix this issue please?


(Arjan) #230

You can download it from https://github.com/TheThingsProducts/gateway/releases

And maybe it’s still the stable branch for automatic updates? Don’t know how to tell from the overview on https://github.com/TheThingsProducts/gateway/tree/develop/firmware (but given the URLs I think this matches the stable branch on GitHub, so then 1.0.3 is indeed the current stable version).


(Danny Engelman) #231

I never update(d) my Gateway manually

http://noc.thethingsnetwork.org:8085/api/v2/gateways/ttn_365csi_nl

Gives me:

"platform": "The Things Gateway v1 
- BL r1-7167873a (2017-06-02T13:48:18Z) 
- Firmware v1.0.2-475aef56 (2018-03-15T09:35:00Z)",

I presume it means 1.0.2 is the latest stable release

I haven’t seen any messages on this Forum (or I missed some);
is automatic update silent, or preceded with a public notification?


(Mike) #232

It appears the LORA modem was at fault. I was getting UART timeout with 1.0.4 which gave me a clue. See TTN Gateway won't register, just reboots


(Smbunn) #233

I looked at my configuration today and it is reporting:
Version Info
Hardware:
v1
Bootloader:
r1-7167873a (2017-06-02T13:48:18Z)
Firmware:
v1.0.2-475aef56 (2018-03-15T09:35:00Z)

When did we go back to V1.0.2? I thought V1.0.4 was out and stable?

My gateway is totally unstable, lasts between a few minutes and an hour or so, then reboots. Endless reboot until I pink button restart again.

I understand this is crowd funded and not a true commercial project but can we have an indication when we might expect these problems to be fixed. I got my gateway in February so have been patient for quite a few months already.

I added a 15 dB gain whip antenna, getting -46 dB signal with SNR of 10.6. Am I over saturating the LoRa card as if I stop my LoRa device the gateway is stable for longer, soon as I start transmitting it crashes withing 60 seconds.


The Things Gateway activation problem