TTN GATEWAY central 2


(Dellekom) #234

I just wanted to say that I still have the same stability issues that I described in April - I now have this

Hardware: v1
Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
Firmware: v1.0.4-a7beae91 (2018-05-02T11:06:21Z)

I am really losing hope.

Meanwhile, I bought a LorixOne Gateway to not block our rollout in Freiburg.


(Lukashenko) #235

Hi,
I was just wondering if it’s possible to provide the TTN Gateway with a static IP address.
The wired network we are attaching it to does not run DHCP so we are somewhat stuck.
Is there a web interface page (or any other way e.g. editing a file) that I could utilize,
in order to configure my TTN Gateway with its own static IP address, subnet mask, internet gateway etc ?

Thanks


(Cmolitor) #236

Hello everyone.

10 days ago my gateway was last seen online. So I tried a restart today, but it seems that it is in a boot loop.
Led1: on
Led2: on
Led3: blink slow -> then off -> Then all Leds off -> reboot

Please see video here: https://photos.app.goo.gl/CiNyt34HN9mfajFZ2

Would be glad to get some guidance what to check next.

Thanks,
Christoph


(Cmolitor) #237

It seems to work now. The Radio module was not perfectly mounted


(Smbunn) #238

Time for a status update. My gateway lasts no more than an hour at most up and running. Then goes into endless reboot.
Hardware:
v1
Bootloader:
r1-7167873a (2017-06-02T13:48:18Z)
Firmware:
v1.0.2-475aef56 (2018-03-15T09:35:00Z)

What is being done and when will this be fixed? There seems to have been a real drop off in communications over the last month, after the flurry of activity earlier this year.

Simple questions:

  1. Has TTN gateway been officially or unofficially dropped?
  2. Has support been dropped?
  3. Should I throw this device away or is there any possibility of a refund or fix?

thanks

Simon


(Reinier van der Lee) #239

The gateway here has been up and stable since the last update to firmware 1.0.4, 3 weeks ago.

Bootloader:
r1-7167873a (2017-06-02T13:48:18Z)
Firmware:
v1.0.4-a7beae91 (2018-05-02T11:06:21Z)

@smbunn noticed you have firmware 1.0.2. That did not work for me either.
Maybe update to 1.0.4 using SD card.


(Smbunn) #240

V1.0.2 is the last official stable release. v1.0.4 is beta. I have used both and had more stability with 1.0.2 but may try the latest version again.


(Jurrien) #241

Unfortunately with all three versions of the firmware my gateway doesn’t start receiving and sending messages but gets in a reboot loop. I’ve tried to reinsert the radio module as much as possible because it is glued to the mainboard with a spacer.

Version 1.0.4 (develop release) once the following log file entries appear it reboots. Most of the times this happens when it is connecting via HTTPS like:

[2018-06-05 01:38:06] HTTPS: Connection Opened: Starting TLS Negotiation
[2018-06-05 01:38:06] HTTP: Wait for TLS Connect
[2018-06-05 01:38:06] HTTP: TLS Connection Opened: Starting Clear Text Communication
[2018-06-05 01:38:06] HTTP: Got 1290 bytes
[2018-06-05 01:38:08] HTTP: Connection Closed
[2018-06-05 01:38:08] HTTP: Close active socket 1
[2018-06-05 01:38:08] CONF: Parsing response token: HTTP/1.1 200 OK
[2018-06-05 01:38:08] CONF: ROUTER URL: mqtts://bridge.eu.thethings.network:8883
[2018-06-05 01:38:08]
[2018-06-05 01:38:08] CNFG: Load online user config state change to 6
[2018-06-05 01:38:10] FREQ: APP_URL_Buffer: https://account.thethingsnetwork.org/api/v2/frequency-plans/EU_863_870
[2018-06-05 01:38:10] HTTP: Starting connection
[2018-06-05 01:38:10] HTTPS: Connection Opened: Starting TLS Negotiation
[2018-06-05 01:38:10] HTTP: Wait for TLS Connect
[2018-06-05 01:38:11] HTTP: TLS Connection Opened: Starting Clear Text Communication
[2018-06-05 01:38:11] HTTP: Got 1232 bytes
[2018-06-05 01:38:13] HTTP: Connection Closed
[2018-06-05 01:38:13] HTTP: Close active socket 1
[2018-06-05 01:42:38] SNTP: State change from 0 to 0
[2018-06-05 01:42:38] SNTP: State change from 0 to 0

Version 1.0.3 (master release) gives initially many timeout messages LORA: UART TIMEOUT. It doesn’t reboot however it does SNTP state change approx. every 10 minutes like

[2018-06-06 09:16:41] MON: SYS Stack size: 2831
[2018-06-06 09:16:41] MON: heap usage: 151KB (233KB), free: 188KB
[2018-06-06 09:16:43] SNTP: State change from 7 to 1
[2018-06-06 09:16:44] SNTP: State change from 1 to 2
[2018-06-06 09:16:46] SNTP: State change from 2 to 3
[2018-06-06 09:16:47] SNTP: State change from 3 to 4
[2018-06-06 09:16:48] SNTP: State change from 4 to 5
[2018-06-06 09:16:48] SNTP: State change from 5 to 6
[2018-06-06 09:16:48] SNTP: State change from 6 to 7
[2018-06-06 09:16:50] MON: SYS Stack size: 2831
[2018-06-06 09:16:50] MON: heap usage: 151KB (233KB), free: 188KB
[2018-06-06 09:17:00] MON: SYS Stack size: 2831
[2018-06-06 09:17:00] MON: heap usage: 151KB (233KB), free: 188KB
[2018-06-06 09:17:10] MON: SYS Stack size: 2831

Version 1.0.2 (stable release) reboots more faster after it tries to configure LORA module

[2018-06-06 10:15:41] LORA: Changing state from 2 to 4
[2018-06-06 10:15:41] LORA: Starting reconfiguration
[2018-06-06 10:15:49] SNTP: State change from 0 to 0
[2018-06-06 10:15:49] SNTP: State change from 0 to 0

Maybe upgrading the bootloader with the Microchip programmer would help?


(Arjan) #242

For the sake of the forum’s search, this was a new one for me, during a boot in version 1.0.3 with the factory bootloader:

CNFG: Load online user config state change to 4
HTTP: Close active socket 0
CONF: ERROR REQUEST

CNFG: Downloading gateway configuration failed

CNFG: Load online user config state change to 8

CNFG: Communication ERROR

…after which it basically stopped its boot and left the thing non-operational until pressing the Mode button. (Which I did after 16 hours; too bad I did not wait to see if it would still reboot for its daily firmware upgrade.)

Details in https://github.com/TheThingsProducts/gateway/issues/47


#243

Is there any communication being done by TTN on this?
Are there also people with working gateways? If so i’d say present them as a warranty back to TTN?

(I’m also an owner of a non functioning TTN gateway)


#245

sure … you live around the corner, did you contact TTN ?


(Floodnetwork) #246

Hi @BoRRoZ I personally can’t keep up with the multiple issues in the threads (assuming I’m looking at the right thread in the first place) so I’m wondering what you meant by “did you contact TTN?” If I can contact TTN outside the forums and subscribe to some progress update, like we had before the kickstarter was delivered, then that’d help a lot. Six months on and I’m still reading about reseating daughtercards and reboot loops, so I have to put it back in the box and keep deploying Multitech conduits until someone finds a fix for more than one device at a time.

Ben


#247

Hi Ben,

no this is the ‘official’ channel where updates ect are announced.
I said this especially to @admiral99 ‘did you contact…’ because he lives around the corner and then its easier to get in touch … probably.

but maybe I shouldn’t said that …I was thinking aloud … I don’t know more then you regarding the dev of new software and the status.

I know that you won’t see/hear the people with a 100% working GW in this topic off course.


(Floodnetwork) #248

No worries. How about 80% working? :wink:


#249

Guys,
crossed my fingers until now, my GW was working until last month, than reboot loop came. So today made some investigations, FW was in 1.0.2, so I updated (plugged Ethernet, time before reboot was longer) to 1.0.4 same thing, need to try with a SD to 1.0.3 but seriously why my GW started reboot loop, that’s a good question.

Anyway, what’s the official answer and fix to this problem?

If there a way to disable all WiFi stuff (or a firmware with no WiFi)? I think this test worth it because ethernet looks really more stable on my side (succeed to FW upgrade and never possible with WiFi)


(Smbunn) #250

I am on about 30% success with my gateway. I have a device sending a message each minute. The Chronograf image below is for the last 24 hours where each line is a signal coming in (I am plotting the channel used)
image

You can see the big gaps when the gateway goes down, but it always auto-recovers. Sometimes it is down only for 2 to 3 minutes, sometimes it is down for hours. The last 24 hours, I had about 50% up time as the image shows but over the weekend it barely ran at all. You certainly could not build a business on it.


(Peter Dtn) #251

gateway-delivery from Element 14 only around end of this year, long time, will we see serious updates / redesign in hardware? e.g. Raspberry as main engine running real Linux?


#252

No worries. I just got my gateway (2nd hand) to replace my rak831 as I expected it to be more ‘stable’ and less hassle: wanted to spend more time on the nodes than on maintaining a gateway. That did just not work out as intended. :wink: Should have done research I guess :slight_smile:

Updated to the beta firmware, let’s see if this helps. Was hoping to see some official FAQ page commenting on any (pending) updates.


(Abaretta) #253

FWIW, I have given up on the TTN gateway for now. It became so unstable it was not even usable as a development system anymore. More often than not a node testing session turned into a gateway troubleshooting session.

A while ago I bought a LoRaGo Port which just worked, and has continued to work ever since. It is interesting to note that the LoRa board in the LoRaGo runs just as hot as the one in the TTN gateway.


(Smbunn) #254

I love that comment “More often than not a node testing session turned into a gateway troubleshooting session” as that is exactly where I am at. I am working through issues on my node, and assume that a recompile has broken it when in the end it was just the gateway going down again.

Have you noticed that there has been no update on the gateway from the developers for some months now? If they could just tell us it is forever dead we could move on (and get our money back)