TTN GATEWAY central 2


#63

Yesterday i copied version
Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
Firmware: v1.0.1-91648b7e (2018-03-13T16:48:17Z)
on a SD card, but this version stay connected but after 5 minutes it stops with receiving messages.

Now i will try the new version
Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
Firmware: v1.0.2-475aef56 (2018-03-15T10:16:13Z)


#64

updated here also to Firmware v1.0.2-475aef56 (2018-03-15T10:16:13Z) auto update and it seems to work fine for the last 5 hours.

now how to update the bootloader… I have a pickit 3 that’s working with MPLAB IPE v3.26


(Willem (pe1dlf)) #65

so far no difference in operation, have had 3 reboots since I upgraded the firmware.


#66


(Martinaarts) #67

Update looked promising, all LED’s up. But after a short while the reboot cycle started again. Firmware was updated to 1.02


(Martinaarts) #68

Maybe i was too early with my comments. After another reboot the gateway is online. The console shows it is receiving messages, too. Unpacked the Node again and receiving data.

Great breakthrough, now hoping for gateway stability.


#69

Version 1.02 also reboots.


(Hylke Visser) #70

Could you be a bit more specific? Which version exactly? v1.0.2-475aef56 fixes a number of problems, but not all. If you still experience reboots, it would be very helpful if you could test the patch that @TTP mentioned above (unfortunately that one may also mention version 1.0.2, so please include the commit hash if you mention the version number). Also, if you have the possibility of reading logs from the gateway, that would be very helpful.

We’re trying to collect all feedback on Github so that everything is on one place and the @TTP team can focus on fixing things instead of spending their time looking for clues on the forum, email or even Twitter. So please use Github for any further feedback on the firmware updates.


#71

Hello Hylke,

I have switched “on” in the TTN console the following options:

  • Automatically update gateway
  • Beta Updates.

The gateway is now running with the following information:

Version Info
Hardware: v1
Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
Firmware: v1.0.2-475aef56 (2018-03-15T10:16:13Z)

Network
Uptime: 3550
Connected: true
Interface: WIFI
Wifi SSID: 88888888-Lora

Configuration
Activation locked: true
Config correct: true
Region: EU_863_870
Gateway Card: 868Mhz

Packet forwarding
Broker connection: true
Packets up: 401
Packets down: 9

Miscellaneous
External storage: false


#72

Hello Hylke,

Before the update with v1.0.2-475aef56, i have tried a patch (on a 16GB SD card) with version

  • Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
  • Firmware: v1.0.1-91648b7e (2018-03-13T16:48:17Z)

The gateway runs for longer time, but after 5 minutes the console sees no more messages.


(Willem (pe1dlf)) #73

@htdvisser I posted some additional log information on github, the reboot reason is consistent and always happens after below.

2018-03-15 15:18:10.107992 MQTT: Sending UPLINK failed: -1
2018-03-15 15:18:10.108014 
2018-03-15 15:18:10.108018 MAIN: MQTT error

(Magnatic) #74

My gateway had a reboot loop out-of-the-box. After updating to firmware 1.01 the reboot loop was solved, but whenever the gateway had to send a package over Lora it rebooted a few seconds later.

Updating to firmware 1.02 solved that last problem as well. The gateway is up for more than 17 hours now.


(Marcel Domingus) #75

Hi, guys,

I observed the same with the v1.0.1-91648b7e firmware 3 days ago, the connection with this firmware will be much more stable than with the 1.0.2 firmware but both versions will stop uplinking messages after 10 minutes or so.


(The Things Products Team) #76

The Things Gateway firmware build percentage over the last 24 hours -


#77

My gateway (v1.0.2-475aef56) stopped sending messages on 13:26 and starts on 15:01 again.


(Pfiadi) #78

1.0.2 does not work for me. Keeps rebooting. 1.0.1 used to be okay until a few hours ago. Lost broker connection. So gateway is again dead after a few lucky days :frowning:


(Casper) #79

Received my TTN gateway a few days ago, trying to set it up, but it keeps rebooting.
I entered correct WIFI/PW (on two different WIFI networks), it boots, 2 LEDs on… 3rd LED on, then back to 2 LEDs and then it restarts. Have tried re-activating, powering up with mode button pressed, …

Is there a solution for this, because it looks like I am not the only one who is experiencing this?


(Samuel) #80

That worked for me https://github.com/TheThingsProducts/gateway/issues/1#issuecomment-372740116


(Casper) #81

thanks Samuel, I’ve tried updating the firmware (it is now v1.0.0-917719b9 (2017-06-26T17:59:33Z)), still the same behaviour. Bootloader is r1-7167873a (2017-06-02T13:48:18Z)

Configuration
switches between:

Activation locked: true
Config correct: true

Activation locked: true
Config correct: false

q: to update firmware place SD card with firmware and checksum in updat folder in GW and unplug / replug power, correct?


(Samuel) #82

Correct, during the update, the leds should fade around