TTN GATEWAY central 2


(Samuel) #83

Maybe try to delete the Flash after the update (Keep Mode pressed, during plugging in the pßower cable


(Casper) #84

update does not seem to work. Firmware is still v1.0.0-917719b9 (2017-06-26T17:59:33Z) (seems like an old version, right?). What is the latest firmware version?

Is there another way to update the gw? Via SSH?


(Casper) #85

what does ‘fade around’ look like? I see 2nd led on while 1st led slowly flashes.


#86

Oh dear - even after the latest upgrade, my TTN gateway is dropping its wifi connection and fails to rejoin. It ends up with first led on and second flashing fast.
It took 4 power restarts to get to 4 leds…
…This didn’t seem to happen as frequently before the upgrade…


(Samuel) #87

That looks not like updating :wink:
When update, 4 or five leds will fade around… you will recognice it, when its doing the update


(Yoeri) #88

After upgrading to v1.0.2-475aef56 (2018-03-15T10:16:13Z) my Gateway seemed to be stable, and I could finally play around with my Node. However, … after some hours, it ended up in a reboot loop once more. :frowning: I did not unplug it.


(Samuel) #89

Maybe do the update again and disable auto firmware updates in the console


(Yoeri) #90

Even if the /info still shows the same version…? I will give it a try!


(Casper) #91

I don’t understand why the update is not happening:


(Stic Ttn) #92

Hello,

We have a Things Gateway on-the-shelf and we try install it the appropriate documentation, https://www.thethingsnetwork.org/docs/gateways/gateway/

We follow the activated procedure and have selected the 868MHz frequency and the european server.

The result is the three leds of the gateway are “on” during some seconds and the gateway restarts the installation procedure. We don’t overcome the last step to have a connected gateway.

So, we have a question related to the TTN packet forwarder protocol, because this kind of gateway implements only the Semtech UDP packet forwarder and we have seen that this protocol is deprecated but is it still running on the server?

Or do you have any information related to this kind of behavior for this gateway?

Thanks,

Joel


(Reinier van der Lee) #93

@casper Had alike experience, no update after inserting SD card. I found in the gateway log that SD card update only happens after the LoRa card accepts configuration. I have two gateways and swapped LoRa modules. When I insert a LoRa module from a “good” gateway, the SD card update runs fine. With a non-working LoRa module, there is no firmware update.


(Arjan) #94

That’s not my experience. Mine updated right after applying power. (And with the original firmware it was getting into the reboot loop when trying to configure the LoRa module, so it never configured that before updating.)


(Reinier van der Lee) #95

@arjanvanb, see my logs posted on March 13. Did you update both the bootloader and firmware? Maybe the bootloader update changes the startup behavior to load the firmware before configuring the LoRa module?


(Scottv H) #96

Same here, made a SD card and placed files like instructed.
when applying power Led 1 is off and 2 blinks fast.
After this LED 1 will turn on and it starts trying to config. -> bootloop

the gateway unfortunately did not update.

later today ill try different sd cards and ways to format (win/mac etc) and logging the gateway

Good to read that people are working hard on resolving the bootloop and other problems! Needs to be said more often I think.


#97

I was ready to turn my Gateway in, but it updated itself last week and now it seems to be running without sudden reboots (still once every 24 hours but that’s by design) a couple of days already. Looking good!


(Reinier van der Lee) #98

@ScottvH I may have been overlooking the obvious, but how did you get that gateway info page?


#99

Vanduino: “how did you get that gateway info page?”

I think I’ve generally used the gateway’s IP address with /info appended at the end, but I’ve also seen references to: http://things-gateway.local/info


(Pfiadi) #100

A few days ago I tried firmware 1.01 (2018-03-13) and got a stable running gateway for >10h. Then I started transmitting data … looks like this causes the gateway to constantly reboot. All other firmware versions failed right from the beginning. Nope - didn’t do any further debugging - easter vacation first :slight_smile: Eventually the next 2 weeks will bring some groundbreaking improvements from the developers.


(Scottv H) #101

@Vinduino, Like sronan said, you’ll need to be on the same network as the TTG is.
So at step 2 on the “Things Gateway - xxxx” network, or in step 3 when TTG has accepted the connection to your own WIFI / LAN.

i used http://things-gateway.local/info in a new tab.

With 3 LED’s solid on, it seems the config of the LoRa Card was complete…

shortly after it rebooted and didn’t come this far anymore. next reboot looked like this
Version Info
Hardware: v1
Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
Firmware: v1.0.0-917719b9 (2017-06-26T17:59:33Z)

Network
Uptime: 3907
Connected: true
Interface: WIFI
Wifi SSID: ZZZZZZzzzzz

Configuration
Activation Locked: true
Config correct: false
Region:
Gateway Card: ND

Still didn’t update, but stayed on for some time.
Don’t understand why it won’t update…
4GB SD FAT-32
SDCARD
└── update
… ├── checksums
… └── firmware.hex

Tried it on windows and Mac, only thing i didn’t call the SD: “SDCARD”, didn’t think this would matter.


(Reinier van der Lee) #102

@ScottvH, @sronan, Thank you!