TTN GATEWAY central 2


(Remko) #103

Today I flashed my first gateway with the latest bootloader using my fresh puchased PICkit4:

Version Info
Hardware: v1
Bootloader: r2-c463e87e (2018-02-23T14:42:40Z)
Firmware: v1.0.2-475aef56 (2018-03-15T10:16:13Z)

Only observation I have is that the programmer is complaining about an incomplete load:

2018-03-22 19:21:54 +0100 - Loading hex file. Please wait…
Loading code from C:\Users\drasv\Downloads\TTNGatewayFirmware\firmware-with-bootloader.hex…
Warning: C:\Users\drasv\Downloads\TTNGatewayFirmware\firmware-with-bootloader.hex contains code that is located at addresses that do not exist on the PIC32MZ2048EFM144.
Code incompletely loaded.
2018-03-22 19:21:55 +0100 - Hex file loaded successfully.

Not Nice and not good for your self confidence.


#104

now I’m confused :thinking:
I thought it worked for you ?


(Remko) #105

@BoRRoZ Yes it worked !
As you can see the bootloader was:

and is now:

My problem is that the programming software is complaining at the load of the new firmware:

Normally that is a sign that someting is wrong and the upload can potentially fail.
I felt as it was a gamble to try but you convinced me that it would go well. :cold_sweat:


(Willem (pe1dlf)) #107

I posted the same about that message here kersing mentioned already just to ignore it …


(Remko) #108

Thanks for noticing. I lost track of a lot of valueable information in this thread. :frowning:


(The Things Products Team) #109

Update:

Thanks to all the people for helping us test a new patch that should make communication with the LoRa module more reliable and reduce the number of reboots caused by the module communication failures identified by a LORA: RESET MODULE log message.

This patch has been pushed to our beta release channel, and should automatically be installed within the next 24 hours if you have automatic updates on, and are subscribed to beta updates. You can do this through the gateway settings on our console.

Unfortunately some gateways are rebooting before the firmware update can be pulled from our servers. Those gateways can be updated using a SD card or using a Microchip programmer

It would be really helpful to have more beta testers for fixing issues more efficiently. If you are happy to help out, please signup here.


The Things Products Team


#110

why did I make a cable for that ? :sunglasses:


(Remko) #111

I just updated one TTN Gateway with the beta channel release. This gateway is using the latest bootloader

Version Info
Hardware: v1
Bootloader: r2-c463e87e (2018-02-23T14:42:40Z)
Firmware: v1.0.3-2c56ce09 (2018-03-22T12:20:52Z)


(Pfiadi) #112

Update using an SD Card went smooth:

Version Info
Hardware: v1
Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
Firmware: v1.0.3-2c56ce09 (2018-03-22T12:20:52Z)

OTAA joins used too take ages with the old firmware (v1.01, same nodes). The gateway is up for >15 minutes and receives/transmits data.


#113

did the previous firmware version also counted the uptime per 2 on the GW info page ??

  • running 8 hours without reboots… looks promising :sunglasses:

(Remko) #114

The same happens on my gateway


(Reinier van der Lee) #115

Confirm, I downloaded the developer pre-beta version on SD card, and left it connected/rebooting. The gateway that was previously not working accepted the firmware update 1.0.3, and is now working.

Good job TTN team, have a great weekend! :grinning:

TTN%20gateway%20success!


#116

With 1.0.2 firmware I was regularly seeing reboots several times an hour, typically every 10-15 minutes, although at least once it did see it hit about 8 hours. Thankfully it has worked pretty well otherwise.
Last night I updated to the latest beta (1.0.3) via the console setting and it hasn’t rebooted since. Uptime over 20 hours now.
Time to set up my second gateway. Any maybe update the bootloaders while I’m at it. :slight_smile:

And @BoRRoZ yes the uptime counter has alway incremented in 2’s from what I’ve seen.


(Dbrouwer) #117

Hello from California!

I am having nothing but trouble. I have 2 of the Kickstarter TTN Gateways. I tried them on FW 1.0.0 and they both would not connect. So I updated to 1.0.3 with the SD card (verified that they update to 1.0.3 here: http://things-gateway.local/info) When I am setting up each gateway, they usually either get stuck in LED Pattern “connecting to the internet” or “still activating”. Though I have seen every non-documented LED light pattern imaginable (blinking on LED1 only, fast blinking on LED4 with all other LEDs ON, etc) . Sometimes they get into the reboot every 5 seconds or so loop, but usually not.

I have tried pushing the pink button, holding the pink button when powering the gateway up. Holding the pink button for 5 seconds.

What is really weird is I had success at first. One of my gateways connected for about 2 minutes and showed connected in the Console.

I am trying to connect over ethernet and over wifi. I am in California so have chosen Frequency Plan: United State 915 MHz (I feel like I had slightly more success when in desperation I tried Europe 868 MHz instead to see if the problem was that something in the USA was down)

I have not had any success for about a week of trying this when I have time.

Thanks for any help you can provide (I must be missing something). Id be especially interested in knowing if there are others with TTN Kickstarter gateways in the USA that are having trouble.

P.S.: I have previous experience with a TTN Gateway working: I connected a gateway in Europe that I bought from Newark and it connected right away and worked fine. So I know it can be done.


(Reinier van der Lee) #118

I had success after loading 1.0.3 on SD card and selecting “Beta Updates” in the General Gateway settings. Left it connected via Ethernet for a few hours, and found that the gateway accepted the fw update and has been working stable for 24 hrs now.


(Dbrouwer) #119

OK, a little update. I was able to get my gateways to work at a different location with a different (more standard IP address range 192.186.1.xxx). Im guessing the range on the network Im having issues with might be the issue: 10.100.253.xxx. But that is just a guess at this point.
Im still having trouble though on even the network that does work. I can only get the TTN Gateway to connect over ethernet when I first set it up. Im able to see it connect in my Console, and I am able to send data via it using my TTN node (and see the data in the gateway traffic). As soon as I power cycle my gateway, it does not connect again. I then have to remove the gateway from my gateway list and activate it again in order for it to connect and transmit data. It keeps working as long as I do not power cycle it.
One time I got it connected to my Console and it did not transmit data via the node. Had to go through the steps to remove it from the gateway list and add it back in for it to work. It is working now, because I am not power cycling it.
By the way, can you have non-standard characters in your wifi password for the network you want your TTN gateway to connect to? For example all of these characters?: !@#$%^&*


(Jurrien) #120

Unfortunately no luck with the new beta release. Still have the same issue: after having the gateway disconnected for couple of days, it works for about 5 minutes like got connected and gateway traffic shows up in the TTN console. But after 5 minutes either it stays online but stops forwarding traffic or it starts rebooting.

The update was loaded into the gateway by using a SD card but the gateway stops working after 5 minutes and won’t reconnect anymore.

Hardware: v1
Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
Firmware: v1.0.3-2c56ce09 (2018-03-22T12:20:52Z)

Now it got stuck with UART timeout:

LORA: UART TIMEOUT
LORA: Close and reopen UART on 115200 baud.
LORA: Changing state from 2 to 1
LORA: Wait init complete, check for communication on 115200 baud.
LORA: Changing state from 1 to 2
MON: SYS Stack size: 2870
MON: heap usage: 151KB (237KB), free: 187KB
LORA: UART TIMEOUT
LORA: UART TIMEOUT
LORA: UART TIMEOUT

(Remko) #124

Observation: the TTN Gateway with the beta channel release “Firmware: v1.0.3-2c56ce09 (2018-03-22T12:20:52Z)” is not forwarding any packets at the moment.
Console is telling “connected” and last seen updates at regular intervals but nothing in the traffic window. also the received messages counter is not incrementing.
When checking the application of a node in the same room I see that no traffic is passing trough the TTN gateway.


#125

I can’t confirm this… here it’s 100% @ the moment

noproblemo


#126

Gateway here with version 1.03 is also not responding. Last seen 20 minutes ago.