TTN GATEWAY central 2


(Remko) #128

We make them rich :clown_face:


(Remko) #129

I just noticed that may TTN Gateway has started forwarding packets again.
I cannot determine if this was a back-end issue or a gateway issue. :frowning:


(Dbrouwer) #130

I can now get both of my gateways to work on different networks. One on ethernet the other of wifi. I still think that the gateway does not accept non-standard characters such as !@#$%^^&* in the wifi password of the network you want it to join.

Now what I am having trouble with is that as soon as I power cycle my TTN gateway, it will not reconnect. It goes through a boot process but ends up with LED 1 slow blinking. I have to remove this gateway from my console, then add it back in, in order for it to activate. If I do not power cycle the TTN gateway it keeps working for days.

For those of you that are running
v1.0.3-2c56ce09 (2018-03-22T12:02:04Z) are you able to power cycle your gateway and have it keep the settings to be able to reconnect to TTN?


#131

Hmmm… yeah, after a power cycle on 1.0.3 I now only get two solid lights, and one blinking.
And in the info webpage I also see “Broker connection: false”
I’m going to leave it for a while and see if it comes good by itself. Else I’ll try a booloader update.

And I can confirm that it won’t accept an ampersand in the WiFi password. I had to use ethernet at one location.


(Dellekom) #132

New question, did not find anything in the FAQ, so here we go:

I am using a TTN Gateway, hardware v1 and software v1.0.2-475aef56 (2018-03-15T10:16:13Z).

For I have connected the gateway via LAN / Ethernet, I do not need neither the accesspoint mode nor the wifi client mode. I would rather like that the Gateway does not in any way listen or interfere to any Wifi signals.

How do I turn Wifi off?

Is there a documentation für the Gateway by now?

Thanks
Andreas


(Dangarlen) #133

Unable to activate a new TTN Gateway
When attempting Gateway Activation Configure (Step 3)
(a successfully registered gateway (Things-Gateway-001EC03B3B8E )
After Reset (power cycle while holding pink button)
with Ethernet disconnected, LED1 solid ON, LED2 flashing, LED3-5 OFF.
Using Chrome on Win10 Pro
(same results with Firefox ESR 52.7.2 (64-bit) and Microsoft Edge 41.16299.248.0)
After filling in WiFi SID, Security Mode: WPA 2 Personal & Password
and pressing “Configure Gateway” Button
Immediately received following message:
Request has been terminated.
Possible causes the
Network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page
Subsequent Button presses give cause the same error message.
Updated to The Things Gateway Firmware from 3/15 version via SD card
(from https://github.com/TheThingsProducts/gateway/tree/master/firmware )
yielded same results.
Attempted with Ethernet activation. Also, same results.


(Jac Kersing) #134

Not a new question, you asked it the same question in “How to turn off Wifi (even Wifi client)?”, the answer is still: not possible.

Please do not post the same question multiple times, it will not change the answer.


(Remko) #135

Where the latest version caused failures like

  • stop forwarding of packets while shown conneted and updates
  • lossing connection

I have decided to revert back to version “v1.0.2-475aef56 (2018-03-15T10:16:13Z)”


(Dellekom) #136

Sorry, last time I did not receive an answer. As this is Open Source I assume, shouldn’t I be able to ssh into the thing and turn it off? I could as well desolder the Wifi unit as - you know - it is still my device.

Also I am one of the folx starting the rollout in Freiburg. It it will stay this way I’ll definitely recommend a different gateway.


#137

“How to turn off Wifi (even Wifi client)?”, the answer is still: not possible.

and now I quote kersing :wink:


(Jac Kersing) #138

Why do you assume open source equals Linux? The device runs embedded software, not an operating system. However as it is open source you can take the source and make the changes you require. If you do (not when because I think the chances of anyone in the community contributing this (or any other) feature are zero) please feed it back so others can ‘enjoy’ the same new functionality.

Yes it is. Including downloadable schematics and the sources to the firmware. That is more then can be said for a lot of other offerings where you (if you are lucky) can change a setting or two.


(Abaretta) #145

I didn’t read anything about Linux, who is assuming what? I think @dellekom’s questions are fair (if a little repetitive ;-), no need to get so defensive.

Whether to recommend the TTN gateway for a community deployment is a fair question as well. There are other options, including outdoor models which may be a better fit as they give more mounting/installation possibilities. Perhaps it helps to think about how the gateways would be used and placed in the community, how many members would be willing to build something themselves, or perhaps collectively place a proper outdoor unit on a tall building, etc. The TTN gateway will surely not be the gateway of choice in all scenario’s.

My TTN gateway has been completely stable for well over a week now, which is a record for me :grinning: From my perspective development appears to be going in the right direction. Before you know it the ability to disable wifi is included as well… :wink:


(Jac Kersing) #146

Linux: Based on the assumption SSH works. (And given most gateways use some embedded Linux it would not be a strange assumption, but it isn’t true for the TTN gateway)

Fair: Yes, it would be very nice to have that option. However, posting the same question twice on the same forum with both marked ‘new’ is a bit pushing buttons… (may-be I should not respond) Is that fair?

It certainly is. For an outdoor gateway I would at least seriously check available options before deciding to invest into making the TTN gateway outdoor proof. May-be my owning 7 RPi based gateways tell you which direction I would go (may-be I just haven’t tried the right alternative yet)?


#147

Is version 1.02 somewhere available. Using version 1.03 gives in the console a message that is connected but i see no messages.


#148

Not ideal,
but to cater for the WiFi problems, I use a hacked SONOFF WIFI switch to power my TTN gateway. (Code won’t win prizes but it works well for me)
It checks for 2 things and controls the power to the gateway accordingly

  • Check if broadband wifi is present every 5 mins. If it is then power up, if not then switch off (This is useful for me - I just use the presence of WiFi to control the gateway being on or off)
  • Check if the TTN Gateway SSID is seen, This can happen in WiFi fault conditions. If it is seen, the gateway is switched off for 5 mins and then the SONOFF tries to connect again

(The Things Products Team) #149

Update

After releasing the new firmware version last week, we have been monitoring the performance and checking up on the issues reported by people here. There are 3 main things so far:

  • Reboot loop 0x10
  • Reboot after MQTT error
  • Network connection issues

Thanks to @Borroz, @Vinduino, @dicktonyboy and others for providing their inputs as well as logs to help us dive into these issues. In some cases, we noticed that the MQTT connection fails and recovers due to which there are no uplink messages. We are working on releasing a patch which solves the WiFi disconnection, and could potentially fix many of the other issues. We will inform the people who signed up as testers and in case more people are keen please let us know here.


The Things Products Team


(C Mourouzis) #150

Hello,

I have a TTN gateway.Everything was working fine for almost a month (first activation one month ago) and two days ago the gateway got disconnected (status in console and last package received was two days ago). I tried everything. Resetting, deleting the gateway and reactivating it, reactivating it with different name, connecting using ethernet and wifi. The gateway is stuck to the activation process. The led status is 3-slow (still activating) and after a few seconds the gateway reboots-connects to the internet (led 2 ON), tries to activate and reboots again.

Anyone else had the same issue? What might be wrong?

Thank you.


(Van Knijff) #151

I’m unable to activate the TTN gateway.

On the TTN Gateway I have two leds on and the third led blinking .

  • internet conectivitiy seems to be astablished.
  • the TTN Gateway is registered at TTN console.

But I’m not able to pass step 3 in the activation process.

Any suggestions on what to do next?


#152

24h

24 hours without one reboot :sunglasses: now


(Willem (pe1dlf)) #153

did you have reboots related to MQTT failures? Just curious to know if upgrading for me is useful to do …