TTN GATEWAY central


(Arjan) #475

Did you try to push it into its socket a bit more? (As nothing happens after trying to send the first command, and not even any error is printed.)


(Verfacil) #476

I would actually prefer to fix the IP address. How do I do that with this TTN gateway?

Can I SSH to it and configure all of these details?


(Willem (pe1dlf)) #477
  • NOT FOR HAND MODIFICATION
  • This file is automatically generated by the MPFS2 Utility
  • ALL MODIFICATIONS WILL BE OVERWRITTEN BY THE MPFS2 GENERATOR
  • Generated Mon Dec 18 2017 03:24:47

I suppose the html sources are outside the source tree and missing …


(Enkion) #478

I got a gateway and tried to set it up.
It does not overcome the message activating.
Tried several times, also resetting the gateway, but it does not work.
Is there something I’m doing wrong or is it something else?


#479

Hi guru,

I would follow the suggestion of Arjan. Mine works after I pushed it in a little further.
It also now works with the original firmware.
Stupid enough I made the debug cable afterwards, so I do not have any log of the failing situation.


(Guru) #480

Yeah. Pushed in and tried at varying angles and pressure points. I’ve even completely removed and blown in the socket and then remounted with a strain-o-matic. Still identical results :confused:


(Arjan) #481

Seems like your LoRa module is much closer to the gateway’s PCB than mine. (At the side of the plastic fasteners.) Also, the fasteners look different, or are those the “strain-o-matic” you’re referring to?


(Guru) #482

That is where I’ve replaced the supplied hardware with screws so I could vary the angle. I tried the original hardware with many different pressures and angles and insertions too :slight_smile:


#483

Take care about reseating connectors. They have a suprisingly low life cycle of “removal and reseat”.
https://www.cirris.com/learning-center/product-articles/other-products/227-connector-life-cycles

unless you are sure the connector is the problem, best to leave well alone.


#484

I’ve posted https://youtu.be/emWBPPhOpck


#485

great ‘BBC’ voice !


#486

if you keep hitting F5 - refresh you should see the values cycle - to no end but you should see it


#487

I was just thinking that you might be able to set the DHCP server to statically reserve a particular IP address for your gateway’s mac address, and that that might help if the gateway has a problem with DHCP lease renewal.
Whether you can additionally ssh in to your gateway and assign it the static address there is beyond my ken. But I’d guess others here would know and might be able to help answer that question.


(Enkion) #488

Pushed the reset button a bit harder this time.
Then followed the activation steps again.
But the gateway still not activated.
Led 1 and 2 are on, led 3 blinks slowly, meaning still activating


(Guru) #490

Too right! IIRC the Intel Edison connector was rated was something amazingly low like 10 cycles :slight_smile:


(Arjan) #491

From GitHub 4 hours ago:

We are working on the issue to solve the root cause of the communication failures (more on it later today on the forum).

Also, my gateway lost its WiFi connection over an hour ago, and could not recover without cycling its power, like others have seen as well. Some observations:

  • I think it had been running for about 20 hours. (Certainly not a full day; I took a picture at 9 PM last night, when it was not connected; at around 6 PM today it showed as “Last seen: 54 minutes ago”.)

  • It might have been in AP mode (LED 2 flashing slow and fast).

  • Plugging in a debug cable with GND, RX and TX somehow restarted the gateway. So to get serial output of a running device maybe only connect GND and RX, to lower the chances of an accidental reset? (Same when not using TX.)

  • The unexpected reset of the gateway did not resolve this.

  • After the reset, it kept reporting things like:

    INET: Trying to connect to WiFi router again (after 120 seconds)
    INET: State change to 0
    MON: SYS Stack size: 3959
    MON: heap usage: 148KB (148KB), free: 191KB
    INET: No Ethernet and WiFi link (after 10 seconds)
    INET: State change to 1
    
  • The FRITZ!Box 7360 WiFi AP did not log any connection attempts.

  • Restarting the WiFi AP did not resolve this. All other devices (Sonos, Apple TV, Chromecast, laptop, tablet, telephone) reconnected just fine.

  • Attaching an ethernet cable did not resolve this. The connector’s LEDs were flashing, but I forgot to check if the router showed a connection.

  • Finally cycling power resolved it.

I was surprised to see there was no GitHub issue yet, so here goes: https://github.com/TheThingsProducts/gateway/issues/8

I forget to check which LEDs on the PCB were on.


(Grahame Horner) #492

IMHO correct and accurate logging is a must, if this was tested then frankly we would be see these issues, and if logging was actually show true reliabile information it may be easier to trace these issues and provide quicker resolution. but all your efforts seem to be highlighting issues that hopefully will be fixed and in the new firmware soon @arjanvanb great work :+1:


(Grahame Horner) #493

Hmm :thinking: makes diagnoses of issues with a running gateway a little difficult if you don’t already have a serial device connected may be time to do a little #esp8266 serial to UDP devices :thinking: for remote debugging


(CyberJunky) #494

Are there any forum members or developers following this thread who own a debugger device (pickit3/icd3 etc) and can read the 2MB flash contents from their gateway using mplab_ide and/or mplab_ipe and the ISCP port? This would help me a lot, thanks!


(Arjan) #495

Just a heads up:

:warning: New firmware will be released soon, so for those who cannot complete activation (hence: for whom the gateway reboots before checking if new firmware is available): make sure you’ve got a microSD card, and whatever needed to write data to that, at hand. It will need FAT32. The previous firmware expanded to about 2.8 MB on disk, so any small storage size will do I guess. I don’t know if there’s a maximum size.