TTN gateway, Tektelic Kona Micro Lite


Can someone help me create a proper customer_conf.json file. I have a Tektelic Kona Micro Lite gateway that want connect to TTN. i have registered my gateway in TTN but it says “not connected”, the firmware and the lorawan_conf.json is downloaded to the GW. Im almost sure the problem is customer_conf. I would appreciate some help.

The Tektelic support is poor and there is no manual for the Kona Micro Lite GW.


Written targetting the Kona Micro vs Kona Micro Lite so I dont know if this tutorial (adjusted for which ever region/freq plan you need to operate under) would help or be applicable?

Have just picked up a Kona Micro and looking at this as an option under .eu. vs faffing with registering to access docs and visual s/w as author says :wink: (I may try both options to gain experience the alternate ways)

Thank you, I will try this.

What firmware have you loaded to it? I banged on the Semtech in the end (legacy) - works perfectly.

This doesnt look like my gateway. There is nothing like config.json, my Micro Lite wants files like “custom_conf.json”

“Kona Micro Lite” is a new name of “Kona Pico”.

1 Like

They renamed Kona Pico to Kona Micro Lite and that created some mess.

Should be something like this:

If you’re not in EU, replace “” with proper router name.

Same here! Did you use the Windows app to set it up?

No, the KonaFT doesnt work on Micro Lite.

Thank you Hobo, I think this is correct. But i dont understand which password it is. And how can the Micro gateway connect to the gateway in my TTN-account? I guess its using the Gateway ID.


Ha! That’ll be the problem then :grinning:

tftp is pretty good though, but really they ought to make this clearer in the docs.

The gateway is up and running. Thanks for your support.

1 Like

I’m trying to connect a Kona Micro Lite for the first time. I uploaded the semtech.v1.7 firmware and copied customer_ttn_EU_legacy and EU868.default.channels.LoRaWAN json files (provided by Tektelic support) in, respectively, Customer.json and LoRaWAN.json using tftp.
I registered the Gateway on TTN V3, using the “+ add gateway” registration.
Since, the gateway status remains as “disconnected”.
I checked the gateway EUI, it is correct.
I also checked the current version of the firmware as well as configuration files using the tftp GET function. Everything seems ok.
Any idea where the problem could come from?

Sounds like that one will point to V2. You need a configuration on the gateway that refers to If it doesn’t it won’t work for V3.

Thank you! I modified the configuration file and it works.
Now I face a new problem : in the live stream of this gateway, a new message is displayed every 30 seconds named “receive gateway status”… I guess this is not normal, is it?!

Live stream

Yes that is normal - GW’s - depending on config and packet forwarder used - will send a status message/keep alive on a regular basis to the NS so it knows the GW is still connected even if no traffic coming through. 30sec is a common period and many GW’s allow this to be modified - 30s is a good compromise between finding out a GW has gone quite and the amount of traffic handled by the comms link and back-end. If you feel this is too frequent check the GW config sw as there may be option to extend update period - 60 sec, 5 mins - 15 mins or what ever you are comfortable with or the system allows.

Don’t modify it, the backend needs regular (<60 seconds) keep alive packets to know a gateway is active and can be used for downlinks.

1 Like

Thanks. I also have a TTIG connected on TTNv3 and don’t see these messages in the live stream. Do you know why?

Ah yes of course knew that but wasnt thinking! Dho… caught out by fact early TTIG deployments only ‘connected’ via web sockets when they had traffic to send and often quickly timed out making me think >60s was kinda ok…but no! :wink:

@Claireh91 TTIG uses BasicStation protocol with other handling procedures that would explain the lack of specific status messages…