Unable to connect/join my end node to network

I am using SX1262MB2CAS shield with NXP MCU running LoRaMac-node.I successfully added my end node (with required information) on Things Network community edition. I am able to check the status and see DevEUI but I am unable to join the network. I have checked DevEUI, AppKey, NwkKey etc. and these looks ok. Please suggest. if i am missing something.


It appears that there was a default DevEUI configured on this device, “app status” command returned DevEUI and I was unable to register/add the device with this EUI and JoinEUI as all zeros (I got error message that DevEUI with JoinEUI already exists) so I tried with different JoinEUI ( 00 00 00 00 00 00 00 01) and I was able to register the device.

Community US gateways will be using FSB2.
Is your device set to use channels 8-15?

Thanks for this info. Yes device is set to use channels 8-15. It appears that there are only 2 community gateways available in whole Maricopa county. I have ordered Things gateway for my trial since i wasnt able to connect to community gateways.

Hi Jason,

I tried again with community gateways in Maricopa by going into vicinity. I saw join request message exchanges (please see below snapshot) but the session information showing pending and i am not able to send uplink data.

Your use of LoRaWAN v1.1.0 is highly ambitious - most devices shipping today are on v1.0.3, the more up to date are on v1.0.4. Whilst TTS does support v1.1, there could be any number of wrinkles in LoRaMac-node for v1 but work on v1.0.4 has been completed so is likely to be ‘better’ in so much as shown to be working in the wild.

To put this in context, the oooh-shiney all-new STM32WL series of integrated MCU & radio (SX1262) comes with LoRaMac-node v4.5.2 which is v1.0.4.

For values of “all-new” being a couple of years old now - everything lags behind.

The really old favourites, like the Murata ABZ, uses LMn v4.4.7 which provides v1.0.3. The Arduino LMIC stack has just reached v1.0.3 compliance.

So you may want to try prior releases with lower versions on TTS.

But mostly, you should get your own gateway - a TTIG costs far less than waiting for the SWAT team to take you out as you wander around a major US city with a home-made radio & a laptop whilst poking the screen intensely.

All that said, if you went and purchased a SAMR34 Xplained Pro Board, you might find the gateway owners would be happy to help you get going …

1 Like

Thanks Nick, i am gonna try with earlier versions v1.0.4 may be.