Uplinks get lost in V3, and too many downlinks

I am measuring temperatures in my beehives.

Setup: cubecell-AB01, EU868, ABP, ADR=off, UNCONFIRMED uplinks, measurement every 15 minutes, deepsleep in between. My own Things Indoor gateway handles all traffic.

This worked great under TTN V2.

Migrated the gateway to V3, everything still worked.

Reprogrammed my nodes. Identical to V2, but with new Keys and devAddr as taken from V3 console.

All uplinks reach my gateway, but only some 30-50% reach my application. Strange.

More worrying is that downlinks are generated somewhere (not by me), for some 10-20% of the uplinks.

My nodes receive these downlinks before going into deepsleep, but my code takes no action on it. Should it, or should all be handled automatically?

Any hints on how to proceed?

Browsing this forum shows different sets for the advanced mac settings. Does anyone have a set for EU868 and cubecell that works?

You may want to look at:

as that appears to have some similar issues.

As for downlinks, those are likely to be MAC commands from the Network Server trying to set settings.

I think I have cracked both issues, all traffic now reaches the application and the unwanted downlinks have stopped.

I have modified RegionEU868.h as downloaded from heltec as follows:

  • Receive delay 1, changed from 1000 to 5000
    #define EU868_RECEIVE_DELAY1 5000

  • Receive delay 2, changed from 2000 to 6000
    #define EU868_RECEIVE_DELAY2 6000

That was all, at least for ABP. Works now with PlatformIO and Arduino IDE

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.