V3 local_conf.json "serv_gw_key": "what value?"

Just having a quick experiment with migrating my v2 gateway to v3 (obviously without deleting my v2 definition so I can swiftly swap back)

However mp_pkt_fwd is hitting an issue with: “ERROR: [TTN] Connection to server “eu1.cloud.thethings.network” failed, retry in 30 seconds”

I have managed to convince myself that the issue is the value in local_conf.json “serv_gw_key”: “value”

With v2 the Gateway Key is generated for me by the console and is of the form ttn-account-v2.blahblahblah

But how do I generate an equivalent Gateway Key in v3 to go into my “serv_gw_key”: “value” ?

I see “Add API key” function in the v3 console but obviously cannot see the wood for the trees :wink:
Do I use one of those to generate a Gateway Key ? And if so which?

Any comments much appreciated!

(If I can just satisfy myself that the migrated gateway can talk to eu1.cloud.thethings.network I will feel much happier about the looming v2 switch off, but I’ll keep the v2 gateway running for as long as possible)

You need an API key with

Link as Gateway to a Gateway Server for traffic exchange, i.e. write uplink and read downlink

For the host entry you need to append :1881 for the correct port.

And with MP forwarder you could consider connecting to both V2 and V3 by adding entries for both.

1 Like

Thanks @kersing I will give that a try.

Fantastic - that worked!

13:03:16 INFO: [Transports] Initializing protocol for 2 servers
13:03:16 INFO: [TTN] server “bridge.eu.thethings.network” connected
13:03:16 INFO: [TTN] server “eu1.cloud.thethings.network” connected
13:03:16 INFO: [main] Starting the concentrator
13:03:19 INFO: [main] concentrator started, radio packets can now be received.
13:03:19 INFO: [up] Thread activated for all servers.

The subtle bit I was missing was the port 1881
Thank you so much :smiley:

1 Like

i’m tryin to get my gateway on the v3 with no succes. could i get a screenshot of your local_conf.json file?

Please don’t do screen shots for text files.

There is a button on the gateway page that will download a conf file for that gateway.

This is my local_conf.json file. is it correct that the serv_gw_id is the same as my gateway id?
thanks !

    "gateway_conf": {
        "gateway_ID": "FFFEb827e*****",
        "description": "joachimindourgateway",
         "servers": [
               "serv_type": "ttn",
                "server_address": "eu1.cloud.thethings.network",
                "serv_gw_id": "FFFEB827E****",
                "serv_gw_key": "NNSXS.CQ6YM67E7M5PAYV5YB4LHX3SUS445ZGL3F2EQBY.M3EJ6UNPVUPIJ7ZD6ZSX65BV2PP*****",
                "serv_enabled": true
        "gps": false,
  "fake_gps": true,
  "ref_latitude": 0,
  "ref_longitude": 0,
  "ref_altitude": 0,

The Gateway ID on the console is for your personal identification of your gateway. The Gateway EUI is, confusingly, called the gateway_ID in the conf file.

There is no way that your EUI would start FFFE - anytime we use FFFE, it goes in the middle. And it goes on public record so there is no point ***** it out.

Given the made up EUI, can you tell us what gateway you own - brand and model please.

It’s not clear if you tried downloading the configuration file from the console as suggested?

I’ve formatted post as per guidelines - please use </> on the toolbar to format blocks of code, logs or conf files.

Hi @joachim1111 I suspect your hardware is different to mine, but for what it’s worth, the main difference I see looking at my own local_conf.json is…

 "server_address": "eu1.cloud.thethings.network:1881"

It was the lack of port number that caused my own gateway not to connect to v3, a problem solved by @kersing

I found on a other topic a sulotion. i’ve deleted the local_conf and adepted the global_conf with the server key. this worked for me.