Victron Energy and The Thing Network


I am trying yo connect a solar energy system with a Victron Energy VE.Direct LoRaWAN - module thru the Thing Network to Victron’s VRM platform.

I can’t seem to get connected. The blue led keeps blink “trying to connect”

Has anybody else used TTN with VE components for a similar application? similar issues?
I am supposed to be within reach of nearby gateways.

What exactly is the right procedure?

Thanks for your help,


I am trying… I can’t seem to get connected, that’s not enough information

links to the product(s)
what did you try exactly
what did you see on the TTN console
ect ect

first obvious question, do you own a LoRaWAN gateway

Connecting a VE MPPT with a LoRaWAN. Blue led starts blinking and that’s it. (Led should be green when ok)
I read the whole victron energy website.

I don’t own a LoRaWAN gateway. I am within 2km of at least 2 gateways nearby. Do I need to have my own gateway? do I need some kind of permission from other gateways? register?


  • You need to register an application in your TTN console and add your (VE) device.
  • Then your device must transmit something that is received by one of those gateways
  • and finaly you can see that data on your console
1 Like

Hi Carlos,

The Victron Energy VE.Direct LoRaWAN device is very simple when it works. You no not need a The Things Network account.

As you are doing, just turn it on and it will connect to a local TTN gateway. If the LED does not flash green it is unable to talk to a gateway. No VE account ( required at this stage. There has been some firmware issues with devices in Australia that will not allow them to connect. Also we are having local issues, as in Australia we should be using gateways on AU915, however some people have decided to go with AS923 and this device will not work with these gateways.

  1. Where are you located? Country and town?
  2. What is the model number of the VE.Direct LoRaWAN node? It’s the ASS0305XXXXXX number.

You can also request support from Victron here:



I assume ’ when there is a gateway within reach, if not it starts blinking ?

There is a single multi-colour LED on the device and it always flashes each 5-10 seconds. The colour is the status. When first turned on it flashes blue to state it’s trying to connect. Then once it has connected it flashes green to stay all is OK.

It connects OTA to a Victron Energy application on the TTN. This is why the end user does not need to configure anything. The data is then pushed to the Victron Portal

tnx for the explanation, but that didn’t answer my question , is it possible that ‘solergy’ need his own AU915 gateway ?

victron ‘node’

Sorry, I have no idea where he is located in the world. Yes, I expect the problem will simply be the gateway is too far away or it’s a different frequency plan. He could buy and add a gateway nearby, but that is then something that has be managed.

Lets see what he comes back with.

agree and thanks for your advise :sunglasses:

he probably need a US/CANADA gateway/node

Wayne and Borroz, thank you both for your tips!
I am located in Montreal, Canada, I have a US902-928 module, which is correct one for the location.

From your comments I am guessing now that I might have a bad gateway connection. I am going to try to connect from a different spot in the city to see if it works.

Thanks again, I will keep you posted.

Hi guys!
Just to give you an update, so I connected my antenna right in front of a gateway nearby, and it worked immediately :smiley: !!
It is just a matter of bad reception.
By the way, the Victron Energy VE.Direct LoRaWAN - module works right away, no configuration to be made.

Thanks again!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

I have some Victron VE Direct LoRa modules on 1 location with distance of max 800m to my gateway. I have a Dragino LG308 gateway, build in a box outdoor on 16M height. Sometimes i got an update every hour, sometimes don’t get update for 20 hours. The signal light on the Victron modules blinks green. The gateway connection is green in my TTN account. If i look at trafic in my TTN account i don’t see any trafic on my gateway. I have set radio 0 on 870000000 and Radio_0 tx min frequency 863000000 Radio_0 tx max frequency 870000000. Maybe not te right frequency?

Hi Alco,

I am having a similar issue now.
I installed a new getaway (The Things Gateway). Now I see green light from the VEDirect LoRaWan module, the gateway is receiving the “payload” as I can see on the gateway console, however the information is not being forwarded to Victron VRM website.

Did you solve your issue? any updates? do you know if this is normal?


1 Like

I am having the same problem in my TTN Gateway. I mean, I am seeing the VE.Direct LoRaWAN join request, but no answer.

As we don´t have any kind of documentation about it, I suppose that for communication between TTN and VRM we have a API doing this job (communication TTN <==> VRM). How we can check if this API exist and it is working or not? Take a look in the screen captured below:

The major point is the VE.Direct is not a LoRaWAN compliance device, I mean the design and behavior don´t follow the LoRaWAN expected behavior (DevEUI, AppEUI, Appkey, etc…). Victron did the most difficult thing for a easy task that any teenager with a arduino spend five minutes for connect a new LoRaWAN compliance device.




Hello Claudio.

Have you solved the issue? I have the same issue. VE-Device is blinking blue, I can see the join requests at my gateway, but nothing more happens… :frowning:


Did you register the VE Direct Module in the VRM???


Looks like rebooting of my gateway solved the issue…