Where to find RN2483 firmware updates


#1

Microchip mentions a firmware version 1.0.1 for the RN2483 chips in it's Feb. 2016 errata document.
However they do not mention where to find this update.

Who knows how or where to get these firmware updates?

PS I got the 1.0.0 update (with flaky install tool) from an URL on virtualbreadboard.com.


#2

The latest firmware I have is RN2483 1.0.2 Jan 21 2016 13:52:51. This also fixed the bootloader when programmed via the programming pins and not the UART pins so that you then dont need to switch baud rates part way through the process.

Apparently this was withdrawn and a new release is on its way. It could be why my usual suppliers have no stock of RN2483 modules until end of April/May time as Microchip are updating the firmware to the certified version.

Andrew


RN2483 firmware versions
#3

A Microchip rep is supposed to contact me about RN module firmware for over two weeks now but I haven't heard anything yet. Their forum suggests my experience is 'normal'. Do you have a contact at Microchip or is your contact one of the suppliers? (if you don't mind me asking)


#4

Ooops, that would be me. I did mean to contact you Jac but I've been slammed with MWC & Embedded World. Sorry. I'll PM you.

Thanks,
JDP


#5

Hi,

I think that we are many people waiting for the latest firmware update. I've four RN2483 modules and two are stuck with release 0.9.5 (the other two use the 1.0.1).

If the 1.0.2 firmware can go public, that will be a good things for everyone. As it seems that pre-1.0 version are not fully LoRaWan 1.0 compatible and post-1.0 version have many bugfixes.

Thank you !

best,
jym


#6

Version 1.0.2 has been withdrawn because of issues. The current release is 1.0.1.


RN2483 firmware versions
#7

Good to know. Thanks.

Is the 1.0.1 firmware download available somewhere ?


TTN UNO - BETA release - Documentation
#8

Firmware v 1.0.1 available for download.

File RN2483-v101.for.ICSP.hex is for use with PICkit3/ICD3 or other compatible PIC programmer (chip is PIC18LF46K22, 3.3V device). RN2483-v101.for.bootloader.hex should be usable with the bootloader available for the 1.0.0 update.

I've used the ICSP version because this file fixes the boot loader as well as update the firmware. Used a simple PICkit3 to RN2483 programming adapter to connect to the RN2483 pins.


(Jan-Willem Ruys) #9

Can I ask what the pinout of the programming adapter is? Having trouble with the Java app not opening the file dialog...

Thanks -


#10

Could someone tell me how to connect the programmer to the RN2483?

I did test it with the java tool but that is not working.


(Jan-Willem Ruys) #11

Amazingly the answer was in the data sheet :smile: - it shows a "test" connector which had the exact pinout of the PickIt. This is the ICSP programming port.

I had to download a new PK2DeviceFile.dat to make my PickIt2 recognise the 18LF46K22 and when programming verify failed (got all zeros back) but on test it worked fine. Reporting 1.01 now.

(Edit: fixed typo in chip model)


#12

I just tried it 'the java way' and it worked :smile:
must be my lucky day.


#13

Found out that programming with the java tools works if activate the reset on the RN2483 and direct after that press scan com ports. Else the software never finds a module in my case.

After updating to 1.0.0 the reset action is not required any more because it finds the module on every scan.

Also updatet to 1.0.1 but after that the scan com ports finds no module.......revert to 1.0.0 and it's working again.


#14

after the update first disconnect/connect and restart java prog before re scan


#15

You havo to click on the "RN Module X" when found, than it will open the LoraWAN...DFU Tab on the right.


#16

Glad you found the information. (I've been off-line for various reasons for the last 3 weeks)


(Martijn) #17

Hi,

Did anyone try to update the firmware with the java tool on the Sodaq Mbili + LoRabee RN2483? Can you share the information/steps how to complete it? It didn't work for me at all. (No RN module found with USB)

Thanks,
Martijn


#18

Is it possible to post the PK2DeviceFile.dat to make my PickIt2 recognise the 18LF46K2?


#19

It is an 18LF46K22, note 22, not 2.


(Jan-Willem Ruys) #20

If I remember correctly, looking at my browser history, I got the PK2DeviceFile here:

http://www.auelectronics.com/forum/index.php?action=dlattach;topic=413.0;attach=1765