Where to find RN2483 firmware updates


(shanu) #21

Hello Everyone, Is there any way to change the Baud rate of RN2483 ? Thanx in Advance


(Leon Schenk) #22

Yes there is @Akanksha,

You should send a 'break' and then a 0x55 command at the new baud. This is described in the RN2483 command reference.section 1.4.
I have a snippet for you:

uint8_t uart_setbaud(uint32_t newbaud)
{
	LEUART_BaudrateSet(LEUART0, newbaud);
  	// setup baudrate/wake up RN2483
   	GPIO_PinOutClear(gpioPortD, 4);
   	LEUART0->ROUTE &= ~(LEUART_ROUTE_TXPEN); // disable UART tx at pin
   	delay_ms(200); // 200 ms break command
   	LEUART0->ROUTE |= LEUART_ROUTE_TXPEN; // enable UART tx at pin
   	LEUART_Tx(LEUART0, 0x55); // set-up baud
   	delay_ms(50);
   	return 0;
}

With a serial adapter I did not manage to change the baud properly.


(Leon Schenk) #23

A valid break condition is keeping the line low for longer than a character. So longer than 9 times the symbol period (Ts). But longer is also possible.


(Pieter) #24

Link to 1.0.1 doesn't seem to work anymore, is there a alternative?


#25

It is a DNS issue. I'm working on getting it fixed.

EDIT: DNS has been fixed, however it might take some time before the old information is purged from the caches.For the time being the update is available here.


(Martijn) #26

"LoRaBee" RN2483 Firmware upgrade guide from Allthingstalk:
http://docs.enabling.be/docs/faq-upgrade-allthingstalk-devkit-firmware


#27

Is the adapter something you made yourself, or available commercially somewhere?

We've figured out the required pinout, but do not yet have a practical means to connect a PICkit to the module.


#28

It is something I made myself. Files for DesignSpark PCB with gerber file included in the archive here. Mount the 1.27 mm header from the component side and the 2.54mm header on the copper side leaving the space required to solder it on the copper side.
(1.27mm headers can be found on AlieExpress)

To program attach to PICkit3 with 2.54mm headers and hold 1.27mm header pins firmly against the contacts of the RN module.


(Cyril DOMINGUEZ) #29

Hi everybody,

Can someone provide me the rn2483 firmware 0.9.5 ?
I have an issue on the 1.0.1 and i think this issue wasn't on the 0.9.5 and i wante to make the test but i can't find the original version 0.9.5.

Thanks for your help


#30

I notice that people are targeting the PIC18LF46K22 chip on the RN2483, but the documentation and the chip writing on top of the onboard micro say PIC18LF25K50, do I have a newer/older version of the RN2483? The firmware version is 0.9.5 at the moment.
cheers,P


#31

The older versions of the DM164138 (868 MHz) LoRa Mote Development Board have a 18LF25K50, however the RN2483 module itself contains a microcontroller under the metal hood. That controller is the 18LF46K22.

Your module is the same, your firmware is old. I would recommend to upgrade to 1.0.1.


#32

Ah! I didn't realise there was another micro under the screening can. That explains why my RN2483 has bricked! I wrote the 1.0.1 firmware to the 25K50. Do you know where I might get the original firmware for the PIC18LF25K50 to fix it? Also my pickit 3 didn't find a PIC18LF46K22 when I tried to write the firmware to it (target device not found message"), I wonder what is going on there?

Puwb


#33

Please do not confuse the DM164138 (as shown at http://www.microchip.com/Developmenttools/ProductDetails.aspx?PartNO=dm164138 ) with a RN2483 (show on http://www.microchip.com/wwwproducts/en/RN2483)

The DM164138 has a RN2483 on board (the module with the metal hood) and also antenna connector, display, switches, battery holder. The RN2483 is just a module with contacts to connect it to a PCB.

For the firmware, use the link above to go to the Microchip site. At the bottom of the page there are a couple of downloads. Get the zip file for the OLED model, it contains the hex file.
While you are there, I suggest you download the documentation as well (and read it)

Did you use J5 while trying to upgrade the RN2483 firmware? J2 is for the MOTE firmware.


#34

Thanks, I have the "RN-2483-PICTAIL" board, I was confusing the two headers. I have now uploaded firmware 1.0.1 to the PIC18LF46K22 and the OLED S/W to the PIC18LF25K50.I can now see the COM port again on my PC but the Tx/Rx green LEDs are permanently on and the device is not responding to the "sys get ver" command. Is the OLED the correct software for the RN-2483-PICTAIL board? (I don't see an alternative software download in the product page
http://www.microchip.com/DevelopmentTools/ProductDetails.aspx?PartNO=RN-2483-PICTAIL )


#35

The OLED software expects a display connected to the 18LF25K50 which is not available so I don't expect it to work. The software for the RN-2483-PICTAIL does not seem to be publicly available, you can try contacting Microchip support and ask them for the hex file. Another option is to create your own software based on the OLED sources.


#36

That's super, thanks for all your help!!!!


#37

I just recovered an RN2483 using @kersing's PicKit3 method. This was after I bricked it by doing a normal firmware upgrade using the Java utility inside a Windows 7 Vbox, using USB forwarding.

With the Pickit3 it was natively under Linux using MPLAB IPE.


#38

Those dev tools are broken on Mac, the firmware file selector throws an exception mentioning someting about an invalid path. Any chance this will be fixed? Is there an issue tracker where we can report and follow up on such bugs?
I wonder if the same thing happens on Linux


#39

The Java based tools was created by Microchip for use on Windows. As far as I know it was not released to the general public so I very much doubt bug fixes will be made available.
You could try if the functionality is included in the LoRa Development Suite found on this page.


#40

Hello francisdb,

A week ago, I had a similar issue when trying an RN2483 (on a Lorabee) from version 0.9.5 to 1.0.1 with Microchip firmware tools using an FTDI cable. The firmware update process did not work and trying to select a file/folder using Bootloader mode on the tool gave me these errors:

Sep 30, 2016 11:05:12 AM java.util.prefs.WindowsPreferences
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Exception in thread "JavaFX Application Thread" java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
at javafx.fxml.FXMLLoader$MethodHandler.invoke(FXMLLoader.java:1774)
at javafx.fxml.FXMLLoader$ControllerMethodEventHandler.handle(FXMLLoader.java:1657)
at com.sun.javafx.event.CompositeEventHandler.dispatchBubblingEvent(CompositeEventHandler.java:86)
at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:238)
at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:191)
at com.sun.javafx.event.CompositeEventDispatcher.dispatchBubblingEvent(CompositeEventDispatcher.java:59)
[... long calling stack dump ...]

Also:

Caused by: java.lang.IllegalArgumentException: Folder parameter must be a valid folder
at com.sun.glass.ui.CommonDialogs.convertFolder(CommonDialogs.java:238)
at com.sun.glass.ui.CommonDialogs.showFileChooser(CommonDialogs.java:190)
at com.sun.javafx.tk.quantum.QuantumToolkit.showFileChooser(QuantumToolkit.java:1496)
at javafx.stage.FileChooser.showDialog(FileChooser.java:416)
at javafx.stage.FileChooser.showOpenDialog(FileChooser.java:350)
at dfu.DFUFXMLController.onFileBrowse(DFUFXMLController.java:238)
[... long calling stack dump ...]

I am using LoRa Development Utility (help / about says: LoRa Xtensive v1.0 Beta) running Java 1.8.0_102-b14 on Win10 (64 bits)

How I fixed it:

It seems the issue is related to accessing the registry on Windows and I had to manually delete and re-create the key here:
[HKEY_CURRENT_USER\SOFTWARE\JavaSoft\Prefs]

After I did that fix, the error in LoRa Development Utility disappeared and I found a new key written in the registry:

[HKEY_CURRENT_USER\SOFTWARE\JavaSoft\Prefs\dfu]
"/File/Path"="/D://lora//"

You may be able to apply a similar fix on your MAC, if it has a registry equivalent.

Cheers.