Cannot connect new The Things Kickstarter Gateway to V3

Hello all,

This is my first post in the community, so bear with me and please let me know if my etiquette doesn’t meet community guidelines. I’m also new to the world of LoRa and cloud services in general, so this has been a bit of an uphill journey for me.

I’m trying to set up The Things Kickstarter Gateway (Note: NOT a TTIG) to a The Things Stack Community Edition-hosted console (NAM1). I’ve followed the steps outlined at The Things Kickstarter Gateway Registration several (read: dozens) of times, but have been unsuccessful in setting up my gateway on the console. I am able to connect to the WiFi, but am unable to activate past that. In my most successful runs, I cycle between the WiFi setup stage (one LED solid, one slowly blinking) and the activation stage (two LEDs solid, one slowly blinking).

The only thing I can see that I didn’t quite follow in the instructions was the addition of a tenant ID after my gateway ID. However, anytime I try to put this into the configuration page, I get an error (see below).
image
image

My gateway is brand new and out of the box. I also downloaded the most recent firmware to make sure it was up to the 1.0.8 standard. I’ve also tried a couple different console setups and WiFi networks and have met the same problems each time. Alls to say I don’t think this is a hardware or console issue; I believe it is purely a configuration problem. However, I am finding no help in the documentation understanding what I am doing wrong. Can anyone in the community help me figure this out?

I’ve attached a copy of the UART debug I received during one of my configurations with areas of interest highlighted. This run was done with the credentials “swri-div-14-gnat-asset-tracker” and the network ID “https://nam1.cloud.thethings.network/” over an Ethernet connection. Any help will be greatly appreciated!

Attempts at Registration Forum.pdf (234.1 KB)

Check Want to move my TTN Gateway to V3 - #9 by aberenyi for instructions that worked for another forum user.

Thanks for the response. These were the instructions I was trying to follow. However, any combinations of my gateway key followed by an “@ttn” results in the “unexpected data sent to gateway” error I received above. I have tried using the tenant ID with two different API keys as well.

Please try with a smaller (less characters) gateway id. You might well be running into buffer size limits concerning the name used.

1 Like

All,

Just wanted to post my resolution for anyone else with similar issues. There were several steps I had to take to find a solution to my problem.

  1. I did in fact need a tenant ID (@ttn) for my gateway.
  2. My original gateway ID was too long, and this was indeed why I got the “unexpected error” issue.

However, this was not the end of my problems. I was still getting the frustrating looping problem and rejected LoRa packets. I did finally manage to find some links tracing this back to a mechanical issue. This led to resolution #3:

  1. Push my LoRa chip firmly into its socket – and pushed it even harder when that didn’t work

– to FINALLY get a working router.

Thank you for all the help Kersing and other members of the community for having the answers that support and the setup page did not. So much for a five minute activation.

4 Likes

Am trying to migrate my old Kickerstarter GW to TTNv3. With the experience as you summed up in this thread I was hoping that it would go smooth. However it seems the gw is not connected

  • The 3rd LED keeps blinking slowly (which means activating) - restarting the gw does not help
  • Have Wiffi and ethernet connected
  • Info (http://192.168.1.68/info) states the following

image

image

So I am puzzled where the problem is?

Finally the kickstarter gateway connects to the network (when I do not configure WiFi it ‘activates’).
Now the 4 LEDs all light up.

However I see no LoRa traffic in the v3 console (while there is traffic flowing thru the air).
Seems like a hw issues to me

I think I have a similar problem, everything looks good on the gateway info page, but no traffic at all showing on the TTN v3 console. Shows as connected but up/down counters are 0/0, there is a node nearby:
image

Yes that is the same as I am seeing (http://192.168.1.69/info)

image

While in the console no traffic is seen

image

imho if the connection between the gateway and the TTS CE-server gets lost for more than 60(?) seconds this counter is reset to zero.
Does your gateway send status messages every 30 seconds?
With one of my gateways I observed that if the WLAN-connection gets lost even for a short time this counter is reset to zero.

After factory reset of the kickstarter GW I configured as described in lnks above.
So I do not know it is is send every 30 secs. Never had issues on v2 so I am puzzled what the reason is :slight_smile:

Well, at least the screenshot now shows “Gateway Card: 868MHz”, so it’s detected, and “config: correct” and “Broker connection: true”. This wasn’t the case in your earlier screenshot, so I think you’re heading in the right direction.

Yes @bertrik - it started working when I did not configure WiFi / to me it seems a weird problem :slight_smile:

What a mess, I feel sorry for people who bought this gateway, and would not recommend it to anyone.

Like @jeroen2 I’m running from one weird problem into another:

  • The screen shot at The Things Kickstarter Gateway | The Things Stack for LoRaWAN shows old/misleading info, is not applicable for TTS CE
  • On my best attempt, according to the internal info page of the gateway, things look OK: LoRa card detected, LoRa packets received, gateway claims to be connected to a network and is able to connect to the gateway server. However no data on the console and no evidence it is passing traffic from nearby nodes.
  • However, after having enabled wifi, the “gateway card” status goes to “ND” (not detected?), no more packets coming in

Not sure anymore what to do, hopefully someone from TheThingsIndustries can look into this.

I finally got it working. I tried various things.
The thing that finally made it work is to remove the “@ttn” from the gateway id, just enter the plain gateway id in as shown in the TTS CE console. This is in direct contrast to an earlier post from june 24 in this thread.

1 Like

Thanks. That also worked for me. So do not use the @ttn behind the Gateway Id:
(at least for the kickstarter gateway)

I am still not able to configure WiFi - > after doing so it does not connect to ttnv3 anymore