Can't verify my email for access to CLI, please help! :)

Hi, we’re trying to verify our account, but your verification email isn’t getting through. Please can you verify our account, manually. Thanks!

Hi, your email server previously told ours that your address doesn’t exist. I just retried sending a validation email, and it looks like it succeeded this time. You can use the validation link to get access to The Things Stack Community Edition.

1 Like

Hi there,

I tried your link but it opened a page not found error screen, is there a way you can do it manually?

We’re going to try CLI as well.

I tried the CLI command but got another error:

WARN Failed to check version update {“error”: “Get " ##### x509: certificate signed by unknown authority”}

I’m using lorawan-stack-cli_3.15.1_windows_386

Now I’m just getting a “You can’t use this app on your pc” from the cmd. So can’t try any new commands.

That smells like Mordac the Preventor of Information Services has caught up with your CLI install.

The certificate issue may be the expiry of the Lets Encrypt intermediate certificate as TTI use them and Windows isn’t great at keeping up to date with lesser providers however popular.

I’d resort to own laptop on public WiFi …

1 Like

I’m not completely sure what’s going on here, but it looks like your account on The Things Stack Community Edition was successfully validated. Are you still not able to access the Console?

1 Like

The OP works for a UK Local Authority whose cyber security policy is normally ‘No’ and ‘Go Away’.

So it may be good to go but it looks like they used Windows Policy to block the running of the CLI app.

So we/you/us/him will have to wait until it’s unblocked or he’s got a laptop on LTE to use.

1 Like

@htdvisser it may have succeeded since, I’m not sure, I’ve tried on a different PC too, but got the same issue, it might’ve got through and then given me that error. I even reached a login page.

I think I may have been able to validate the email, but since then I haven’t been able to send the command I’m after, this was our first reason to access the CLI:

“B:\General Downloads\lorawan-stack-cli_3.15.1_windows_386\ttn-lw-cli.exe” end-devices set #KeyHereButItsASecret# #AnotherSecretKey# --mac-settings.desired-rx1-delay RX_DELAY_1

@descartes, you’re absolutely right about our security policies, I’ve since retreated home where life is easier xD I am however getting this error on my home device, outside of our LA policies.

Not sure about the secret key bits - they are best setup in the config file - Installing the CLI | The Things Stack for LoRaWAN

The CLI will pony up the help but here’s an older CLI reference (close but has most of the details) that may help with navigation:

ttn-lw-cli end-devices set [application-id] [device-id] --mac-settings.desired-rx1-delay RX_DELAY_1


This is the issue now, on my private PC, outside the local authority.
I’m using the latest version, as far as i’m aware. Happens after entering any command related the to ttn-lw-cli in cmd. I believe this started after the authorisation, will probably shift this part onto another topic.

New topic:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.