Data storage integration with meshed "Not Authorized"

I have been following the posts that I have found on this issue as some people seem to have had the “Not Authorized” issue as well. I have watched the youtube video to help me through, and its meant to be a really simple process.

When I click the Go to platform link in the Data Storage integration I go to a blank page that simply say Not Authorised. I have the device set up on the which may be where the problem lies.
I have tried typing the address that is meant to take me to the swagger link “” with no luck. I have also tried typing the link in the video with myapplication as per normal. Although I get the website as per the video, I get no connections to anything.

Has anyone had any experience/success working on the meshed console with data storage?



Hi Dylan. You are correct. There is an issue using the data storage integration on the Australian instance and we’re working on a solution to this. Either I or one of the TTN team will update this topic when we have some news.

Ok good to hear your on the case. Thanks for the reply.


Same issue… have we found a solution?

Has there been any progress on this, it’s incredibly annoying not having a simple data storage method on here.

You’ll need to use the meshed console. See Meshed-handler

Thank you for the reply. I have been using the meshed-handler from the beginning, it was certainly a difficult one to figure out. Have you managed to get the data storage to work on the meshed-handler for AU? It is still not working for me.

This is the data storage URL I get to when I click on it in the integrations tab:

Which still says:
Not authorized

This is my meshed-handler integrations url:


The Meshed console doesn’t have the Swagger UI for viewing the storage integration online. You can use normal REST API to access it, see

For an example using curl:

curl -D- -X GET -H "Authorization: key ttn-account-v2.***********************" -H "Content-Type: application/json" ""

You can see what devices are under the application, but checking my storage shows no data under these devices. So, it may be something that the meshed crew need to look into, if it is meant to be working at all, yet.

Maybe @Maj can update us on the progress…

I don’t think this will get addressed before v3 is released. It’s something the TTN team would need to fix.

How are we travelling with this issue for Australian TTN collaborators?
Anyone found a workaround?
To be honest the ease of integrations is the main driver for using TTN for me…

Old thread.
I am just checking that the Storage Integration is still not available on the Meshed server in Australia.

Turns out, it is working! It’s just that the Swagger UI isn’t working.

curl -X GET \ '' \ -H 'Accept: */*' \ -H 'Authorization: key yourAppsAccessKey' \ -H 'Cache-Control: no-cache' \ -H 'Connection: keep-alive' \ -H 'Host:'

1 Like

Hi Maj
There are some updates on this topic?
I was using Meshed router with US-WEST handler and Swagger UI work, now i have migrated all to Meshed console, router and handler, but see that swagger UI does not work.

Any updates will be appreciated.

Thanks in advance.


Hi Maj

Like Hugo and all previous I am stuck not being able to see anything on Swagger as I get the ‘Not Authorized’ message. Are you able to give a step by step explanation on how to use this from you previous comment:

Many thanks


If you’re on Windows then see also Using curl or Postman for the HTTP Integration on Windows for a note about using double quotes instead.

Hi Andrew
Good morning, I hope you are well.
I just wanted to see if there is any news regarding the use of Swagger on the Australian console?
From already thank you very much


I don’t think we’ll see Swagger implemented here as the core team are focussed on releasing V3.