Legacy packet forwarder mikrotik

Hello, in order to migrate my gateway a mikrotik one, i need to enable legacy packet forwarder, i don’t seem to find it in the gateway settings on the v3 console, what approach should i take?

Are you sure you’re following the instructions for The Things Stack (V3)?

Where does it say you need to enable legacy packet forwarder?

Yes, I’m following the instructions.
I only copy the gateway id, because there is no space to enter anything else.
The server I provide is correct, but the device appears OFFLINE.
In previuos version I needed to enable legacy packet forwarder, this indicates to me that I need to enable legacy packet forwarder.
Also this guide tells me to enable Legacy Packet forwarder https://www.thethingsnetwork.org/docs/gateways/mikrotik/
WAP LORA8 KIT

image

Here is my gateway config

That page you linked to is for V2, not V3. I guess we should make that more clear (cc: @benolayinka).

The V3 instructions can be found here: MikroTik Routerboard wAP LoRa8 kit | The Things Stack for LoRaWAN

does not work according to this instruction.
All gateways is Disconnected
And try RAK2245 V4.2.7R same Disconnected
UDP and TCP ports allowed

fixed here doc: Add V2 warning to all V2 docs by benolayinka · Pull Request #475 · TheThingsNetwork/docs · GitHub

1 Like

bump, still the issue persists even if I follow documentation for V3, didn’t have any success with RAK2245 either. Both devices are fully up to date and have been reset to their default settings.

@Gytis can you perhaps share a screenshot of the Servers tab on the Mikrotik so we can verify the address and ports look right?

If two different gateway models don’t work it makes me think there is a firewall in the way that is blocking UDP traffic on port 1700. Are you perhaps on a company, school/university or other network with a firewall?

Also now that I think about it, did you perhaps select “require authenticated connection” when you registered the gateways? This needs to be deselected when using the legacy packet forwarder.
image