LSN50v2 does not receive downlinks

Hi there,

I am trying to get my LSN50v2 to join TTN v3 via OTAA but it does not seem to receive the join accept message.

Here is an excerpt from my console.
image

At first, I thought it was the RX1 Delay of 5 seconds. LSN50v2 uses 1 second by default but changing it to 5 seconds did not solve the issue.
I think I have chosen the correct frequency plan: Europe 863-870 MHz (SF9 for RX2). My device is EU868 and shows an RX2 datarate: DR3.
Could this be an issue with the ADR, which is set to on?

Here is a dump of the LSN50v2 configuration
AT+ADR=1
AT+TXP=0
AT+DR=5
AT+DCS=0
AT+PNM=1
AT+RX2FQ=869525000
AT+RX2DR=3
AT+RX1DL=5000
AT+RX2DL=2000
AT+JN1DL=5000
AT+JN2DL=6000
AT+NJM=1
AT+NWKID=00 00 00 00
AT+FCU=0
AT+FCD=0
AT+CLASS=A
AT+NJS=0
AT+RECVB=0:
AT+RECV=0:
AT+RJTDC=20
AT+RPL=0
AT+VER=v1.7 EU868
AT+CFM=0
AT+CFS=0
AT+SNR=0
AT+RSSI=0
AT+TDC=300000
AT+PORT=2
AT+RX1WTO=24
AT+RX2WTO=9
AT+MOD=1
AT+INTMOD=2
AT+WEIGAP=400.0
AT+5VT=0
AT+CHS=0

Thanks for your help.

That applies only after the join process is completed; the join accept itself has to used standard RX2 if it ends up transmitted in RX2 rather than RX1 - but the network side log appears to show RX1 used, so that isn’t the problem in this instance, still you should use the standard setting when trying to join; the network will command the customization automatically.

Similarly, ADR only applies after the join process works.

Same for RX1 time customizations - the join accept RX slots have standard timing, custom timing only comes after.

Does the node give you any way to determine what it is trying to do?

How far is the node from the gateway? Both too close (within a few tens of meters) and of course too far can cause problems.

As mentioned that is the wrong setting. Set it back to 0.

OTAA takes care of that, leave it at 1 second.

These values do not make sense. RX2 delay is always RX1 delay + 1 second. So if you ever need to modify them by hand, make sure RX2DL is set to 6000 if RX1DL = 5000

From your excerpt we’re unable to check the data rate of the packet received. Please provide that information as well. And don’t bother crossing out all those values, all of them travel in clear text over the air so anyone interested can listen for them. If you want to prevent someone from across the world registering the same device just blocking the DevEUI is sufficient.

Thanks for the suggestions so far. I still did not get the node to join the network but here is some more info.

RX2 datarate:

As mentioned that is the wrong setting. Set it back to 0.

3 was the default but I now set it to 0

RX1 delay:

OTAA takes care of that, leave it at 1 second.

I changed it back to 1 second

How far is the node from the gateway? Both too close (within a few tens of meters) and of course too far can cause problems.

I am using any available gateways so I don’t know how far it is from my node. I have just ordered my own gateway which will hopefully arrive within the next days.

Here is the debug info from the node

[15403]***** UpLinkCounter= 0 *****
[15404]TX on freq 868300000 Hz at DR 5
[15470]txDone
[20459]RX on freq 868300000 Hz at DR 5
[20488]rxTimeOut
[21500]RX on freq 869525000 Hz at DR 0
[21701]rxTimeOut

[22442]***** UpLinkCounter= 0 *****
[22443]TX on freq 868100000 Hz at DR 4
[22561]txDone
[27552]RX on freq 868100000 Hz at DR 4
[27584]rxTimeOut
[28591]RX on freq 869525000 Hz at DR 0
[28791]rxTimeOut

[33880]***** UpLinkCounter= 0 *****
[33881]TX on freq 868500000 Hz at DR 4
[34000]txDone
[38991]RX on freq 868500000 Hz at DR 4
[39023]rxTimeOut
[40030]RX on freq 869525000 Hz at DR 0
[40230]rxTimeOut

[45319]***** UpLinkCounter= 0 *****
[45320]TX on freq 868300000 Hz at DR 4
[45438]txDone
[50429]RX on freq 868300000 Hz at DR 4
[50461]rxTimeOut
[51468]RX on freq 869525000 Hz at DR 0
[51668]rxTimeOut

[56757]***** UpLinkCounter= 0 *****
[56758]TX on freq 868100000 Hz at DR 3
[56969]txDone
[61964]RX on freq 868100000 Hz at DR 3
[62004]rxTimeOut
[63000]RX on freq 869525000 Hz at DR 0
[63200]rxTimeOut

[77396]***** UpLinkCounter= 0 *****
[77397]TX on freq 868500000 Hz at DR 3
[77608]txDone
[82603]RX on freq 868500000 Hz at DR 3
[82643]rxTimeOut
[83638]RX on freq 869525000 Hz at DR 0
[83838]rxTimeOut

[98035]***** UpLinkCounter= 0 *****
[98036]TX on freq 868100000 Hz at DR 3
[98247]txDone
[103242]RX on freq 868100000 Hz at DR 3
[103282]rxTimeOut
[104277]RX on freq 869525000 Hz at DR 0
[104477]rxTimeOut

[118673]***** UpLinkCounter= 0 *****
[118675]TX on freq 868500000 Hz at DR 2
[119049]txDone
[124052]RX on freq 868500000 Hz at DR 2
[124113]rxTimeOut
[125080]RX on freq 869525000 Hz at DR 0
[125280]rxTimeOut

[155812]***** UpLinkCounter= 0 *****
[155814]TX on freq 868300000 Hz at DR 2
[156188]txDone
[161191]RX on freq 868300000 Hz at DR 2
[161251]rxTimeOut
[162218]RX on freq 869525000 Hz at DR 0
[162418]rxTimeOut

[192951]***** UpLinkCounter= 0 *****
[192953]TX on freq 868300000 Hz at DR 2
[193327]txDone
[198330]RX on freq 868300000 Hz at DR 2
[198390]rxTimeOut
[199357]RX on freq 869525000 Hz at DR 0
[199557]rxTimeOut

[230089]***** UpLinkCounter= 0 *****
[230091]TX on freq 868300000 Hz at DR 1
[230918]txDone
[235933]RX on freq 868300000 Hz at DR 1
[236035]rxTimeOut
[236949]RX on freq 869525000 Hz at DR 0
[237149]rxTimeOut

[312529]***** UpLinkCounter= 0 *****
[312531]TX on freq 868100000 Hz at DR 1
[313358]txDone
[318373]RX on freq 868100000 Hz at DR 1
[318474]rxTimeOut
[319388]RX on freq 869525000 Hz at DR 0
[319588]rxTimeOut

[394968]***** UpLinkCounter= 0 *****
[394970]TX on freq 868300000 Hz at DR 1
[395797]txDone
[400812]RX on freq 868300000 Hz at DR 1
[400914]rxTimeOut
[401828]RX on freq 869525000 Hz at DR 0
[402028]rxTimeOut

[477408]***** UpLinkCounter= 0 *****
[477410]TX on freq 868300000 Hz at DR 0
[478896]txDone
[483926]RX on freq 868300000 Hz at DR 0
[484126]rxTimeOut
[484926]RX on freq 869525000 Hz at DR 0
[485126]rxTimeOut

[625748]***** UpLinkCounter= 0 *****
[625750]TX on freq 868300000 Hz at DR 0
[627236]txDone
[632266]RX on freq 868300000 Hz at DR 0
[632466]rxTimeOut
[633266]RX on freq 869525000 Hz at DR 0
[633466]rxTimeOut

[774087]***** UpLinkCounter= 0 *****
[774089]TX on freq 868500000 Hz at DR 0
[775576]txDone
[780606]RX on freq 868500000 Hz at DR 0
[780806]rxTimeOut
[781606]RX on freq 869525000 Hz at DR 0
[781806]rxTimeOut

Here is what the console shows (I hope I have captured all relevant information)
image
image
image
image

I think this answers everything! Have you checked the TTN map (home page) and TTNMapper to see where any gateways there may be around you and if they are active?

https://www.thethingsnetwork.org/gateway-map
https://ttnmapper.org

Clearly your device is transmitting the join request but it is also not hearing the response.

Please read this on how to format your post

I have checked the map and there is a gateway nearby (~200m). Also the fact that I see the node join requests means that there is a gateway listening, no? Do you think the gateway is too far away to forward the join accept message in time?

Indeed, it does.

Timing to the gateway is not terribly likely to be an issue, but the gateway itself could be faulty.

What RSSI do you see for the node’s join request at the gateway receiving it? It seems to be cut off in your picture - generally, posting pictures rather than text is ill advised.

As @cslorabox says, it does mean there is a gateway hearing the join request, it just might not be the one ~200m away.

As well as signal strength, a list of the gateways that heard the join could help figure out which gateway(s) are active in your area.

Here is the full content of the message received by the gateway. RSSI is -117, SNR -18.5 so rather poor. I hope it will work once I get my own gateway.

Click to see the full logs
{
  "name": "ns.up.join.receive",
  "time": "2021-03-23T20:20:14.229405538Z",
  "identifiers": [
    {
      "device_ids": {
        "device_id": "lsn50v2-watersensor",
        "application_ids": {
          "application_id": "flosslaende-water-sensor"
        },
        "dev_eui": "xxx",
        "join_eui": "A000000000000101"
      }
    }
  ],
  "data": {
    "@type": "type.googleapis.com/ttn.lorawan.v3.UplinkMessage",
    "raw_payload": "AAEBAAAAAACggqqCEYFBQKgNHal11Ws=",
    "payload": {
      "m_hdr": {},
      "mic": "qXXVaw==",
      "join_request_payload": {
        "join_eui": "A000000000000101",
        "dev_eui": "xxx",
        "dev_nonce": "1D0D"
      }
    },
    "settings": {
      "data_rate": {
        "lora": {
          "bandwidth": 125000,
          "spreading_factor": 12
        }
      },
      "coding_rate": "4/5",
      "frequency": "868500000"
    },
    "rx_metadata": [
      {
        "gateway_ids": {
          "gateway_id": "packetbroker"
        },
        "packet_broker": {
          "message_id": "01F1GBXD5ZZQCSNQ9N67TBSRH9",
          "forwarder_net_id": "000013",
          "forwarder_tenant_id": "ttn",
          "forwarder_cluster_id": "ttn-v2-eu-3",
          "home_network_net_id": "000013",
          "home_network_tenant_id": "ttn",
          "home_network_cluster_id": "ttn-eu1",
          "hops": [
            {
              "received_at": "2021-03-23T20:20:14.143587601Z",
              "sender_address": "40.113.68.198",
              "receiver_name": "router-dataplane-79957f858b-kvnss",
              "receiver_agent": "pbdataplane/1.4.4 go/1.16.2 linux/amd64"
            },
            {
              "received_at": "2021-03-23T20:20:14.162543059Z",
              "sender_name": "router-dataplane-79957f858b-kvnss",
              "sender_address": "forwarder_uplink",
              "receiver_name": "router-ddf8f9b96-5x7df",
              "receiver_agent": "pbrouter/1.4.4 go/1.16.2 linux/amd64"
            },
            {
              "received_at": "2021-03-23T20:20:14.171966003Z",
              "sender_name": "router-ddf8f9b96-5x7df",
              "sender_address": "deliver.000013_ttn_ttn-eu1.uplink",
              "receiver_name": "router-dataplane-79957f858b-kvnss",
              "receiver_agent": "pbdataplane/1.4.4 go/1.16.2 linux/amd64"
            }
          ]
        },
        "rssi": -117,
        "channel_rssi": -117,
        "snr": -18.5,
        "uplink_token": "eyJnIjoiWlhsS2FHSkhZMmxQYVVwQ1RWUkpORkl3VGs1VE1XTnBURU5LYkdKdFRXbFBhVXBDVFZSSk5GSXdUazVKYVhkcFlWaFphVTlwU2xsU1ZVWkZaVVk1YW1OSVVrSk9WMXBMWVZWb1FrbHBkMmxrUjBadVNXcHZhVlpWY0UxTk1XUXhVV3hvUkZVeVVuWlVSbWN5VmpCU1prNXVTbGxSVTBvNUxtaHFlbmhZTjNwQ1ZUSkNMVjg0WlZJeFRrVlZMV2N1V0ZGM1RHVjBMVVphYzJOQlVsVjBiQzV3VFRsT2VHZ3hhWGd4ZVRWR1lWbFRWRE5TTmkxRlMwNWtRMEp4TTNad2FXdDZhMWxYUVRSd1QwNXNTVEp0Wms1T00yWlFjbmROWkVacGRWVXhOMDVSU0c5WFIybG5RMEZRVkY5YU1IVjJUVzk0V1VjNGRrUk9TM05MWTBOcldtVnVXR2hWYkZsV2JuQjJZV2d3YnpNeFMwcElaMUEyUmpkelZqSktaalZYTms1d1RWQkViR3BwYWpKRlduSk5Na1pTVjI1V2RWOXNkM2hHWjFSS2JtUkRaVjgzYnpkcU5DNTJNV3hMVTIxelEzUTRia1Y2TTJZNVdEVkpZVWRCIiwiYSI6eyJmbmlkIjoiMDAwMDEzIiwiZnRpZCI6InR0biIsImZjaWQiOiJ0dG4tdjItZXUtMyJ9fQ=="
      }
    ],
    "received_at": "2021-03-23T20:20:14.228457942Z",
    "correlation_ids": [
      "ns:uplink:01F1GBXD8MZ900YGZK58M55F7V",
      "pba:conn:up:01F1FY6KYDWW6Y99H1X9Q1ANCN",
      "pba:uplink:01F1GBXD5ZZQCSNQ9N67TBSRH9",
      "rpc:/ttn.lorawan.v3.GsNs/HandleUplink:01F1GBXD8MECDFQ5MADHK43G4G"
    ],
    "device_channel_index": 2,
    "consumed_airtime": "1.482752s"
  },
  "correlation_ids": [
    "ns:uplink:01F1GBXD8MZ900YGZK58M55F7V",
    "pba:conn:up:01F1FY6KYDWW6Y99H1X9Q1ANCN",
    "pba:uplink:01F1GBXD5ZZQCSNQ9N67TBSRH9",
    "rpc:/ttn.lorawan.v3.GsNs/HandleUplink:01F1GBXD8MECDFQ5MADHK43G4G"
  ],
  "origin": "ip-10-100-14-32.eu-west-1.compute.internal",
  "context": {
    "tenant-id": "CgN0dG4="
  },
  "visibility": {
    "rights": [
      "RIGHT_APPLICATION_TRAFFIC_READ"
    ]
  },
  "unique_id": "01F1GBXD8NDV7HXP6NEHSDCE76"
}

So I got my own gateway today. After setting it up my node was able to join via OTAA on the first attempt.
Thanks again for your support.

1 Like

Hi mosivers, can you let me know what gateway are you using? Thanks.