Move your TTIG to V3: YES!

I have good news: TTIG claiming is now enabled in the V3 Console.

For details, see this page on our documentation site, but here is a quick summary of the steps to claim your TTIG on V3:

  • Make sure your TTIG is not yet registered on V3. The claiming process will register it for you.
    • If you did already register your gateway on V3, you can delete it, but then you’ll have to choose a different Gateway ID for the claiming process.
  • Find the EUI of your TTIG. This should be printed on the sticker on your gateway. The EUI starts with 58A0CB, then on some stickers there’s FFFE (if it’s not, just imagine it’s there), and the EUI ends with 80****.
  • Find the WiFi password of your TTIG. This should also be printed on the sticker.
  • Go to console.cloud.thethings.network/gateways/claim and select the V3 cluster you want to use.
  • Enter the Gateway EUI.
  • For Claim authentication code, enter the WiFi password of your TTIG.
  • Choose a Gateway ID. You can’t use a gateway ID that is (or was) already registered on V3.
  • Select the frequency plan you want to use on your gateway.
  • Click Claim gateway.
  • Keep your fingers crossed and hope that everything works.
  • If claiming was successful, now either wait (up to 24 hours) for your gateway to reload or unplug your gateway, wait a couple of seconds and then plug it back in.
  • When you see your gateway online on V3, you can (but don’t have to) delete it from V2.

NOTE: If your The Things Indoor Gateway was sold by IoT-Shop.de (either directly or via Amazon.com) The Things Network was not always able to claim your gateway on the upstream server. This issue should now be resolved.

12 Likes

Works like a charm! Thanks a lot!

1 Like

perfect solution :partying_face:

2 Likes

I attempted this and it it gave me an error on the claim screen “No Claim Authentication Code”. I had a code entered (the wifi password on the back of the device). I confirmed it was correct by logging into the device using it.

I then claimed the device using the CLI which worked and my device is claimed and has a solid green light but still says disconnected in the console. I unplugged the device from the wall for a count of 30 and plugged it back in. Still showing disconnected.

I then tried to download the global_config.json file from the console for the device and got a failed to download with and error of “Failed to download global_conf.json An unknown error occurred and the global.conf.json could not be downloaded”

I am not sure where to go from here.

Welcome back :+1:

2 Likes

The global_conf.json has nothing to offer a TTIG - it is configured over the network.

How do you know? Does it have the four attribute settings in General settings and the two API keys?

AFAIK, that’s just says it is connected to the backend, it doesn’t tell you which backend because it’s just an LED.

Was it previously setup on v2? If so, is it showing traffic?

And the famous Jeff-Nick acid test, does a device near to it show uplinks routed via the gateway?

Thanks a lot for the solution. It works!

Make sure your TTIG is not yet registered on V3.

  • How can you tell if you are registered on V2 or V3?

Any gateway registered after 30 June of this year will be registered on V3 as registration on V2 was disabled that day.

Just my luck.
I registered my Indoor gateway on Jun 30, 2021 23:45:25.

So what, none of the instructions mention v2.

Just CLAIM it on v3

If you search the forum you’ll find multiple comments about not deleting it from v2 ‘just in case’.

I am trying…

Yes, very trying - please don’t double post, it’s not a good use of the volunteers time.

Hello, I claimed TTIG in V3 according to above documentation. I un- and replugged it but it stays disconnected in the console and the green LED blinks (freq 1/4 sec).
Before, the TTIG was disconnected for months because I changed WIFI password and forgetting to change it in TTIG as well - I have corrected this. How can I trouble shoot?

Can you check if the extra BasicStation info has appeared in the gateway settings (menu on the left will get you there, scroll down a bit, it appears after the description box, gateway server address & required authentication):

Screenshot 2021-07-10 at 12.32.59

You should expect the LNS key and the three attributes. The numbers/entries/details will not necessarily be the same.

If you can’t see any of this stuff, then delete the gateway and re-claim it.

You will not be able to reuse your gateway ID so think of another one.

PS, the public bit is optional, I turned it on because I’m a nice TTNer

I did everything you wrote above, I can see that the gateway is connected to my WiFi AP, I can ping the IP and I can see that it exchanges traffic:
image
image
But the status in the console remains “Disconnected”, the cups attributes are missing and the gateway blinks red and green. I let it run for 2-3hours but nothing changed… Any idea?

Yes,

Not sure why you remark on your gateway having the CUPS attributes missing, which implies you read my post but read my post above where it says

but when you read it this time, do not past Go, do not collect $200, just do it!

One of my TTIGs took three goes. It’s not a great state of affairs but there is a lot going on in the background to do a claim and it’s only been running a few days now so plenty more ironing out to do.

I did it at least 6 times before I wrote the post yesterday and nothing changed. So, yes, I read your post and also your copy/pasted post in the other thread. Does it help to be a moderator and assume that nobody reads your posts, basically expecting the worst from other people? In my experience if you try something so many times and it doesn’t work your in a situation where you need real help and that’s why I wrote the post, rather hoping for help than sarcasm.

Anyhow: I left the gateway unplugged over night and put it back in this morning and now it is connected. So my message to other users in the same situation: you might have to be patient, don’t expect the system to give you any helpful indication and keep re-trying, even if you have to do that many times.

When I follow this guide I get the following error
could not update CUPS credentials

Edit : I think this was an error in formatting after copying the eui from v2. When I manually entered it it seems to work

Something you choose not to share with us, so we had no context to your situation.

It doesn’t help to be a moderator as it takes up a fair amount of time, but you are confusing my role as moderator with someone who posts answers which is what I was doing above, you don’t have to volunteer to be a moderator to post pointed comments. As to expecting people not to read my posts, that would be a normal expectation, yes. Some threads go on for 40 to 60 posts before we get a result. If I ask three factual questions to help debug, I usually get at least one full answer, one partial and then we have to go back & forth to get the third answered.

If you’re game, you could add me as a collaborator that can manage gateways only and DM me your EUI and WiFi password and I can have a go.

[ModeratorMode] FYI, we don’t do ad hominem attacks here. [/ModeratorMode]

1 Like