New gateway: The Things Indoor Gateway

5km reached with the new antenna, TTIG indoor at 1st floor.


RS USA (Allied Electronics & Automation) has begun shipping USA orders. My TTIG ordered 3/13 was mailed last night from Ft. Worth, TX and is scheduled to be delivered tomorrow.


Is there any source code for the gateway’s firmware on ESP8266 ?
Is it possible to have it connect to anything other than TTN’s server ?

1 Like

No source available. Hard coded to connect to a server that configures it for TTN at the moment.

Mine arrived in Boston today! Just got one connected and successfully passing some data using the instructions:
(the EUI for me started with 58 rather than 5B… I can have trouble distinguishing them in tiny type)


A post was merged into an existing topic: Things Indoor Gateway - part 1

I had now the TTIG for a while and can now compare it with a RAK2245.
I realize, as many above that the TTIG is missing a lot of packets, and does not work with some of the channels. Is this problem solved ?

What is the way to update the firmware, and what is the current firmware ?
Mine is :

MFG date2018-12-11 09:03:45
FW Build2018-12-06 09:30:37
FW Version2.0.0
Core Version2.0.0(minihub/debug)

So I hope there has been a release since.
Thanks for any help.

I too found that some packets get lost. Packets I know of because received by 2-3 gateways at distance (10-20km, not mine).
My impression, formed initially when I observed with some attention the gateway log in the console, is that the gateway is like deaf for some time after receiving a packet. This in part could be due to downlinks windows, but I did not check whether downlinks were sent too in those moments.

Interesting - a test to run could be to blast out two packets in quick succession, that aren’t actually from any recognized node (and therefore won’t generate any downlink reply) and see if they get reported as raw gateway traffic.

1 Like

This is something I promised myself to try, but I have yet to find time and will :slight_smile:

A post was merged into an existing topic: Things Indoor Gateway - part 1

Hi guys. Recently received the TTIG. Works like a charm. But… no power plug in the package from RS Components. Was really hoping to get one afterwards…

Have somebody got their hands on one?


Hi. Got my hands on gw - Eu model. Configured in console. Shows as online but no received/sent packets.

Testing via S76 module. It works on some other network i tested.

Not sure what else to do

The S76 worked on another network or the TTIG? My understanding is the TTIG configures via CUPS Server and only works on TTN/TTI?

Double check you have received 868EU version and not 915US…I received 5units and all boxes showed TTIG-868 with correct RS Stock code but the 5th was actually a mis-pack with a 915 in the box…check the label if it says TMBT100915xxxx and not TMBT100868 and has the FCC ID called out (bottom left of lable) you have a problem unit… (I’m aware of other instances not only mine)

If you have a 915 it will show up in console and appear as online but will be deaf to the 868EU Tx’s of the S76 so no traffic captured.

Good Luck! :wink:

1 Like

It worked on Lattelecom lorawan network -


Did anyone managed to get it working on AS923 or AU915?
I have a solid green light and a connected status on the console but no data packet coming through.

As per my post 6D ago above its not unknown for the wrong type to ship so double check you have a 915Mhz vs 868Mhz version. If it shows connected in the TTN Console then being wrong freq would mean its ‘deaf’ to your 915Mhz nodes and no data coming through and is one of the possibilities to consider… :wink:

Worth checking to eliminate possibility just in case…good luck! :slight_smile:

Maybe a stupid question, but how can I buy it? I can’t find any links.

1 Like

Not sure where in the world you are but sales are through RS Components/Allied.

Here is UK link

Single units:

Back in stock 17th June?

1 Like

I have both a TTIG and a RAK2245.

For test, I send a message every minute with a Steval-STRK01 Lora sensor.
With a message every minute, the RAK2245 got all messages, but the TTIG got only one message over two.

I have now repeated the experiment with a message every two minutes.
Now both TTIG and RAK2245 get all messages.

The sensor is in the house, but far away from the gateways

RAK2245 :
“rssi”: -67,
“snr”: 10,

“rssi”: -69,
“snr”: 10.75,

but variations occur. the rssi of both gateways are comparable.