Register end device - V3 Stack - Au1 - Missing Tenant ID error

Hi All,

Anyone getting this error registering a new device on v3 stack - au1?



I think you might be jumping the gun here. The au community cluster hasn’t been announced yet. Probably work in progress.

Hey Leo! I was under the impression that when AU1 was up here (see link below) it was “launched” :slight_smile: incorrect?

Hey Nick,

Yeah. I know it’s there. But only the EU cluster has been announced. I guess we find out the exact status this evening.

Ah right on. thanks mate. We’ll sit tight.

I’m getting the same error.

I think htdvisser kind of announced AU1 is live in a post about 16 hours ago in the Current and Upcoming Clusters topic. The link is posted and seems to be live

Yes. New infrastructure is there but is undergoing testing after community call with Johan last night.

I would suggest to bring this up in the Slack #support or #the-things-stack channel so the infrastructure guys are aware.

Yep, getting the same error:

  "code": 3,
  "message": "error:pkg/tenant/middleware:missing_tenant_id (missing tenant ID)",
  "details": [
      "@type": "",
      "namespace": "pkg/tenant/middleware",
      "name": "missing_tenant_id",
      "message_format": "missing tenant ID",
      "correlation_id": "bbdb095512164941993148586f994bfe",
      "code": 3
  "request_details": {
    "url": "/ns/applications/cttg-agri-sensor/devices/2028a0008",
    "method": "put",
    "stack_component": "ns"

I’ve posted the error in the #support channel on Slack. Let’s see if we can get it resolved.

We just fixed this issue.

The new nam1 and au1 clusters are still considered “under maintenance” (see also until we’ve verified that everything works as expected. You can already try using the new clusters, but there can still be some things that we need to tweak.


Thanks @htdvisser all good from our end!

we are getting same error , how to resolve this issue
{ 2 “code”: 3, 3 “message”: “error:pkg/tenant/middleware:missing_tenant_id (missing tenant ID)”, 4 “details”: [ 5 { 6 “@type”: “”, 7 “namespace”: “pkg/tenant/middleware”, 8 “name”: “missing_tenant_id”, 9 “message_format”: “missing tenant ID”, 10 “correlation_id”: “f3a9e44e91b14204882eec56194d798e”, 11 “code”: 3 12 } 13 ] 14}

Without knowing what actions you took (what buttons you clicked in the Console, what CLI commands you ran, what API calls you made) to end up with this error, it’s impossible to help you with this, I’m afraid.

Blockquote htdvissr

we are installing first time Network server , we are getting the above mentioned error while opening UI.

no button clicked on the console,no action carried out to get the error.

Based on the little information in your posts, it sounds like you’re trying to install The Things Stack Enterprise with a multi-tenant license.

If it’s saying that the tenant ID is missing, you’re probably missing the tenant subdomain in the URL when you try to access the Console (https:://{tenant-id}.yournetwork.tld/console).

Note that if you subscribed to a support plan with The Things Industries, you can also file a support ticket. TTI’s support staff may be able to walk you through the steps to get up and running.