The Things Industries The Things NODE

Any support questions you might have can be asked here:
https://www.thethingsnetwork.org/marketplace/product/the-things-node
image

I get this message when trying to upload a sketch to the things node:

avrdude: ser_open(): can’t set com-state for “\.\COM7”

I have tried 4 different USB cables on two computers - same result, I have also tried putting the node into bootloader node as suggested in the troubleshooting section.

I am using Windows 10 - the TTN Uno seems to program fine using the same setup.

Thanks

It might be that the bootloader is corrupted. Than can be corrected.

Thanks for the reply - how do I go about reloading the bootloader, I tried the option given in the troubleshooting section - double press on the reset but I still couldn’t connect.

This site is giving solutions for solving isses with The Things Node: https://www.thethingsnetwork.org/docs/devices/node/troubleshooting.html
As the hings Node is using sparkfun bootloader this page might be interesting too: https://forum.sparkfun.com/viewtopic.php?t=27960

Hi,

I have already tried the TTN troubleshooting route - no luck. Reading through the Sparkfun topic I see most of it involves the “stk500_getsync()” error message which is not what I am getting. I also do not have an FTDI programmer.

If I cannot get it to respond via the normal USB cable then I will return the node for a refund.

Thanks

As for “the same setup”: does the Uno report the same COM7? In other words: any chance you need to use a different port for the Node? In other words: is COM7 what the Arduino IDE is suggesting to use?

Hi,

Apolgies for the confusion - I tried it on two PCs and the one I used to send these messages enumerated the USB as COM7 - the other PC (Lenovo laptop) brought the USB up as COM7 for the Node and COM8 for the Uno (Arduino Leonardo actually). Interestingly the Arduino IDE (latest version) picked up the Arduino Loeonardo (i.e. it showed the board name alongside the port but did not pick up the board name from the TTN node.

Would you expect the IDE to usually pick up the board name?

Thanks

Update - eventually after many many attempts (the timing is critical) I managed to get node to accept a blank sketch during it’s few seconds of ‘bootloader’ mode (press reset twice). After that a normal upload works as it should.

My advice to others in this situation is to keep trying - it does work eventually.

Thanks again to all those who took the time to reply to my original post.

I’ve just recently bought the Node along with the Gateway but after following the instructions to register the gateway and create the application for this device, I persistently just get a “Join not accepted: denied” message; the accompanying message says “Check your coverage, keys and backend status”, which all look fine as far as I can tell.

Can anyone provide me with advice on how to go about troubleshooting this?