The Things Industries The Things UNO

Any support questions you might have can be asked here:

1 Like

I recently purchased TTN UNO and right out of the box the device couldn’t be seen on the activation map. I ignored this and carried on with the quick setup. During the setup process I was able to get the device to communicate with the application on TTN. However, since then I cannot get it to join via OTAA, all i get is Join not accepted: denied. I deleted the app and registered the device but still cannot connect! If there is any information that could help it would be greatly appreciated.

I suggest try it again

do you have a gateway that is listening ?

Unfortunately I don’t have my own gateway, I am just using whatever gateways are in my local area.

Tried following the setup video, received the same outcome:

Sending: mac join otaa
Join not accepted: denied
Check your coverage, keys and backend status.

So it’s possible that your node is working but can’t join the network because it’s not received by a gateway.
If you are sure you are close to a working gateway try moving to another location in the house.

it can also be a key problem

Tried in a different house located beside a working gateway, still facing difficulties, checked and double checked the keys but no luck. Not sure how to progress from this.

I suggest have a look at the console of a gateway and see (and copy) what you see there, because its very difficult to ‘debug’ this without more information from you.
try to contact someone from a local TTN community …and maybe he/she can have a look at his/her gateway console and see what really going on.

your sure your antenna is good… cable … connection, and your power is enough ?

19 posts were merged into an existing topic: TTN UNO rn2483(A) questions

I have a similar question as ross_s. I purchased a Things Uno from Element4 (915 MHz unit) in the US. When I try to activate it I am unable to see it on the map.

Is a gateway required for this to work? I only see a couple of gateways in my area (Orlando, Florida) and neither of them are close by.

yes, a gateway within range of your uno.

My code:

#include <TheThingsNetwork.h>

// Set your AppEUI and AppKey
const char *appEui = "xxxxxxxxxxxxxxxx";
const char *appKey = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";

#define loraSerial Serial1
#define debugSerial Serial

// Replace REPLACE_ME with TTN_FP_EU868 or TTN_FP_US915
#define freqPlan TTN_FP_US915

TheThingsNetwork ttn(loraSerial, debugSerial, freqPlan);

void setup()

  // Wait a maximum of 10s for Serial Monitor
  while (!debugSerial && millis() < 10000)

  // Set callback for incoming messages

  debugSerial.println("-- STATUS");

  debugSerial.println("-- JOIN");
  ttn.join(appEui, appKey);

void loop()
  debugSerial.println("-- LOOP");

  // Prepare payload of 1 byte to indicate LED status
  byte payload[1];
  payload[0] = (digitalRead(LED_BUILTIN) == HIGH) ? 1 : 0;

  // Send it off
  ttn.sendBytes(payload, sizeof(payload));


void message(const byte *payload, size_t length, port_t port)
  debugSerial.println("-- MESSAGE");

  // Only handle messages of a single byte
  if (length != 1)

  if (payload[0] == 0)
    debugSerial.println("LED: off");
    digitalWrite(LED_BUILTIN, LOW);
  else if (payload[0] == 1)
    debugSerial.println("LED: on");
    digitalWrite(LED_BUILTIN, HIGH);

I made an application and put my apps EUI and key into the uno but Serial keeps returning the following error:

Sending: mac join otaa 
Join not accepted: denied
Check your coverage, keys and backend status.

This is my first time using LoRaWAN and the things network.


I am trying to power up my Things Unos via an AC/DC wall adapter with barrel jack connector but to no avail. I was looking for instructions specific for the Things Uno but couldn’t find any, so I followed the specs for Arduino Uno/Leonardo instead.

I’m using a 9V, centre positive switching power adapter, bought a few of them and checked that I am actually getting 9V out of them and in the correct polarity, but none of my Things Unos turn on. They work fine plugged in via USB either to computer or a USB mains adapter.

What could be the issue?


strange… I tested it just now and it works.


  • update

check this ?

Did you ever resolve this issue? I have exactly the same problem using a Things Node but I also have their gateway that shows a Join Accepted message being generated and sent but apparently never being received at the Node. Same error messages in the Serializer as yours…

What is the distance between node and gateway? Keep them at least 3 meters apart.

They’re on separate sides of my house but I’ve also tried from outside since it’s nice and compact but with the same results.

I recently purchased a TTN indoor gateway, a TTN outdoor gateway, 2 TTN NODE’s and 2 TTN UNO’s.
after a bit of a learning curve I have both gateways working and both TTN NODE’s are reporting. Both NODE’s worked out of the box to TTN mapping, and then worked fine when I changed the sketch to what I needed.
But neither of the TTN UNO’s even show up on my windows 10 computer. I have tried 2 different laptops and desktops, different cables; and still the same issue. Error 43 on windows USB device. I do have it set to Arduino Leonardo board and the TTN libraries loaded. I’ve tried uninstalling the usb driver and re-installing. I can connect with same cables to the NODE units, but not the UNO units. I even tried 2 different brands of ICSP USB cables instead of the normal micro-usb cable.
Thanks in advance for all hints, directions… jedi tricks are welcome. I’m stumped.

I already had ‘verbose output during upload’ checked. I can’t even get to upload sketch as the UNO board does not show up as valid usb serial port.

I checked the library and i currently have The Things Network Arduino Library version 2.5.16 installed.

So that doesn’t seem to be the issue. When i reboot Arduino IDE and remove USB cable and insert again i get windows msg ‘setting up Arduino Leonardo’, then msg of ‘unrecognized usb device’, this usb device malfunctioned.

I plug in either of the new NODE units with same cable and they are fine. I plug in either of the new UNO units and this same error. Could I possibly have gotten 2 bad boards?

From the symptoms that is not unlikely. The boards might be missing the bootloader software or have a hardware issue. Time to contact your supplier and ask them how to proceed.