TTIG "not connected"

Seems this is normal in the meantime. My TTN-GW behaves the same if there is no traffic in the air. If a device is sending data over the air via the GW its state becomes connected again.


Same situation here. I am located in the US, connection through ttn-router-us-west. I have a confirmed TTIG 915 and my gateway id is eui-58a0cbfffe800b8d.
I was able to get it connected in the console when I first set it up approx 2 weeks ago but it drops the connection after approx 1 hour and shows not connected in the console. I was not able to receive any messages as of today. Tried different wifi networks, broadband/router setups.
Currently shows not connected in console, here is current logged serial output from gateway:
2020-03-31 14:56:53.633 [AIO:WARN] [2] Ignoring WS ping/pong message
2020-03-31 14:56:53.675 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:56:54.679 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:56:55.683 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:56:56.686 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:56:57.690 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:56:58.694 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:56:59.698 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:00.702 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:01.706 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:02.538 [SYN:VERB] Time sync rejected: quality=1070 threshold=1069
2020-03-31 14:57:02.710 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:03.714 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:04.643 [SYN:INFO] Time sync qualities: min=1046 q90=1069 max=1070 (previous q90=1069)
2020-03-31 14:57:04.647 [SYN:INFO] MCU/SX1301 drift stats: min: 0.5ppm q50: 1.7ppm q80: 2.4ppm max: 2.9ppm - threshold q90: 2.9ppm
2020-03-31 14:57:04.654 [SYN:INFO] Avg MCU drift vs SX1301#0: 1.0ppm
2020-03-31 14:57:04.718 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:05.723 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:06.726 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:07.730 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:08.734 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:09.738 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:10.742 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:11.746 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4
2020-03-31 14:57:12.752 [SYS:DEBU] Free Heap: 19232 (min=17264) wifi=5 mh=7 cups=8 tc=4

Restarting the gateway reconnects me for approx 1 hour in the console.

Any idea?

thank you

I also have a TTIG indoor gateway. It worked since December. However now when I go to console I see it offline. I unplug and replug the gateway and it shows online again. I’ve even resetted and setup the device again, but still failure persists.
If you look at there are a lot of gateways red/offline on the map. So I believe thats a genral issue. Hope there is a solution that gateway stays permanently online.

Please look on the official status site:

The Gateway shows as offline, but transmits the received packets.

So this problem exits since January? When will it be fixed? It causes gateways to be deleted from ttnmapper because these gateways seem offline.

The NOC component will not be fixed:

To be more specific: The issue will not be fixed in the current V2 version of the TTN stack.
Migration to V3 will follow later this year.

I recently bought a TTIG and I can not get it to work. I filled out all the data on the TTN website and I am sure that I filled out the EUI correctly. It is eui-58a0cbfffe802768. I managed to wireshark the traffic that is sent between the TTIG and some backend ( It ends with an ‘Encrypted Alert’ sent to TTIG after which the connection is terminated.
Any ideas how to proceed further?

Thanks in advance.

Hey @jerryneedell. This seems like a mess-up by the distributor. They’ve given us the gateway information now. Can you check if you can connect it?

Mine works now. I just discovered a solid green LED. And I can also see data passing at the web console.

I added my TTIG yesterday. It shows not connect when ever I a have a glance in the console.
The console shows last seen 8 hours ago.

Any ideas.

Same here. Just installed and connected my new device (TBMH100) but it won’t connect. The UART logging shows (had to invalidate the URLs, coz of new user 2 links restriction):

1970-01-01 00:00:07.246 [CUP:INFO] Starting a CUPS session
1970-01-01 00:00:07.255 [CUP:INFO] Connecting to CUPS … hxxps:// (try #1)
1970-01-01 00:00:07.267 [any:INFO] cert. version : 1
serial number : 01
issuer name : CN=Root CA, OU=TrackCentral (ez5Cj0eN), [](, C=CH
subject name : CN=Root CA, OU=TrackCentral (ez5Cj0eN), [](, C=CH
issued on : 2018-11-22 10:23:38
expires on : 2024-11-20 10:23:38
signed using : ECDSA with SHA256
EC key size : 256 bits
1970-01-01 00:00:07.293 [AIO:INFO] cups has no cert configured - running server auth and client auth with token
1970-01-01 00:00:07.387 [CUP:VERB] Retrieving update-info from CUPS hxxps://…
1970-01-01 00:00:13.955 [SYS:DEBU] Free Heap: 26168 (min=25664) wifi=5 mh=7 cups=1 tc=0
1970-01-01 00:00:14.057 [any:VERB] Failed to retrieve TCURI from CUPS: (404) Not Found
1970-01-01 00:00:14.061 [AIO:DEBU] [2] HTTP connection shutdown…
1970-01-01 00:00:14.068 [SYS:INFO] sys_inState - Ignoring state transition: 5
1970-01-01 00:00:14.071 [CUP:INFO] Interaction with CUPS failed - retrying in 1m
1970-01-01 00:00:14.075 [TCE:INFO] Starting TC engine
1970-01-01 00:00:14.080 [TCE:ERRO] No TC URI configured
1970-01-01 00:00:14.090 [TCE:INFO] INFOS reconnect backoff 0s (retry 0)
1970-01-01 00:00:14.093 [TCE:ERRO] No TC URI configured
1970-01-01 00:00:14.096 [TCE:INFO] INFOS reconnect backoff 10s (retry 1)

Finally, the issue was an unprovisioned gateway. My vendor forgot to unlock the device. I was able to detect that with the following POST request (substitute with your gateway id):

$ curl -k -i -X POST --data '{ "router": "xx-xx-xx-FF-FE-xx-xx-xx" }'
HTTP/1.1 404 Not Found
Content-Type: text/plain; charset=utf-8
Content-Length: 15
Date: Sat, 02 May 2020 21:13:07 GMT
Server: Python/3.6 aiohttp/3.5.4
Connection: close

Not Provisioned

Especially thanks to @KrishnaIyerEaswaran2 who assisted even on a Sunday!


same issue. After normal setup procedure, status changed to “not connected”, despite green led is solid.

Best regards,

My gateway was recently offline, too (last 6 hours). Turning it off and on again solved the issue.

How do you determine it being ‘offline’? Could you please characterise it in a bit more detail? What is the state of the LED?

also the same issue.
It is not connecting.
Any tipps?

My TTIG is still listed as online.
My Raspberry Pi + RAK831 however is listed as “Last seen 7 days ago”.

Sometimes (once every few months - that’s at least when I notice it) the Pi based gateway is listed in TTN console as not online.
I thought this was caused by a hickup of the gateway and when I detect it, I just reboot it (without actually checking if it is truly offline or that TTN console just reports an incorrect status).
The reboot usually makes it listed as online again.

So today when I noticed “Last seen 7 days ago” I just rebooted the Pi gateway.
After reboot the TTN console still shows “Last seen 7 days ago”.
But in the Application Data tab I just see messages coming in and the Pi gateway listed as “Last seen 7 days ago” is listed as one of the gateways that received the message. So while it is listed as offline it is just working.

1 Like

Wasted a huge amount of time trying to debug GW’s over weekend and Monday and tracking some of the outages and \Console issues flagged by others in recent days (changing back haul connections, changing/reprogramming Wifi links & router connections, multiple reboots, pinging GW’s to confirm on local connections, pinging external servers from GWs to confirm they had viable internet connections, doing software rebuilds etc… :frowning: ) . Like you mine are showing Last seen 7 Days ago now… problem is I have 11GW’s currently in that state (out of 30+)… I finally followed Jac’s (@kersing) suggestion to another forumite and loaded up ttnctl yesterday and after a bit of a battle (meatware problem and lack of experience on my part I guess!) finally managed to get all my GWs listed and worked through status of each in turn confirming they were online (well most of them!) problem is its laborous compared to just a quick eyeball scan down the Console GW page and fact 2 TTIG’s and a TGW cant be seen (‘gateway ‘ID’ not found’) and looked to be stuck offline despite fact they have been rebooted a few times and in the case of the TGW have 4 stable leds. Console inadequacy is unsustainable esp as number of GW’s escalates - have more waiting to go online but cant be bothered until I can be sure I can see them online and wont be wasting my time debuging status or backhaul issues where real problem is its just the Console misreporting :frowning:


Hi, same issue here…
‘not connected’ while LED is solid green…