TTN GATEWAY central


#332

OK @bsiege , let me understand this correctly
I have a mostly working gateway (thanks goodness) and have highlighted a shortterm way to mitigate its known “connection” issues in a cheap manner.
Where have I said that it should be a permanent fix?
I’ve posted on here offering to help others to use my network environment to test their gateways.
I’ve also posted on here giving detail about what steps I took to get a successful activation

Whilst I agree with your sentiment and have liked your post, I was just trying to respond to a post from @onehorse because we have a similar connection issue.
It wasn’t anything designed to excuse the problem (as you seem to think it is), but it is supposed to be a sticking plaster to give time for a proper solution to be made.
I’m sorry for you that you see my post differently to how it was intended to be.
Do you always kick messengers of bad news? :slight_smile:


(Grahame Horner) #333

FYI, deleting a gateway from a console, doesn’t delete all the associated information; I deleted a gateway named gcs-ttn-example-gw-001 which has information with regards to last seen 20hrs; recreated a gateway with the same name, and information was displayed from the previous instance


(myLoraLake) #334

How much time does usually the activation process take ? On my gateway it moves from blinking LED 2 during several seconds to blinking LED 3 then goes to standing 3 LEDs on and then back to no LEDs and to blinking LED 2, and it does so for a several minutes. I tried to disconnect reconnect the power, no change.


(Dolphin) #335

It takes from 30 seconds to 2 mins to get the configuration settings in place.
See here: https://www.thethingsnetwork.org/docs/gateways/gateway/

But in my case, it’s also a never ending loop… no idea, but will not work.


(myLoraLake) #336

Oh, this I know… went through it. My gateway reboots every 60 seconds…


#337

For mine (which works fine) around 60 seconds…


(Bsiege) #338

Easy! Ok, sorry after rereading the post there could be the idea, that i offend @CurlyWurly. My intention was more to wake up more makers that it is time to name the real issues and not doing workarounds for for badly designed gear. The Gateway is still not finished and outdated before delivery. There are many Hackers/Makers out there who have the potential to take care about this. But they have a open source gateway without any source or documentation. Look at Sonoff/ESPeasy/Tasmota whatever: Improvement is everywhere.


(myLoraLake) #339

One more precision from my observations. I have one gateway that crashes approx. every 60s. More precisely it crashes approx. 10s after it says “Config correct: True” and “Gateway card: 868MHz”. If I block the network, it takes much more time to reach that status without crash. But when the network is back, it proceeds … and then crashes. I have seen that sometimes it goes twice to “Config correct: True” before is crashes.


(Grahame Horner) #340

Ok FYI I’ve managed after a little bit of trial and error to deploy a private TTN backend including a very hacky account server, using some outdated documentation I have published in a blog. I believe this now completely rules out environment issues with regards to gateway activation and reboot issues as I’m seeing exactly the same behaviour.

On the upside I now have a completely isolated TTN backend ready for when the gateway issues are resolved and I’m working on creating a Microsoft .NET standard version of the Application SDK which I’ll post on GitHub in due cause.


(Marcel Domingus) #341

Hi, Grahame, if you are willing to share a write-up / blog post on how to deploy a private TTN backend, I would be very interested! TIA.


(Grahame Horner) #342

@mrjdomingus I’d be more than happy to share a write up this, I will be doing a little work in hope to smooth out the rough edges and be repeat what I learnt from my first attempt, also I will be looking into creating a high availability deployment, as this deployment was using a signal machine with docker CE

HA may require nginx not sure as yet, be good to know what if/how the TTN do load balancing?


(Guru) #343

Gateway is DOA. 5 lights and an 8-second reboot loop. No console output when it does this.

Console output:

**************************
*   The Things Network   *
*      G A T E W A Y     *
**************************
Firmware name: AmazingAckermann, type: 0, version: 1.0.0, commit: 917719b9, timestamp: 1498499973
Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
Build time: Jun 26 2017 19:59:53
Reboot reason: 0x03
BOOT: (persisted info) 6F 72 72 65 01 03 BB FD 8E 4D E4 2D 9A F7 FA DC 




WIFI: Entering state 0
WIFI: Entering SCAN state 0

MAIN: Initialisation complete
LORA: Changing state from 0 to 0

MAIN: Leaving state 0
MAIN: Entering state 1
FLASH: Magic bytes found: wifi config present
FLASH: Magic bytes found: activation data present
FLASH: Magic bytes not found: no stored FOTA data present
FLASH: Loading Firmware Data
CNFG: (Firmware HASH (sha256)) FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF 
FLASH: Loading WiFi Data
CNFG: WiFi SSID:      **REDACTED**
CNFG: WiFi key:       **REDACTED**
CNFG: WiFi conn_type: 4
CNFG: WiFi sec_type:  4
FLASH: Loading Activation Data
CNFG: Gateway ID:         **REDACTED**
CNFG: Gateway Key:        **REDACTED**
CNFG: Account Server URL: https://account.thethingsnetwork.org
CNFG: Locked:             true
CNFG: Locked first time:  false

MAIN: Leaving state 1
MAIN: Entering state 2
INET: State change to 0
LORA: Initialisation complete
LORA: Changing state from 0 to 1
WIFI: Entering state 1
ETH: IP Address: 0.0.0.0 
WIFI: Entering state 4
WIFI: Entering SCAN state 1
Scan is completed successfully
WIFI: Entering SCAN state 2
WIFI: Entering SCAN state 5
WIFI: Entering SCAN state 0
WIFI: Entering state 2
WIFI: Disabling modules
Head magic match void: trying to free an already freed block, ignore
WIFI: Entering state 3
SNTP: State change from 0 to 1
INET: Gateway has Ethernet
INET: State change to 2
INET: Connected to a network, waiting for DHCP lease, checking validity with ping
WIFI: Enabling modules for server
WIFI: Entering state 6


>WIFI: IP Address: **REDACTED** 
CB: ETH: IP Address: **REDACTED** 
SNTP: State change from 1 to 2
SNTP: State change from 2 to 3
SNTP: State change from 3 to 4
INET: State change to 3
INET: Ping probe
INET: Error sending probe on WiFi
INET: Ping response from PIC32INT, set as default
INET: State change to 4
SNTP: State change from 4 to 5
SNTP: State change from 5 to 6
SNTP: State change from 6 to 7
INET: State change to 5

MAIN: Leaving state 2
MAIN: Entering state 3

CNFG: Load online user config state change to 4
HTTP: Close active socket 0
HTTP: Starting connection
LORA: Wait init complete, waiting for application.
LORA: Changing state from 1 to 2
HTTPS: Connection Opened: Starting TLS Negotiation
HTTP: Wait for TLS Connect
HTTP: TLS Connection Opened: Starting Clear Text Communication
HTTP: Got 1281 bytes
MON: SYS Stack size: 2863
MON: heap usage: 228KB (233KB), free: 111KB
HTTP: Connection Closed
HTTP: Close active socket 1
CONF: Parsing response token: HTTP/1.1 200 OK
CONF: ROUTER URL: mqtts://bridge.eu.thethings.network:8883

CNFG: Load online user config state change to 6
FREQ: APP_URL_Buffer: https://account.thethingsnetwork.org/api/v2/frequency-plans/EU_863_870
HTTP: Starting connection
HTTPS: Connection Opened: Starting TLS Negotiation
HTTP: Wait for TLS Connect
HTTP: TLS Connection Opened: Starting Clear Text Communication
HTTP: Got 1232 bytes
HTTP: Connection Closed
HTTP: Close active socket 1

CNFG: Load online user config state change to 7

CNFG: Configuring LoRa module
LORA: Changing state from 2 to 4
LORA: Starting reconfiguration
MON: SYS Stack size: 2863
MON: heap usage: 152KB (233KB), free: 187KB

Have tried:

  • Ethernet and WiFi.
  • LoraWAN module in/out/with extra pressure/gently stroked.
  • Nothing obvious in the serial output.
  • Waiting for someone to return from KFC with a dead chicken to try that.

(Christian Studer) #345

CONFIGURING Step 4
waiting for gateway chrisartgw to check in…

even after 15 minutes and longer, all 5 blue LEDs light up for 7 seconds, clear for half a second and then light up again for 7 seconds, etc.
Also a reset and reinstall did not help.
What else can I do now?


(Erwin Homan) #346

My TTN-gateway does the same. And there are more. See this thread.

Wait until The Things Network come up with a solution.


(Martinaarts) #347

How did you delete the gateway from the console? I end up with multiple gateways after resetting.


(Grahame Horner) #348

goto the console, select gateways, then the gateway you wish to delete, the settings for the top right of the panel.
at the bottom of the gateway details you should see delete.

it would be good to have a quick delete from the list of gateways; possibly adding a checkbox to the list where you can select one or more gateways to delete


(Dolphin) #349

I asume - nothing. I have the same troubles, the only thing that change reboot within 2 up to 60s (depend on ethernet / wifi connection / available wifi). Registration ok, but no connection, no dataflow. Non idea how to solve this problem - sorry.


(Dolphin) #350

the same result with my gateway…


#352

To contrast all those bad experiences/problems:
I recently got my gateway, the node and the 2 unos. Dis not setup the unos so far but setting up the gateway and the node exactly following the quickstart guides. Allowed me to setup and activate the devices within minutes without any problems. No reboot problem. I do not know about the 24 hour reboot, will check.
Gateway connected via wifi to my router, Provider Swisscom, location Zurich.


(Arjan) #353

Just heard at the conference it has no functionality yet.