Not sure if useful to others, but I activated my gateway entirely by Wifi using the latest version of win10 as follows:
N.B. If something has gone wrong, then I understand you can reset it to factory before trying this again?


  • Use a win10 computer that is wifi enabled (Don’t connect via ethernet)
  • Using your Win 10 computer, “Forget” the Wifi connection and reconnect making sure your wifi connection for broadband is ticked to connect automatically and looks for anything on the network
  • Attach the antenna and switch the gateway on where it can get a good wifi signal with your broadband router. N.B. When it powers up, the gateway is first in AP mode (you will see it listed in your computer’s Wifi connections).

Right so now what?

  • The first thing you do, is go to the TTN activate page (via your broadband - gateway not involved yet)
  • Follow the initial instructions on the TTN web page and at some point, it will display a password It is at this point that you go to your computer’s WIfi connections and sign into the gateway wifi AP using the password you have just been given,
  • The TNN Web page will advance to the next step and you will be prompted to give the broadband SSID and password that your computer is using.
  • Once you have pressed continue, the info will be passed to the gateway and then it will then reboot (it will dissappear from your Wifi list). 2 things will happen - your computer will now reconnect back to your broadband and the gateway will no longer be an AP (because it will try to sign into your broadband SSID)
  • If your gatway connects to your broadband OK - then hopefully, the rest of the process should be OK
  • In the TTN console, switch off “automatic updates” for your gateway
  • Once all set up. switch off your gateway and install where you want to put it. When you power it up next, the gateway should now aiutomatically connect to give you 4 LEDS

Hope this helps?

1 Like

Hi, guys (@htdvisser, @rish) , also checking in to report a similar reboot loop issue as reported elsewhere in this thread.

Although I managed to register / activate my (finally!) received TTN gateway relatively easy, it will maintain a stable connection only for some 5-10 minutes and then will spontaneously reboot. After a few iterations it may become stable again for a short while and then enter the reboot loop again.

Any assistance / progress reports regarding this issue would be appreciated.


the contents of my gateway info

Version Info

Hardware: v1
Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
Firmware: v1.0.0-917719b9 (2017-06-26T17:59:33Z)


Uptime: 565
Connected: true
Interface: WIFI & Ethernet


Activation locked: true
Config correct: true
Region: EU_863_870
Gateway Card: 868Mhz

Packet forwarding

Broker connection: true
Packets up: 0
Packets down: 0


External storage:

1 Like

Hi @vanesp , in which country are you located and which ISP are you using ? I suspect that I have a problem with the ISP blocking the link or not supporting the protocol.

Netherlands, Ziggo as ISP. I have done nothing special to get my gateway to work, other than using a wired Ethernet connection. It worked out of the box.

Your info page shows that you can access the Gateway. I presume, because Packet Forwarding says: Broker connection: true, that the Gateway is connecting to the TTN. If you go to your TTN Console page, and then check your Gateway, what does it say for “Gateway Status”, Last Seen?

Have you tried sending packets through your gateway using a the TTN node or the Uno?

I don’t like to says “me too” however in this case this is all I can say. Gateway received today, installation done as prescribed and gateway keeps rebooting.

Same here, the setup (wifi and ethernet) seems to be okay but never comes “online”, keeps rebooting I am going to wait for a solution, I do hope at some point (hopefully soon…) some of the TTN development team will respond with a proper solution.

I am having the same issues. Have not found a solution yet.

Exactly the same here, reboot loop.

I have a TTN Node that sends data, it is received by another gateway in Neuchatel (Switzerland).

The gateways on TTN console says the following

Gateway ID loralake_gw01
Description     A TTN gateway in an appartement
Owner    LoRaLake Transfer ownership
Status    not connected
Frequency Plan    Europe868MHz
Router    ttn-router-eu
Gateway Key    ttn-account-v2.···································································     base64
    (gateway key ends with the same number as the one I can read on the gateway)

Last Seen
Received Messages
Transmitted Messages

So it does as if it never saw the gateway, but it was somehow able to set its ID.

on the subject of activation

I got my gateway activated and on line with some hickups, it is now running for about one day.

When I reboot the gateway it has initial problems (I use wired ethernet) to get connected. I have seen my gateway stuck with 3rd led flash. To get it correctly registered with the backend, I entered the gateway key again (read from the TTN website “console”, entered it in the “advanced” settings on the root-page (http://<gatewayaddress>) of the gateway, then I saw it rebooting and registering right away.


looks like I’ve got the same issue, full reset several times :’( is there a fix for this ?

Hi Rudi,

Can you indicate in which country you are located and who is your ISP ?

Thanks and Best Regards.

My experience is the same. Initially the gateway works. After a reboot the issue appears. It does not continue after the 3rd LED flashes and keeps rebooting. Tried to configure it over cable and Wifi, no difference there. I will try next Monday if entering the key solves the issue for me as well.

My gateway in NL connected using a fiber connection with Oxilion as provider. Why do you expect a relation to this?

Because one of the error messages says that Origin is not allowed by Access-Control-Allow-Origin which may bin linked to either the server refusing the connection (not knowing the origin) or the ISP refusing the message.

Interesting. I can check the ZyWall settings to see if it strips this from the header.

Our friends at TWTG.io4 are working on getting everything ready for Github. They promised us that we could publish it during the conference.

Please allow a simple question: Although there where delays, the definitive hardware design and the delivered firmware is over a half year old. In the Kickstarter there is still the promise of open hardware and open software. And they had plenty of time. I suspect we well see only the expected new firmware for the v3?

For information to the people trying to debug the issue, the error message is generated on the TTN Gateway Activation page. It is generated by the .js in the following part when reaching t.crossDomainError(). This happens at the time I click the greenish Configure Gateway button on stage 3 of the configuration:

l.prototype._end = function() {
        var t = this,
            e = this.xhr = b.getXHR(),
            n = this._formData || this._data;
        this._setTimeouts(), e.onreadystatechange = function() {
            var n = e.readyState;
            if (n >= 2 && t._responseTimeoutTimer && clearTimeout(t._responseTimeoutTimer), 4 == n) {
                var r;
                try {
                    r = e.status
                } catch (t) {
                    r = 0
                if (!r) {
                    if (t.timedout || t._aborted)
                    return t.crossDomainError()

Best Regards.

Connected my gateway to my home network, but get message that the network is down while everything works in my network. Do i need special Router firewall settings or do i something wrong

Is your message the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc. ? If yes, then we are several people having the same issue.