V3 Gateway status request via https fails with "unauthenticated"

Hi there – yesterday we tried to ask the v3 (experimental)-gateway status via https-GET-request:


but it fails with message “unauthenticated” - we double-checked in the v3. console of our gateway the checkbox for “Gateway status” = PUBLIC – yes, its activated. – Also we placed an API Key with the credentials for “Gateway status read” and tried to read via node-red. Here we included the API-Key as credential “Authorization” and within node-red its working fine here.

Today we are not sure about this status read function without credentials – as formerly (in v2 stack) we were able to ask all our community-gateways via https request without any authentication. Can somebody explain or evaluate this ? Thanks in advance !

There is no public API for querying gateway status in v3. It would be useful for debugging if this could be included, any thoughts on this @htdvisser?

The API you have used requires authentication in the headers as per docs.

It would indeed be useful if non-collaborator users can call that RPC. It won’t be available to unauthenticated callers, but any member of the network should be able to see the gateway status if the gateway settings allow it.

You can subscribe to this GitHub issue for updates.

In the meantime you could consider creating an organization for your local community, and giving that organization (some) rights on all gateways in your local community.


thanks a lot for your thoughts guys, i will follow up with node-red and share the results with a grafana dashboard for our local community !