Cannot register a new TTIG - "the gw already exists"

Hi there
I’ve just opened a brand new TTIG with id: eui-58a0cbfffe801225 and tried to register it in the console but I got the error message “Cannot register - the gateway already exists”.
I found the gw data in the db dump at https://www.thethingsnetwork.org/gateway-data/ with the following values:

"eui-58a0cbfffe801225":{
"id":"eui-58a0cbfffe801225",
"description":"TTIG - 868 - Dekker Chrysanten - Netherlands",
"attributes":{
   "brand":"The Things Industries","frequency_plan":"EU_863_870",
   "model":"The Things Indoor Gateway",
   "placement":"indoor",
   "version":"2.0.0"}

I configured the wifi backhaul of the gw and it seems it’s online (I could see it receives packets from my application), but as you can see in the values, there is neither owner nor any geo location data.
Moreover, 3 hours ago, I sow the last_seen property and not value in the description. Now you can see the description but no last_seen property.

Do we have a problem in the gateways db or management module?

How could I add the gw to my account and possibly become the its digital owner (not only real)

1 Like

The noc appears to show it live:
image

However I note that the uplink count is quite low suggesting it has not been online for very long.

It may be that ‘Dekker Chrysanten’ accidentally registered the wrong ID and it only then went live when you powered up (and your or local nodes then deleivered the uplinks), in which case hope he didnt simply delete as you cant then re-register. OR double double double check that the id you have entered exactly matches what is on your device - caution with B’s 8’s & 0’s etc. It may be you have mistyped and are trying to register the wrong one. (Easily done as I know the text is very small to my old tired eyes! :wink: )

Dekker isnt active on forum under own name - not found in search, so given looks like The Netherlands peraps another Forumite knows him from e.g. a local community. If so perhaps you can ask him if he still has it registered and get him to transfer ownership - or buy your TTIG off you so you can get another?! Sadly I didnt see a (fake) GPS location as its a TTIG so cant narrow down which local community he may be in/covered by…perhaps you can step through the full set (56off) of the NL communities and look for members in each matching him?! :thinking:
https://www.thethingsnetwork.org/country/the-netherlands/

2 Likes

Good find, and that’s easily checked?

@pshemek do you see the number increase when you have the TTIG connected? See http://noc.thethingsnetwork.org:8085/api/v2/gateways/eui-58a0cbfffe801225 (Note that this is an HTTP URL; if your browser tries to use HTTPS then using an incognito window may help.)

Aside, as this very recognizable name is not used for any other gateway, I wonder if it may have been returned after short experiments…

Strang you can’t find an owner for Dekker Chrysanten as google found the company in 5 seconds… Their contact page contains an address and phone details so if you are sure of the gateway ID (check the bottom of the embedded webpage, easier for cut and paste) you could try to contact them.

1 Like

Dho! As it was TTN I only did a quick check on forum search etc. Wider tracking down someone elses problem but feel a bit dumb I didnt suggest that myself! :wink:

You can do the following things:
Connect your TTIG to the network (WiFi) and keep it online, maybe you see at http://noc.thethingsnetwork.org:8085/api/v2/gateways/eui-58a0cbfffe801225 that it’s online with a new date and time, Capture that
Make a Node aktive and make for that a Application at the https://console.thethingsnetwork.org/applications/ and send some data. Youwill see at the console the data is coming in true the above gateway. Capture that.
Disconnect (power down) your TTIG, and send a gain a few message’s (data) with your Node. You will see no data is coming from/true the above gateway (Your TTIG). Capture that.
Make also a capture that you can’t add you gateway (gw already exist).
Communicate with the TTN so may they can help you to get the right owner ship. Maybe the gw is marked as deleted. Hope full TTN (TTI) can help you.
It looks that somebody has made a type in registration, and maybe deleted. It is for shure a easy mistake to make with all that numbers, why not make Barcodes for that :grinning: It happens every one with code from nodes, but you can change that but with gateway’s you can’t.
I have done a small search to this firm, or that in the same regio somebody else is busy with LoRa, I can’t find.
If nobody can help send it back to your supplier with the same info you have collected above.

Hey guys
Thanks for the quick reaction! Basically I have done all the things you proposed except contacting the TTN team on slack, what is being done now (well, in some minutes, after this post is written) .

To respond to your advises/questions:
@arjanvanb : once I connected the gw to internet and tested with my node, the packets arrived from my node to the application via the eui-58a0cbfffe801225 and my other gw 4 meters aside with basically the same rssi (55-60 dB)
@kersing : I checked Dekker straight away , but since the property owner of the gw in the db dump is absent, Dekker wouldn’t help me much anyway.
@jwijngaard : you are probably right - someone from Dekker most probably screwed sth up: tried to register their gw using euid of mine and then after realizing it didn’t work, deleted it in the consol ignoring the warnings

In general I don’t have a problem not having the gw in my until it works, but I’d rather have at least possibility to check the packets arriving to it.

I’ll keep you posted.

This gateway ID is registered by @Farm21. If they don’t actually own the gateway (anymore), they should delete it, so that you can register it.

If @Farm21 does still own a gatewaw with that ID, someone somewhere at a factory must have really screwed up, because these EUIs are supposed to be unique. In that case, there’s not much that can be done, I’m afraid.

Given the scary dire warnings about not deleting is it easier if they just transfer ownership from console if contacted?

2 Likes

I’d anticipate that you, @htdvisser, are not in sales or marketing?

Like many other consumer rights like right to repair etc, it’s not unreasonable that people can buy a unit second hand (I appreciate that that’s not the case here).

Or if there is the occasional registration problem there is a solution.

Or if the factory has a glitch (pause production just as an EUI is burnt in but before the system knows this, restart at the last EUI, end up with a duplication).

This can apply to other gateways, not just TTIG.

Attracting new people to the LoRaWAN cause is somewhat the whole point of TTN, killing the second hand market is likely to have a future impact.

Please could this be escalated, along with a change to the v2 gateway console so it has a message or link to the forum entry about the gateway last seen information.

Thanks.

3 Likes

@Jeff-UK: Sure, that also works.

@descartes: We are working on a feature called “Device Claiming” that makes it easier to transfer ownership of devices (and later also for gateways) in The Things Stack (v3). This will not be added to v2 though, so for now transferring ownership is going to require the old owner to assist with the transfer.

If anyone knows then it’s you, but we all make mistakes, so just to be sure: isn’t that the only way that works?

Delete gateway

You will not be able to restore the gateway or re-use its ID.

@htdvisser, thanks for the info about the current owner - without this I deducted from the json the gw doesn’t have an owner. I’ve just sent him/her a priv message to sort out the problem *wanted t add you in cc, but you’re not accepting messages :expressionless: )

In fact I bought 2 new TTIG in May 2020 from maker-shop - which was the only place to buy it in Switzerland. I registered the first TTIG without a problem just after the purchase. The second one was not so lucky.

Hopefully @Farm21 will clear out if there are two TTIG with the same id of there was a fixable mistake.

What about introducing a pragmatic approach: you can always delete a gateway if no packets were received by it? That would cover most of the cases of inputting invalid gateway id by mistake?

1 Like

Without being aware of all V2 implementation intricasies:
My common sense (based on extensive experience with software and hardware) says that this is all mainly about configuration / data.
From that viewpoint it should be technically possible to update, delete or invalidate such data to enable successfull reregistration of a gateway (even if this would possibly lose hostorical data).

But that of course is only as viewed from my simplified logical perspective.

Hi pshemek,

I’ve checked the registered eui against the actual gateway eui and indeed, I’ve made a typo. I’ve removed the gateway with the wrong eui so you should now be able to register your gateway.

Sorry for the inconvenience!

2 Likes

Removed? - Hopefully not ‘deleted given’ warnings as easiest to just transfer ownership as above?!

If deleted then Hylke will need to help step in and correct the database to allow re-addition?

With “Removed” you mean “Deleted”?
As in “You will not be able to restore the gateway or re-use its ID.”? :thinking:

Hey @Farm21,
Thanks for the super quick response and the explanation.
I’ve just registered my gw and it received successfully packets from my node.

@arjanvanb @bluejedi : it seems the dire warnings about deleting the gateway are a bit exaggerated - the minute after @Farm21 deleted the gw from his/her account, I was able to register it on my console.

2 Likes

This is how it used to work at least and therefore not something that the average gateway owner was willing to experiment with.

Maybe it was transferred, not deleted.
Or @htdvisser already automagically intervened?