New gateway: The Things Indoor Gateway

Brilliant, exact same here!!! I thought I was going mad - RAK831 is not doing this and yet the TTIG sat next to it is going crazy on triplet downlinks/join confirms.

yep… I’ve seen that before too, can even replicate :


1 Like

Hummm, went to have a closer look at mine soak testing and 1 is showng same behaviour


Looking closely this appears to be a repeating down link for a Laird RS1xx sensor that asks for occasional confirmed packets as part of keep alive/watchdog process.

Looking at @BoRRoZ and @bluesensing1 screen grabs like its the GW repeating downlink (ack or join accept?) in each case!? Is that expected behaviour I wonder…

Update on the 5th unit showing connected but no traffic - have left it running for many hours continuously to see if it started working, no joy :frowning: Have then checked Autoimatic updates box in console and again left running for many hours, still no joy and finally also checked Beta updates as well…again after many hours running and connected still no joy.

Monitoring all 5 I notice that the questionable unit starts blinking green LED every few minutes and I can see power consumption fall away each time suggesting it is going through a self reset/restart…looking more closely at the other 5 I have noticed all do something similar but the dodgy unit does this every few minutes where the others take far longer between flashing cycles…will monitor (have to sit and watch! - not very productive) for a longer period to see if there is a pattern and how it compares with the 4 apparently ‘good’ units.

1 Like

I don’t understand in which way the gateway could be causing the console to show multiple downlinks. Each downlink shown in the console should be issued by the back-end, not generated by the gateway.
Only thing I can think of is the Semtech to Basic Station translation layer somehow NACKing the downlinks and the back-end repeating them.


I forgot to post update on power consumption:

4660mAh after 17hrs
5466mAh after 20hrs…
And after a full 24Hrs…6541mAh

That’s around 55% of an original SMTC LoRa IoT STK (RPi2B based), 75-80% of a Laird RG186, 73-77% of a RAK831/RPi0W/Hallard interface board, and ~40% of a RAK Pilot (RAK831/RPi3B+) under similar test conditions.


so do you guys think this is TTIG related? do the nodes triggering this have ADR activated?

disclaimer : I’m not in anyway 'connected to TTI :sunglasses:

No, I never said that, I’m with Jac… this has something todo with the backend

well, go figure:

today i brought a different gateway (RAK2245) to where the triple-downlink-generating (ADR) node is sending. after starting it up it received the uplinks fine, no downlinks there - TTIG still returning triplets.

climbing up to the attic i found the TTIG (as others mentioned) is flashing it’s LED. checking it’s power supply i found it was a 1A, which i assumed might be a bit on the weak side, so i thought i’d try hooking it up to the raspi, which itself is powered with 2A only - but who knows … lo and behold - for several minutes the TTIG returned single downlinks only.

coming home now, opening the console for the two gateways unfortunately we’re back at triple downlinks from the TTIG. whereas the other gateway seems to sometimes try to take over the ADR-control and sends a downlink by itself instead - a single one i may underscore.


so yes. to me these triple-downlinks look like an issue of the TTIG (though being all but logical, as - as @cslorabox mentioned in another place - shouldn’t be able to “invent” downlinks by itself … but quite obvioulsy, something one could interpret like this is happening.

might bring the node home where i have “classic” TTG, curious if this would behave the same way.


1 Like

have you tried yet using a different / more powerful powersupply?

The TTIG does not put downlink information in the console, the back-end does. So I think the TTIG or the Semtech to Basic Station gateway software between the back-end and the TTIG is triggering strange back-end behavior.

@johan @htdvisser any idea what is happening? Is logging an issue on github for the V2 stack of any use?


The TTIG with the Basic Station PF has it’s own scheduler which might be causing some issue here. Will investigate.


Just receive information from Allied Elect, that the TTIG are expected to ship in the USA on 24 April 2019. What odd, is they have only receive less that 40 order for the device… I expected to see a lot more orders in the USA.


@trlafleur thanks for that info. I got the same date from them.

As to order quantity, we are way behind Europe with LoRaWAN adoption in the US. I like to think it’s because there are giant cell carriers with competing tech and lots of lobbying money in our perverse form of capitalism keeping adoption down. We are the David to their Goliath. The real reasons are probably far more complex. I am encouraged by the LoRaWAN evangelists I do know in the US, however. This community rocks!

1 Like


I just add a link to this pdf file with the foto’s off the modify off the TTIG gateway use it with a external antenne.

Just use a standaard SMA pigtail

and now just use a standaard 868 mhz rubber duck antenne.

After leaving my ‘connected’ but none functioning unit on line for a long period with many resets and checking automatic updates in console and even leaving beta option ticked just in case I finally gave up today and figured as I was thinking of modding for external ant using sma pigtail as others above I figured start with the failed unit…was also thinking to check for loose connectors or re-seating the radio bd just in case. Voided warranty:



All seemed sound from mechanical pov so was about to power up the open bd to check for operation when I noticed one small detail!


Per other peoples images it looks like the device is mis-shipped or mis-labled or mis-manufactured with the zero ohm resistor in the US position vs EU! :frowning:

Guess I will have to try and relocate component over the weekend to see if it fixes problem (at same time as adding the external Ant :wink: )

So 5 x 868Mhz ordered, 4 delivered and functioning with one that looks like a 915Mhz…

  1. Remove the two gray end pieces with a small screwdriver.

  2. Below these two end pieces you will find two Phillips screws, unscrew them.

  3. Split the white parts of each other with a small flat head screwdriver. There are a few slots next to each other that easily come loose.

  4. Make room for the SMA connector in both parts on the USB connector side

  5. Drill a hole in one of the gray end pieces (USB side, there is already a marking on the back)

  6. Screw the SMA connector on the gray plate, perhaps use an extra ring for sturdiness.

  7. If you have the right pigtail you can simply swap the plugs of the antenna, and push the existing plug away between the print and housing.

Follow the photos It is easy

1 Like

Gently pry of the grey top and bottom covers - you can see in pictures just posted there are 4 small lugs holding each in place - doesn’t take much to force/twist to remove You will then see 2 x T5 (very fine star) screws holding assy together - despite using correct screwdriver I managed to strip one of mine! :frowning:
remove, then with a small amount of force, starting at on end of side split you can leverage the halves apart - again 4 lugs hold together which can be forced apart with a little pressure

…he beat me to the post! :slight_smile:

and what cable length, 5 cm or 7cm or longer ?

you sure that’s ok ?? :sweat: