Send messages from the Multiconnect Conduit Gateway to an Adafruit Feather 32u4 end-node


(Aayk) #1

Good afternoon. I am new using LoRaWAN technology.

After many days of investigation and tests I sent a “Hello World” message from the Adafruit Feather 32u4 to a mlinux Multiteconnect Conduit gateway using the LMIC library in Arduino IDE. It works very well.

But now, I am trying to send a message from the Multiconnect Conduit gateway to the Adafruit Feather 32u4.

I have tried using Putty commands:
$ mosquitto_pub -t lora/00:BE:30:6C:25:57:93:94/down -m ‘{ “data”:“aGVsbG8gd29ybGQ=” }’

or

$ nc --udp localhost 1786
lora/00:BE:30:6C:25:57:93:94/down {“data”:“aGVsbG8gd29ybGQ=”}

But in Arduino I only can see that the Adafruit Feather is transmitting but it is not receiving.

I tested in Putty and I received the message from the gateway, so it is working good. The problem is the Adafruit Feather. I have tested many things in Arduino IDE but I have not gotten nothing

(I am using the ABP example of the LMIC library)


(Andy14) #2

Have you tried serial.read?