Trouble finding Dragino Device Address/Other Information

I’m using a Dragino LSN50 and attempting to get the Device Address from it so I can connect it. I’ve followed the guide on the user manual (page 41 is where the AT-Commands are located). Anyways using Serial Port Utility I’ve only been able to get it respond to the command AT+DEUI to give me the device EUI, and that only worked once. Now when attempting to get the Device Address it will occasionally respond with AT_TEST_PARAM_OVERFLOW but I’ve been unable to get it to give me the Device Address. Has anyone else run into this issue and fixed it or have any more advice on what to do?

If the device is setup for OTAA and has not joined yet there probably is no device address. That is assigned during the join.

It won’t respond to the AT+APPKEY command either

For security reasons I would not allow reading the secret key either as it would allow anyone with access to the device to read the secret and start a denial of service attack.
Have you tried programming your own? TTN generates it when you add a new device.

1 Like

The manual says:

Step 1: Create a device in TTN with the OTAA keys from LSN50.
Each LSN50 is shipped with a sticker with the default device EUI as below:

Now, there’s nothing “below” that line. I’d contact Dragino if you don’t want to program new details into the device. (For OTAA you’d need DevEUI, AppEUI and AppKey.) Programming yourself, like @kersing suggested, doesn’t seem too hard either, but the error you’re getting reading the DevEUI is worrying a bit.