TTIGs Report Not Connected in TTN Console

My TTIG has been down for the last 2-3 days (since the recent Major Outage on us-west). It hasn’t come back online since the outage allegedly cleared. I’ve tried unpluggin / replugging it in. I’ve tried re-doing the configuration process. Green light is on solid, but TTN Console says “Not connected”, and my devices data isn’t getting forwarded. There is scarce ability, as far as I know, for diagnosing this further as an administrator of this Gateway. Can anyone help / give guidance on how to get it back up and running?

1 Like

I am in the same boat. There is no way to reconnect with us-west after a day out outage, and the LED is solid green.

1 Like

I was reading the 450+ post thread to fix our TTIG that’s out. Is there any SSH or web interface for debug? I saw there’s a UART, can that be used to restart the packet forwarder?

No, no and no. Power cycling restarts the software.

@KrishnaIyerEaswaran2 can you check?

I’m remote from the TTIG until tomorrow, but on Slack #ops @vicatcu reported that power cycling did not work, nor did a factory reset work.

This thing only has one button and one reset - I think we tried all the permutations pretty quick! Is there any debug information we can provide?

Sorry to reply to myself. I finally found a few threads detailing the same circumstances, it sounds like the TTIG requires some backend “temporary/experimental BasicStation-Bridge” because the v2 stack does not support the BasicStation protocol:

I will message @KrishnaIyerEaswaran2 with my Gateway ID EUI in hopes he can restart the bridge.

@Naia, Please let me know if that gets you over the hurdle, and I will follow suit. I can’t imagine everyone with a TTIG messaging @KrishnaIyerEaswaran2 is a sustainable solution to this problem, though.

Yikes! Just noticed the same problem here. Solid green so I thought it was ok. Looked at the console and no connection for the last 2 days. us-west router.

Ursalink gateway working fine.

With no debugging on these things it may not be the best solution for anything commercial or production I guess.

Keep us updated please.


It is not meant to be. If you invest some time you can read the BasicStation back-end protocol is not supported by TTN Community Network V2. It will be by TTN V3. For now there is a work-around in place which happens to get confused once in a while.

Once TTN v3 is in place debugging can be done at the back-end. From experience most people use that to debug the other gateways as well because getting access and interpreting the messages for the existing packet forwarders requires knowledge a lot of people lack. (Just take a look at the amount of messages by people dumping logs to the forum and asking for help because they can’t figure what is wrong.)

Do you happen to know if the plan is for fielded TTIGs to automagically get support for the v3 protocol when it’s ready for prime-time by way of an over-the-air firmware update at some point?

TTN V3 will support the protocol implemented on the TTIGs so there is no need to update the TTIGs.

1 Like

Hello Everyone,

Just came back from vacations and gave the bridge a kick. Should be working again. Can you let me know via direct message if any of your gateways are still down?


PS: +1 for all of @kersing’s answers. V2 doesn’t natively support Basic Station so we have a temp work around, V3 already supports it natively with v3.1.0 and any firmware updates will be applied automatically.


Thanks, it does seem to be working again at the moment!

My TTIG gateway has been decidedly less effective at forwarding packets to TTN since “the event” in this post (outage from 7/26 - 7/29). I’ve calculated the number of missing reports from one device that reports once every ten minutes and plotted the number of missing reports over time from 7/21 - 8/6, and here’s what it looks like (minutes from start along x-axis):


There’s a pretty obvious increase in the incidence and duration of missing events. Here are histograms of the missing reports before and after the event.


Is it just me or is this compelling evidence representative of a broader experience within (at least) the us-west community?

What’s on the X Axis? What do you mean my “missing events”? Missed uplinks?
Could you please move this to a new post under a new name “TTIG Reliability check” or something?

I’d like to close this post since the reported issue is closed. This helps in better searches for other users.

My endpoint tries to report on a regular 10 minute interval (actually more like 8.2 minutes). The x-axis is minutes from the start of the data. A missing report is implied by the time since last report (i.e. ROUND(deltaT / 8.2) - 1). Sure I’ll move it to here.