Gateway already registered! But i didnt registered it

Hi Team,

I bought a RAK7258 indoor Gateway and followed the SetUp precisely and checked all parameters over and over again. But in the end, I always get the same error after trying to create my Gateway in the ttn console.

"A gateway with EUI AC1F09FFFE052239 is already registered (by you or someone else) as rak-7258fsdf"

“(by you or someone else)” → Definitely not me because this is my first ever Lora Gateway

  "code": 6,
  "message": "error:pkg/identityserver:gateway_eui_taken (a gateway with EUI `AC1F09FFFE052239` is already registered (by you or someone else) as `rak-7258fsdf`)",
  "details": [
      "@type": "",
      "namespace": "pkg/identityserver",
      "name": "gateway_eui_taken",
      "message_format": "a gateway with EUI `{gateway_eui}` is already registered (by you or someone else) as `{gateway_id}`",
      "attributes": {
        "administrative_contact": "chrisx",
        "gateway_eui": "AC1F09FFFE052239",
        "gateway_id": "rak-7258fsdf"
      "correlation_id": "114999cbd03049efadd7e5330ddf724e",
      "code": 6

I already talked with some guys on the RAK Discord, and they mentioned posting my question her.
I’m fairly new to all the TTN and forum stuff, so I hope I posted this in the right place.
If any more information are required to solve my problem I’m happy to provide them.

Thanks in advance,

AC 1F 09 is an OUI prefix belonging to RAK, it seems odd someone would be guessing values in their range, so likely either this gateway was previously tried, or they have an issue in the uniqueness of their assignments.

It is possible to change the number the gateway uses, but a bit tricky and has a little risk of messing things up. If I recall the Ethernet MAC is stored in an early partition, then scripting in the hard to change system partition is going to read that, insert two filler bytes in the middle and put it somewhere that the packet forwarder can get at. Modifying the ultimate value on the overlay partition could work, but would be lost if the gateway gets factory-type reset.


Looks like someone testing something …

can i do anything about that ?
It’s kind of frustrating not being able to connect my gateway to ttn.

Yes, first, after you’ve searched the forum to see all the other posts about this topic, you could ask whoever sold it to you if anyone called chrisx was testing a gateway.

And, after you’ve searched the posts, you’ll see that no one here can help. But the TTI staff on the Slack #support channel can.

It doesn’t look like this gateway ever connected, and we haven’t seen @chrisx since they registered the gateway, so we can assume that the gateway was abandoned. I just released the EUI of the gateway, so you should now be able to register your gateway.


Thanks for the quick respons and action.
My issue is solved now.

Stay safe and healthy!
Kind regards,


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.