Want to move my TTN Gateway to V3

but do not find the Gateway EUI. How can I find (or read back) this EUI?

You can get it from the legacy console : https://v2console.thethingsnetwork.org/gateways

An EUI is not required in V3 if your gateway doesn’t have one.

The Things Kickstarter Gateway doesn’t have an EUI, so you can just leave the field empty.

The EUI of The Things Indoor Gateway can be derived from the code on the sticker on the back of the gateway, but you may want to wait with registering TTIGs on V3 (see Connecting TTIG to TTN V3 - (NOT YET) - #58 by ohlhues).

I’m also struggling with the migration of The Things Kikstarter Gateway.

I can see the GW on the legacy V2 console, so the connection looks okay.

After reading many articles, blog entries and web pages and watching this video I got the impression that the migration will be really simple, just “redirecting” the traffic to the V3 stack by replacing the address of the cluster.
However, I’m not quite sure how to do that as the device configuration page doesn’t have a “cluster server address” input filed (only an account server URL field).

Should I use the CLI tool (ttn-lw-migrate)? If so, is there a guide availbale somewhere?

Can someone point me to the right direction?

Thanks in advance.Screenshot 2021-06-04 at 21.54.15

For the Kickstarter gateway, use The Things Kickstarter Gateway | The Things Stack for LoRaWAN

Many thanks for the fast reply @kersing.

I’ve tried that several times before, but I’ll give it one more go as the GW just updated itself.

Speaking of which, how can one check the firmware version? Maybe it’s not on 1.0.8 yet as outlined in the prerequisites section.

Which server did you specify as the account server on your attempts?

There is a way to get the firmware version of a gateway from the V2 NOC. Check Show firmware version of TTN Gateway

I’ve tried eu1.cloud.thethings.network with and without the https:// prefix.

But maybe the gateway ID sould be defined as <gatewayId>@ttn? I haven’t tried with a tenant ID so far, so I’ll give this a go.

Thanks for the link!

It looks like it’s finally connected to the V3 stack.

I’m unsure which change cured the issue (still unable to figure out the current firmware version, @kersing’s link seems dead), but I’ll share the Gateway Settings I’ve used for future referece:

Gateway ID: <gatewayId>@ttn
Account Server: https://eu1.cloud.thethings.network/
Gateway Key: <apiKey>

Hopefully this will help if someone’s trying to follow The Things Kickstarter Gateway | The Things Stack for LoRaWAN.

Maybe the documention should have a sub-section detailng the registration procedure if one’s to use TTS CE.



Problem is V2 noc now down & out :frowning: Old way from linked thread no longer an option…

I think there may still be a way via “account.things…” I recall seeing at some point that will access data in more limited fashion - hopefully with firmware version…will post back if I find it (need myself for migrating my own TGW!)


Found what I was thnking of

https://account.thethingsnetwork.org/api/v2/gateways/{Gateway-ID} but sadly this doesn’t pull in traffic history (uplinks/downlinks totals) or firmware version in the way full NOC view did :slight_smile: So back to drawing board…

1 Like

I think you can find EUI on the label of your gateway. sometimes it is mac number, add FFFE in the middle of mac number.

hmm, that is the account server…
I could not find that in the docs…
I am not a specialist :slight_smile: just supported The Things Network with the kick starter.
forgive me for not understanding all details and naming of all different components in the architecture.
I still believe in your mission!
But this migration was a bit hard on me

1 Like

Same here. I had a gateway up and running to test an AmbaSat in the lab and in the field.

It suddenly stopped working in mid-June. I’ve spent hours on this trying to get moved over to version 3. “May as well do it now” is what I thought.

I have a Gateway ID, a Gateway Key, An Application EUI, a Device EUI, a Device Address, a network session key, an application session key, a “new” application ID, and a “new” API Key. I am no longer sure of what is what (I thought I knew, but it just doesn’t work) and where these values go. I have tried every combination that looks reasonable. I’ve gotten “new” ones when it seemed like it was instructed.


There are conflicting explanations from different webpages and projects. I’m just trying to get this to work. I believed in the TTN thing and campaigned pretty hard to raise awareness about it. But, it’s not the central piece of the project I’m working on. If I can’t figure it out then how in the world are users going to figure it out?

I already lost one lab volunteer because their data has been missing for nearly a month.


That shouldn’t be caused by V2 to V3 migrations so it might have been better to find the cause of the issues. As that is a last station let’s move on…

It is not that hard if you take a moment or two to think about it. And use the proper documentation which can be found on the TTN website.

What brand gateway are you using and what protocol does it use to talk to the backend?

There is plenty of migration documentation on the TTN website and you could have asked for help on this forum earlier on.

Your current message does tell us anything about what currently works and what doesn’t. Perhaps you can start by telling if the gateway is online in V3 and if not provide the information I asked for above?

Next we can look at the issues you might be having with the node(s).

Users? It’s not a mobile phone service, we are the users. Any one can deploy a device being heard by a community gateway, but it’s not really at appliance level (yet).

Why didn’t your lab volunteer make enquiries the day data stopped?

We get the use of a set of servers for free, the rest is up to us!

1 Like

Question specific to Kickstarter GW. Documentation states cannot change ID., yet searching forums seems you need to if moving from V2 to V3.
Like some others, being a numpty I jumped the gun months ago after receiving several emails with dire warnings from TTN to move to V3. Just hope I have not bricked my GW as now probs with connecting to V3
Reset and Followed the Kick st Docs exactly to connect multiple times but LED3 fast flash which I see may be a key problem or GW already activated.
Question should I try again but use the same ID that I had on V2 ?
Answer: attempted this but “ID already taken”
So what next? Have read and re read every doc and forum . I know that at 75 my brain is getting foggy but I thought I had followed instructions to the letter. Shame as have now got a great aerial site high atop the South Downs if I can get this to work.

@niccoleman, I followed these instructions and the gateway was recognized in the V3 console, I could see connect & disconnect events, but nothing else.

I followed the advice here, to not use @ttn in the gateway ID and it worked! Immediately I started seeing “Receive gateway status” messages in the console.

This with a Kickstarter gateway running Firmware: v1.0.8-846da98b, fresh reset and reconfigure:

  • Gateway ID: my-gateway-name (without @ttn)
  • Account Server: https://nam1.cloud.thethings.network
  • Gateway Key: apiKey created in the V3 console with “Link as Gateway to Gateway Server…” permission


  • Frank


I am not able to connect my TTN Gateway to V3. Firmware is v1.0.8.

HTTP: Starting connection<\r><\n>
HTTPS: Connection Opened: Starting TLS Negotiation<\r><\n>
HTTP: Wait for TLS Connect<\r><\n>
HTTP: TLS Connection Opened: Starting Clear Text Communication<\r><\n>
HTTP: Got 1074 bytes<\r><\n>
MON: SYS Stack size: 2833<\r><\n>
MON: TCPIP Stack size: 3759<\r><\n>
MON: APP Stack size: 4155<\r><\n>
MON: LoRa Stack size: 3909<\r><\n>
MON: heap usage: 265KB (275KB), free: 73KB<\r><\n>
HTTP: Connection Closed<\r><\n>
HTTP: Close active socket 1<\r><\n>
CONF: Parsing response token: HTTP/1.1 400 Bad Request<\r><\n>
ACTI: Failed to parse JSON: -3<\r><\n>
CNFG: Downloading gateway configuration failed<\r><\n>
CNFG: Load online user config state change to 8<\r><\n>
CNFG: Communication ERROR<\r><\n>

That’s what I get with my serial monitor. The third LED is slowly flashing, means that the activation is not working.
I tried the Gateway ID with and without @ttn, different Account-Servers and different Gateway Keys. With V2 I am able to connect.

Please have a look to my screenshot. I am using the gateway ID from the top, and the gateway server address from the bottom. Is that correct?

What could I try? What is the correct way?


If you want to connect to TheThingsNetwork community edition you should use a gateway server address like:
(first part may be different depending on your region)

What worked for me:

  • DON’T set up WiFi on the gateway
  • enter the gateway id WITHOUT @ttn
  • make sure that you copied the ENTIRE API key from the console (you can see it only once in its entirety)

Thanks, but still the same issue.
How could I check if I am using the community edition?

I am using ethernet connection.